]> git.pld-linux.org Git - packages/waf.git/blame - waf.spec
- up to 2.0.19
[packages/waf.git] / waf.spec
CommitLineData
a4eae65c 1Summary: The Waf build system
1a3366fc 2Summary(pl.UTF-8): System budowania Waf
a4eae65c 3Name: waf
f095bc66 4Version: 2.0.19
cf2b81bf 5Release: 1
c9f31fb5 6# note: waf book is on CC-BY-NC-ND (not included in binary package)
a4eae65c
ER
7License: BSD
8Group: Development/Building
00844803 9Source0: http://waf.io/%{name}-%{version}.tar.bz2
f095bc66 10# Source0-md5: 7dfb98532bfc5be19092917c4e268903
9c06b44f 11Patch0: %{name}-path.patch
00844803 12URL: http://waf.io/
c9f31fb5
JB
13BuildRequires: python >= 1:2.6
14BuildRequires: python-modules >= 1:2.6
12557f0e 15BuildRequires: rpm-pythonprov
2110cbf6 16BuildRequires: rpmbuild(macros) >= 1.234
c9f31fb5 17Requires: python(abi) = %{py_ver}
7a16ee04 18BuildArch: noarch
a4eae65c
ER
19BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
20
a4eae65c
ER
21%description
22Waf is a general-purpose build system which was modelled from Scons.
23Though it comes last in the arena of the build systems, we believe
24that Waf is a vastly superior alternative to its competitors
25(Autotools, Scons, Cmake, Ant, etc) for building software,
26
f7ccf166
JR
27%description -l pl.UTF-8
28Waf to system budowania ogólnego przeznaczenia opracowany na podstawie
29Scons. Mimo że pojawił się jako ostatni na arenie systemów budowania,
30autorzy wierzą, że przewyższa alternatywne narzędzia (Autotools,
67f52179
JB
31Scons, Cmake, Ant itp.).
32
a4eae65c
ER
33%prep
34%setup -q
9c06b44f 35%patch0 -p1
a4eae65c 36
5e7a2f5e
JP
37%{__sed} -i -e '1s,/usr/bin/.*python,%{__python},' waf-light waflib/processor.py waflib/extras/javatest.py
38
a4eae65c 39%build
c9f31fb5
JB
40# check waf-light
41extras=
42for f in waflib/extras/*.py ; do
43 tool=$(basename "$f" .py)
44 if [ "$tool" != "__init__" ]; then
45 extras="${extras:+$extras,}$tool"
46 fi
47done
48./waf-light --make-waf --strip --tools="$extras"
a4eae65c
ER
49
50%install
51rm -rf $RPM_BUILD_ROOT
c9f31fb5
JB
52install -d $RPM_BUILD_ROOT%{_datadir}/waf/waflib/{Tools,extras}
53
54cp -p waflib/*.py $RPM_BUILD_ROOT%{_datadir}/waf/waflib
55cp -p waflib/Tools/*.py $RPM_BUILD_ROOT%{_datadir}/waf/waflib/Tools
56cp -p waflib/extras/*.py $RPM_BUILD_ROOT%{_datadir}/waf/waflib/extras
57
58install -D -p waf-light $RPM_BUILD_ROOT%{_bindir}/waf
a4eae65c 59
c9f31fb5
JB
60%py_comp $RPM_BUILD_ROOT%{_datadir}/waf/waflib
61%py_ocomp $RPM_BUILD_ROOT%{_datadir}/waf/waflib
a4eae65c
ER
62
63%clean
64rm -rf $RPM_BUILD_ROOT
65
66%files
67%defattr(644,root,root,755)
cb78d8a7 68%doc ChangeLog README.md
a4eae65c 69%attr(755,root,root) %{_bindir}/waf
c9f31fb5 70%{_datadir}/waf
This page took 0.061997 seconds and 4 git commands to generate.