]> git.pld-linux.org Git - packages/vim.git/blobdiff - vim.spec
add python3 bcond
[packages/vim.git] / vim.spec
index ed449b107ca8591980eabfad4da88ee30c8b1d1d..6105c3cc45a9f131a6119d9f389188be2883eae1 100644 (file)
--- a/vim.spec
+++ b/vim.spec
@@ -4,7 +4,7 @@
 %bcond_without athena          # don't build Athena Widgets-based gvim
 %bcond_without motif           # don't build Motif-based gvim
 %bcond_without gtk             # don't build GTK+-based gvim support
-%bcond_with    gtk3            # use GTK+ 3.x instead of 2.x
+%bcond_without gtk3            # use GTK+ 2.x instead of 3.x
 %bcond_without gnome           # don't build GNOME-based gvim support
 %bcond_without heavy           # don't build heavy (full-featured GNOME-based gvim/vim)
 %bcond_without gui             # don't build any GUI
@@ -12,7 +12,8 @@
 %bcond_without x11             # don't build vimx (non-GUI with X11 clipboard support)
 %bcond_with    lua             # with Lua interp in vim package
 %bcond_with    perl            # with Perl interp in vim package
-%bcond_with    python          # with Python interp in vim package
+%bcond_with    python          # with Python 2 interp in vim package
+%bcond_with    python3         # with Python 3 interp in vim package
 %bcond_with    ruby            # with Ruby interp in vim package
 %bcond_with    tcl             # with Tcl interp
 %bcond_without selinux         # without selinux support
@@ -29,8 +30,8 @@
 # wget ftp://ftp.vim.org/pub/editors/vim/patches/8.0/MD5SUMS -O - | tail -n1 | awk '{print $2}'
 # VCS Commits: https://github.com/vim/vim/commits/master
 
-%define                ver             8.1.0005
-%define                rel             2
+%define                ver             8.2.0011
+%define                rel             1
 Summary:       Vi IMproved - a Vi clone
 Summary(de.UTF-8):     VIsual editor iMproved
 Summary(es.UTF-8):     Editor visual incrementado
@@ -50,7 +51,7 @@ License:      Charityware
 Group:         Applications/Editors/Vim
 #Source0:      ftp://ftp.vim.org/pub/vim/unix/%{name}-%{ver}.tar.bz2
 Source0:       https://github.com/vim/vim/archive/v%{ver}.tar.gz
-# Source0-md5: b758c94c83c3fe9de2f2361be429c941
+# Source0-md5: 9ff52728337b4053fcf11f2a65a19296
 Source1:       http://www.mif.pg.gda.pl/homepages/ankry/man-PLD/%{name}-non-english-man-pages.tar.bz2
 # Source1-md5: bc4d1e115ca506ad7751b9bd2b773a7f
 Source2:       http://skawina.eu.org/mikolaj/usr_doc_pl.zip
@@ -137,6 +138,7 @@ BuildRequires:      gtk+3-devel >= 3.0
 BuildRequires: gtk+2-devel >= 2:2.6.0
 %endif
 %endif
+BuildRequires: libcanberra-devel
 %{?with_gnome:BuildRequires:   libgnomeui-devel >= 2.2.0.1}
 %if %{with selinux} || %{with heavy}
 BuildRequires: libselinux-devel
@@ -152,6 +154,11 @@ BuildRequires:     perl-devel
 %endif
 %if %{with python} || %{with heavy}
 BuildRequires: python-devel >= 2.3
+%endif
+%if %{with python3} || %{with heavy}
+BuildRequires: python3-devel
+%endif
+%if %{with python} || %{with python3} || %{with heavy}
 BuildRequires: rpm-pythonprov
 %endif
 BuildRequires: rpm >= 4.4.9-56
@@ -843,6 +850,7 @@ build() {
                --%{!?with_lua:dis}%{?with_lua:en}able-luainterp \
                --%{!?with_perl:dis}%{?with_perl:en}able-perlinterp \
                --%{!?with_python:dis}%{?with_python:en}able-pythoninterp \
+               --%{!?with_python3:dis}%{?with_python3:en}able-python3interp \
                --%{!?with_ruby:dis}%{?with_ruby:en}able-rubyinterp \
                --%{!?with_tcl:dis}%{?with_tcl:en}able-tclinterp \
                %{!?with_selinux:--disable-selinux} \
@@ -869,6 +877,7 @@ build vim.static \
        --disable-gui \
        --without-x \
        --with-features=small \
+       --disable-canberra \
        --disable-luainterp \
        --disable-perlinterp \
        --disable-pythoninterp \
@@ -876,7 +885,7 @@ build vim.static \
        --disable-tclinterp \
        --disable-cscope \
        --disable-gpm \
-       --disable-multibyte \
+       --enable-multibyte \
        --disable-nls
 
 LDFLAGS="%{rpmldflags}"
@@ -887,6 +896,7 @@ build vim.light \
        --disable-gui \
        --without-x \
        --with-features=small \
+       --disable-canberra \
        --disable-luainterp \
        --disable-perlinterp \
        --disable-pythoninterp \
@@ -900,12 +910,14 @@ build vim.light \
 build vim.ncurses \
        --disable-gui \
        --without-x \
+       --disable-canberra \
        --with-features=huge
 
 %if %{with x11}
 build vimx \
        --disable-gui \
        --with-x \
+       --disable-canberra \
        --with-features=huge
 %endif
 
@@ -915,6 +927,7 @@ build gvim.athena \
        --enable-gui=athena \
        --with-x \
        --enable-fontset \
+       --disable-canberra \
        --disable-gpm \
        --without-gnome
 
@@ -927,6 +940,7 @@ build gvim.motif \
        --with-x \
        --enable-multibyte \
        --enable-fontset \
+       --disable-canberra \
        --disable-gpm \
        --without-gnome
 
@@ -943,6 +957,7 @@ build gvim.gtk \
        --enable-gtk2-check \
 %endif
        --with-x \
+       --disable-canberra \
        --disable-gpm
 
 %endif
@@ -967,8 +982,10 @@ build vim.heavy \
        --enable-luainterp \
        --enable-perlinterp \
        --enable-pythoninterp \
+       --enable-python3interp \
        --enable-rubyinterp \
        --enable-tclinterp \
+       --disable-canberra \
        --disable-gpm
 
 build gvim.heavy \
@@ -980,6 +997,7 @@ build gvim.heavy \
        --enable-luainterp \
        --enable-perlinterp \
        --enable-pythoninterp \
+       --enable-python3interp \
        --enable-rubyinterp \
        --enable-tclinterp \
        --disable-gpm
@@ -1434,7 +1452,6 @@ rm -rf $RPM_BUILD_ROOT
 %lang(ja) %{_datadir}/vim/tutor/tutor.ja.utf-8
 %lang(ko) %{_datadir}/vim/tutor/tutor.ko.euc
 %lang(ko) %{_datadir}/vim/tutor/tutor.ko.utf-8
-%lang(lv) %{_datadir}/vim/tutor/tutor.lv
 %lang(nl) %{_datadir}/vim/tutor/tutor.nl
 %lang(nl) %{_datadir}/vim/tutor/tutor.nl.utf-8
 %lang(nb) %{_datadir}/vim/tutor/tutor.nb
This page took 0.067686 seconds and 4 git commands to generate.