]> git.pld-linux.org Git - packages/tmux.git/blame - tmux.spec
up to 3.3a
[packages/tmux.git] / tmux.spec
CommitLineData
21dfa491
ZU
1# TODO:
2# - vim doesn't detect filetype
73fd702d
JP
3#
4# Conditional build:
5%bcond_without systemd # without system integration
6
0a168b43 7Summary: tmux - a terminal multiplexer
df1e8c4e 8Summary(hu.UTF-8): tmux egy terminál-sokszorozó
0a168b43 9Summary(pl.UTF-8): tmux - multiplekser terminali
df1e8c4e 10Name: tmux
d0a365e4 11Version: 3.3a
e9e307be 12Release: 1
c4f39c44 13License: ISC
df1e8c4e 14Group: Applications/Terminal
1a940cea 15#Source0Download: https://github.com/tmux/tmux/releases
a018f7c2 16Source0: https://github.com/tmux/tmux/releases/download/%{version}/%{name}-%{version}.tar.gz
d0a365e4 17# Source0-md5: 8eee5883b9f6550fa4efaad0c9ec38f3
df1e8c4e 18Source1: %{name}-filedetect.vim
466bc6bc 19Source2: https://raw.githubusercontent.com/keith/tmux.vim/master/syntax/tmux.vim
101ede04 20# Source2-md5: cd1169a1757b515b5c57816d339c6f72
13f42450 21Source3: https://raw.githubusercontent.com/imomaliev/tmux-bash-completion/master/completions/tmux
7a54b8d0 22# Source3-md5: 6d65c0f42c74f61602a399d7bb04a85c
095bed52 23Source4: tmux@.service
a018f7c2 24URL: http://tmux.github.io/
05eab483 25BuildRequires: libevent-devel
ea24db7e 26BuildRequires: libutempter-devel
c4f39c44
JB
27BuildRequires: ncurses-devel >= 5
28BuildRequires: pkgconfig
1a940cea 29BuildRequires: rpmbuild(macros) >= 1.673
73fd702d 30%{?with_systemd:BuildRequires: systemd-devel}
df1e8c4e
ZU
31BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
32
33%description
34tmux is a terminal multiplexer: it enables a number of terminals (or
35windows), each running a separate program, to be created, accessed,
36and controlled from a single screen. tmux may be detached from a
37screen and continue running in the background, then later reattached.
38
39%description -l hu.UTF-8
40tmux egy terminál-sokszorozó: terminálok (vagy ablakok) sokaságát
41hozhatd létre, mindegyikben egy külön program fut, létrehozhatsz,
42csatlakozhatsz és irányíthatod egyetlen képernyőről. tmux
43lecsatlakozhat a képernyőről és folytathatja a futását a háttérben, és
44később újracsatlakozhatsz.
45
0a168b43
JB
46%description -l pl.UTF-8
47tmux to multiplekser terminali: pozwala na tworzenie wielu terminali
48(lub okien) z osobnymi programami, dostęp do nich i sterowanie z
49pojedynczego ekranu. tmux może być odłączony od ekranu i nadal działać
50w tle, a następnie ponownie podłączony.
51
df1e8c4e
ZU
52%package -n vim-syntax-tmux
53Summary: Vim syntax file to tmux config files
54Summary(hu.UTF-8): Vim syntax fájl a tmux konfigurációs fájljához
0a168b43 55Summary(pl.UTF-8): Plik składni Vima dla plików konfiguracyjnych tmuksa
df1e8c4e 56Group: Applications/Editors/Vim
0a168b43 57Requires: vim-rt
df1e8c4e
ZU
58
59%description -n vim-syntax-tmux
60Vim syntax file to tmux config files.
61
62%description -n vim-syntax-tmux -l hu.UTF-8
63Vim syntax fájl a tmux konfigurációs fájljához.
64
ee0f9a2f
ZU
65%package -n bash-completion-tmux
66Summary: Bash completion for tmux
0a168b43 67Summary(pl.UTF-8): Bashowe dopełnianie poleceń dla tmuksa
596f5bca 68Group: Applications/Shells
0a168b43 69Requires: %{name} = %{version}-%{release}
1a940cea 70Requires: bash-completion >= 2.0
ee0f9a2f
ZU
71
72%description -n bash-completion-tmux
73This package provides bash-completion for tmux.
74
0a168b43
JB
75%description -n bash-completion-tmux -l pl.UTF-8
76Ten pakiet dostarcza bashowe dopełnianie składni dla polecenia tmux.
77
df1e8c4e
ZU
78%prep
79%setup -q
df1e8c4e
ZU
80
81%build
c4f39c44 82# note: on Linux use plain glibc functions instead of utf8proc
bdef13e9 83%configure \
73fd702d
JP
84 CPPFLAGS="%{rpmcppflags} -I/usr/include/ncursesw" \
85 %{__enable_disable systemd}
bdef13e9 86
27a56cc0 87%{__make}
df1e8c4e
ZU
88
89%install
90rm -rf $RPM_BUILD_ROOT
91
92%{__make} install \
93 DESTDIR=$RPM_BUILD_ROOT \
94 PREFIX=%{_prefix}
95
96install -d $RPM_BUILD_ROOT%{_datadir}/vim/vimfiles/{ftdetect,syntax}
97install %{SOURCE1} $RPM_BUILD_ROOT%{_datadir}/vim/vimfiles/ftdetect/tmux.vim
466bc6bc 98install %{SOURCE2} $RPM_BUILD_ROOT%{_datadir}/vim/vimfiles/syntax
1a940cea 99install -d $RPM_BUILD_ROOT%{bash_compdir}
efc13735 100sed -e '1s,#!/usr/bin/env bash,#!/bin/bash,' %{SOURCE3} > $RPM_BUILD_ROOT%{bash_compdir}/%{name}
095bed52
JP
101install -d $RPM_BUILD_ROOT%{systemdunitdir}
102install %{SOURCE4} $RPM_BUILD_ROOT%{systemdunitdir}
df1e8c4e
ZU
103
104%clean
105rm -rf $RPM_BUILD_ROOT
106
107%files
108%defattr(644,root,root,755)
13f42450 109%doc CHANGES COPYING README
0a168b43
JB
110%attr(755,root,root) %{_bindir}/tmux
111%{_mandir}/man1/tmux.1*
095bed52 112%{systemdunitdir}/tmux@.service
df1e8c4e
ZU
113
114%files -n vim-syntax-tmux
115%defattr(644,root,root,755)
116%{_datadir}/vim/vimfiles/ftdetect/tmux.vim
117%{_datadir}/vim/vimfiles/syntax/tmux.vim
ee0f9a2f
ZU
118
119%files -n bash-completion-tmux
120%defattr(644,root,root,755)
1a940cea 121%{bash_compdir}/%{name}
This page took 0.250865 seconds and 4 git commands to generate.