]> git.pld-linux.org Git - packages/swish-e.git/blobdiff - swish-e.spec
- fix function name clash with zlib
[packages/swish-e.git] / swish-e.spec
index c69166272744569cd2527fc66f080c9c5e9c127c..e12b64329dff56645aa08ef6db02e360987731e7 100644 (file)
@@ -1,16 +1,25 @@
+#
+# Conditional build:
+%bcond_with    tests           # do not perform "make test"
+
+%define                rel     9
+%define                snap    2014-09-14
+%define                snapver %(echo %{snap} | tr -d '-')
 %include       /usr/lib/rpm/macros.perl
 Summary:       Simple Web Indexing System for Humans - Enhanced
 Summary(pl.UTF-8):     Prosty system indeksowania stron WWW - wersja rozszerzona
 Name:          swish-e
-Version:       2.4.5
-Release:       6
+Version:       2.7.0
+Release:       0.%{snapver}.%{rel}
 License:       GPL/LGPL
 Group:         Applications/Text
-Source0:       http://swish-e.org/distribution/%{name}-%{version}.tar.gz
-# Source0-md5: feae5ca1f5f4352190156b54a19c0153
-Patch0:                %{name}-perl.patch
+#Source0:      http://swish-e.org/distribution/%{name}-%{version}.tar.gz
+Source0:       http://swish-e.org/swish-daily/%{name}-%{version}-%{snap}.tar.gz
+# Source0-md5: c6b918413382ff61eb5e224c8b4c6f7d
+Patch0:                format-security.patch
+Patch1:                namespace.patch
+Patch2:                zlib-clash.patch
 URL:           http://swish-e.org/
-#Icon:         swish-e.xpm
 BuildRequires: libxml2-devel
 BuildRequires: pcre-devel
 BuildRequires: rpm-perlprov
@@ -139,14 +148,16 @@ Static library for swish-e.
 Biblioteka statyczna dla swish-e.
 
 %prep
-%setup -q
+%setup -q -n %{name}-%{version}-%{snap}
 %patch0 -p1
+%patch1 -p1
+%patch2 -p1
 
 %build
 %configure \
        --with-pcre
 %{__make}
-%{__make} test
+%{?with_tests:%{__make} test}
 
 cd perl
 echo skip | \
@@ -160,7 +171,7 @@ echo skip | \
        SWISHBINDIR=../src
 
 %{__make}
-%{__make} test
+%{?with_tests:%{__make} test}
 cd ..
 
 %install
@@ -185,8 +196,8 @@ rm -rf $RPM_BUILD_ROOT
 %defattr(644,root,root,755)
 %attr(755,root,root) %{_bindir}/%{name}
 %attr(755,root,root) %{_libdir}/libswish-e.so.*.*.*
+%attr(755,root,root) %ghost %{_libdir}/libswish-e.so.2
 %dir %{_prefix}/lib/swish-e
-%attr(755,root,root) %{_prefix}/lib/swish-e/swishspider
 %{_mandir}/man?/*
 
 %files doc
@@ -204,7 +215,6 @@ rm -rf $RPM_BUILD_ROOT
 %{perl_vendorarch}/SWISH/*.pm
 %dir %{perl_vendorarch}/auto/SWISH
 %dir %{perl_vendorarch}/auto/SWISH/API
-%{perl_vendorarch}/auto/SWISH/API/*.bs
 %attr(755,root,root) %{perl_vendorarch}/auto/SWISH/API/*.so
 
 %files devel
@@ -213,7 +223,7 @@ rm -rf $RPM_BUILD_ROOT
 %attr(755,root,root) %{_libdir}/libswish-e.so
 %{_libdir}/libswish-e.la
 %{_includedir}/*.h
-%{_pkgconfigdir}/*
+%{_pkgconfigdir}/*.pc
 
 %files static
 %defattr(644,root,root,755)
This page took 0.218917 seconds and 4 git commands to generate.