]> git.pld-linux.org Git - packages/subversion.git/blobdiff - subversion.spec
- drop obsolete and outdated manual inclusion of rpm macros
[packages/subversion.git] / subversion.spec
index 216ccced844211a2b05156797b3aa663c2be8f63..e0963c5ba16141c6b89e243719fc29dda005001a 100644 (file)
@@ -2,15 +2,15 @@
 # Conditional build:
 %bcond_with    net_client_only         # build only net client
 %bcond_without swig                    # disable bindings generation with Swig
-%bcond_without python                  # build without Python bindings (broken)
+%bcond_with    python                  # build without Python bindings (broken)
 %bcond_without csvn                    # build Python csvn bindings
 %bcond_without perl                    # build without Perl bindings
-%bcond_without ruby                    # build without Ruby bindings
+%bcond_with    ruby                    # build without Ruby bindings
 %bcond_without apache                  # build without Apache support (webdav, etc)
 %bcond_without java                    # build without javahl support (Java high-level bindings)
 %bcond_with    tests                   # don't perform "make check"
-%bcond_without kwallet                 # build without kde4 wallet support
-%bcond_without kde                     # build without kde4 support (alias for kwallet)
+%bcond_without kwallet                 # build without kde5 wallet support
+%bcond_without kde                     # build without kde5 support (alias for kwallet)
 %bcond_without gnome                   # build without gnome keyring support
 %bcond_without db                      # disable Subversion Berkeley DB based filesystem library
 %bcond_with    db6                     # allow BDB6 (not tested by upstream, released on AGPL)
 %define        pdir    SVN
 %define        pnam    _Core
 
-%{?with_perl:%include  /usr/lib/rpm/macros.perl}
 Summary:       A Concurrent Versioning system similar to but better than CVS
 Summary(pl.UTF-8):     System kontroli wersji podobny, ale lepszy, niż CVS
 Summary(pt_BR.UTF-8):  Sistema de versionamento concorrente
 Name:          subversion
-Version:       1.9.1
-Release:       1
+Version:       1.13.0
+Release:       3
 License:       Apache v2.0
 Group:         Development/Version Control
 Source0:       http://www.apache.org/dist/subversion/%{name}-%{version}.tar.bz2
-# Source0-md5: 8e879b61fffe3ac0cf16aeae1e8eda32
+# Source0-md5: 3004b4dae18bf45a0b6ea4ef8820064d
 Source1:       %{name}-dav_svn.conf
 Source2:       %{name}-authz_svn.conf
 Source3:       %{name}-svnserve.init
@@ -68,10 +67,12 @@ Patch0:             %{name}-home_etc.patch
 Patch1:                %{name}-DESTDIR.patch
 Patch2:                %{name}-ruby-datadir-path.patch
 Patch3:                %{name}-tests.patch
+Patch4:                x32-libdir.patch
 URL:           http://subversion.apache.org/
 %{?with_apache:BuildRequires:  apache-devel >= 2.4.14}
 BuildRequires: apr-devel >= 1:1.3
 BuildRequires: apr-util-devel >= 1:1.3
+BuildRequires: apr-util-crypto-openssl
 BuildRequires: autoconf >= 2.59
 BuildRequires: automake
 BuildRequires: bison
@@ -79,27 +80,32 @@ BuildRequires:      cyrus-sasl-devel
 %if %{with kwallet} || %{with gnome}
 BuildRequires: dbus-devel
 %endif
-BuildRequires: db-devel >= 4.1.25
 %{!?with_db6:BuildRequires:    db-devel < 6}
+BuildRequires: db-devel >= 4.1.25
 BuildRequires: expat-devel
 BuildRequires: gettext-tools
 %{?with_gnome:BuildRequires:   glib2-devel >= 2.0}
-%{?with_kwallet:BuildRequires: kde4-kdelibs-devel}
+%{?with_kde:BuildRequires:     kf5-kdelibs4support-devel}
+%{?with_kwallet:BuildRequires: kf5-kwallet-devel}
 %{?with_gnome:BuildRequires:   libgnome-keyring-devel}
+%{?with_gnome:BuildRequires:   libsecret-devel}
 BuildRequires: libmagic-devel
-BuildRequires: libtool >= 1.4-9
+BuildRequires: libtool >= 2:2
+BuildRequires: libutf8proc-devel >= 1.3.1-4
+BuildRequires: lz4-devel
 BuildRequires: pkgconfig
 %{?with_csvn:BuildRequires:    python-ctypesgen}
 BuildRequires: rpm-pythonprov
 BuildRequires: rpmbuild(macros) >= 1.656
 BuildRequires: sed >= 4.0
 BuildRequires: serf-devel >= 1.3.4
-BuildRequires: sqlite3-devel >= 3.7.12
+BuildRequires: sqlite3-devel >= 3.8.11.1
 BuildRequires: texinfo
 BuildRequires: which
+BuildRequires: zlib-devel >= 1.2
 %if %{with java}
-BuildRequires: jdk >= 1.5
-BuildRequires: libstdc++-devel
+BuildRequires: jdk >= 1.8
+BuildRequires: libstdc++-devel >= 6:4.7
 %endif
 %if %{with perl}
 BuildRequires: perl-devel >= 1:5.8.0
@@ -176,6 +182,7 @@ Group:              Libraries
 Requires:      apr >= 1:1.3
 Requires:      apr-util >= 1:1.3
 Requires:      serf >= 1.3.4
+Requires:      zlib >= 1.2
 Obsoletes:     libsubversion0
 
 %description libs
@@ -252,7 +259,7 @@ Summary(pt_BR.UTF-8):       Módulos python para acessar os recursos do Subversion
 Group:         Applications
 Requires:      %{name} = %{version}-%{release}
 Requires:      python
-Requires:      python-subversion = %{version}
+%{?with_python:Requires:       python-subversion = %{version}}
 
 %description tools
 Subversion tools and scripts.
@@ -422,17 +429,17 @@ to authenticate using GNOME Keyring.
 Moduł uwierzytelniający dla Subversion pozwalający klientom SVN
 uwierzytelniać się przy użyciu mechanizmu GNOME Keyring.
 
-%package -n kde4-kwallet-subversion
+%package -n kde5-kwallet-subversion
 Summary:       KDE Wallet authentication provider for Subversion
 Summary(pl.UTF-8):     Moduł uwierzytelniający dla Subversion wykorzystujący Portfel KDE
 Group:         X11/Applications
 Requires:      %{name}-libs = %{version}-%{release}
 
-%description -n kde4-kwallet-subversion
+%description -n kde5-kwallet-subversion
 Authentication provider module for Subversion which allows SVN client
 to authenticate using KDE Wallet.
 
-%description -n kde4-kwallet-subversion -l pl.UTF-8
+%description -n kde5-kwallet-subversion -l pl.UTF-8
 Moduł uwierzytelniający dla Subversion pozwalający klientom SVN
 uwierzytelniać się przy użyciu Portfela KDE.
 
@@ -442,6 +449,7 @@ uwierzytelniać się przy użyciu Portfela KDE.
 %patch1 -p1
 %patch2 -p0
 %patch3 -p1
+%patch4 -p1
 
 sed -i -e 's#serf_prefix/lib#serf_prefix/%{_lib}#g' build/ac-macros/serf.m4
 
@@ -554,7 +562,8 @@ install -d $RPM_BUILD_ROOT/etc/{rc.d/init.d,sysconfig,bash_completion.d} \
        $RPM_BUILD_ROOT%{_sysconfdir}/%{name} \
        $RPM_BUILD_ROOT/home/services/subversion{,/repos}
 
-%{__make} install -j1 \
+%{__make} -j1 install \
+       pkgconfig_dir=%{_pkgconfigdir} \
        toolsdir=%{_bindir} \
        DESTDIR=$RPM_BUILD_ROOT \
        APACHE_LIBEXECDIR="$(%{_sbindir}/apxs -q LIBEXECDIR)" \
@@ -567,21 +576,24 @@ install -d $RPM_BUILD_ROOT/etc/{rc.d/init.d,sysconfig,bash_completion.d} \
        swig_pydir=%{py_sitedir}/libsvn \
        swig_pydir_extra=%{py_sitedir}/svn \
 %endif
+       install-tools
+
 %if %{with csvn}
-       install-ctypes-python \
+# manually execute install-ctypes-python target
+cd subversion/bindings/ctypes-python
+%py_install
+cd ../../..
 %endif
-       install-tools
 
 %if %{with ruby}
-%{__make} install -j1 \
+%{__make} -j1 install-swig-rb install-swig-rb-doc \
        SWIG_RB_RI_DATADIR=$RPM_BUILD_ROOT%{ruby_ridir} \
-       DESTDIR=$RPM_BUILD_ROOT \
-       install-swig-rb install-swig-rb-doc
+       DESTDIR=$RPM_BUILD_ROOT
 
 # not our package
 %{__rm} -r $RPM_BUILD_ROOT%{ruby_ridir}/OptionParser
 %{__rm} -r $RPM_BUILD_ROOT%{ruby_ridir}/Time
-%if "%{ruby_version}" >= "2.0"
+%if "%{ruby_abi}" >= "2.0"
 %{__rm} -r $RPM_BUILD_ROOT%{ruby_ridir}/File
 %endif
 %{__rm} $RPM_BUILD_ROOT%{ruby_ridir}/cache.ri
@@ -609,9 +621,9 @@ install -p tools/backup/hot-backup.py $RPM_BUILD_ROOT%{_bindir}/svn-hot-backup
 %endif
 
 # rename not to conflict with standard packages. (are these needed at all?)
-mv $RPM_BUILD_ROOT%{_bindir}/{,svn}diff
-mv $RPM_BUILD_ROOT%{_bindir}/{,svn}diff3
-mv $RPM_BUILD_ROOT%{_bindir}/{,svn}diff4
+%{__mv} $RPM_BUILD_ROOT%{_bindir}/{,svn}diff
+%{__mv} $RPM_BUILD_ROOT%{_bindir}/{,svn}diff3
+%{__mv} $RPM_BUILD_ROOT%{_bindir}/{,svn}diff4
 
 %if %{with python} || %{with csvn}
 %py_ocomp $RPM_BUILD_ROOT%{py_sitedir}
@@ -639,7 +651,7 @@ cp -p tools/examples/*.c $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
 %endif
 %if %{with gnome} || %{with kwallet}
 # dlopened by soname (libsvn_auth_*-1.so.0)
-%{__rm} $RPM_BUILD_ROOT%{_libdir}/libsvn_auth_*-1.{so,la,a}
+%{__rm} $RPM_BUILD_ROOT%{_libdir}/libsvn_auth_*-1.{so,la}
 %endif
 
 %find_lang %{name}
@@ -675,8 +687,8 @@ rm -rf $RPM_BUILD_ROOT
 %post  -n gnome-keyring-subversion -p /sbin/ldconfig
 %postun        -n gnome-keyring-subversion -p /sbin/ldconfig
 
-%post  -n kde4-kwallet-subversion -p /sbin/ldconfig
-%postun        -n kde4-kwallet-subversion -p /sbin/ldconfig
+%post  -n kde5-kwallet-subversion -p /sbin/ldconfig
+%postun        -n kde5-kwallet-subversion -p /sbin/ldconfig
 
 %post svnserve
 /sbin/chkconfig --add svnserve
@@ -725,10 +737,14 @@ fi
 %doc tools/hook-scripts/*.{pl,py,example}
 %doc tools/hook-scripts/mailer/*.{py,example}
 %doc tools/xslt/*
+%attr(755,root,root) %{_bindir}/fsfs-stats
 %attr(755,root,root) %{_bindir}/svn
+%attr(755,root,root) %{_bindir}/svn-mergeinfo-normalizer
 %attr(755,root,root) %{_bindir}/svnadmin
+%attr(755,root,root) %{_bindir}/svnconflict
 %attr(755,root,root) %{_bindir}/svndumpfilter
 %attr(755,root,root) %{_bindir}/svnlook
+%attr(755,root,root) %{_bindir}/svnmover
 %attr(755,root,root) %{_bindir}/svnmucc
 %attr(755,root,root) %{_bindir}/svnrdump
 %attr(755,root,root) %{_bindir}/svnsync
@@ -814,23 +830,31 @@ fi
 %{_libdir}/libsvn_repos-1.la
 %{_libdir}/libsvn_subr-1.la
 %{_libdir}/libsvn_wc-1.la
-%{_npkgconfigdir}/libsvn_client.pc
-%{_npkgconfigdir}/libsvn_delta.pc
-%{_npkgconfigdir}/libsvn_diff.pc
-%{_npkgconfigdir}/libsvn_fs.pc
+%if %{with gnome}
+# only for feature check, linking will fail (no libsvn_auth_gnome_keyring.so)
+%{_pkgconfigdir}/libsvn_auth_gnome_keyring.pc
+%endif
+%if %{with kwallet}
+# only for feature check, linking will fail (no libsvn_auth_kwallet.so)
+%{_pkgconfigdir}/libsvn_auth_kwallet.pc
+%endif
+%{_pkgconfigdir}/libsvn_client.pc
+%{_pkgconfigdir}/libsvn_delta.pc
+%{_pkgconfigdir}/libsvn_diff.pc
+%{_pkgconfigdir}/libsvn_fs.pc
 %if %{without net_client_only}
-%{_npkgconfigdir}/libsvn_fs_base.pc
-%endif
-%{_npkgconfigdir}/libsvn_fs_fs.pc
-%{_npkgconfigdir}/libsvn_fs_util.pc
-%{_npkgconfigdir}/libsvn_fs_x.pc
-%{_npkgconfigdir}/libsvn_ra.pc
-%{_npkgconfigdir}/libsvn_ra_local.pc
-%{_npkgconfigdir}/libsvn_ra_serf.pc
-%{_npkgconfigdir}/libsvn_ra_svn.pc
-%{_npkgconfigdir}/libsvn_repos.pc
-%{_npkgconfigdir}/libsvn_subr.pc
-%{_npkgconfigdir}/libsvn_wc.pc
+%{_pkgconfigdir}/libsvn_fs_base.pc
+%endif
+%{_pkgconfigdir}/libsvn_fs_fs.pc
+%{_pkgconfigdir}/libsvn_fs_util.pc
+%{_pkgconfigdir}/libsvn_fs_x.pc
+%{_pkgconfigdir}/libsvn_ra.pc
+%{_pkgconfigdir}/libsvn_ra_local.pc
+%{_pkgconfigdir}/libsvn_ra_serf.pc
+%{_pkgconfigdir}/libsvn_ra_svn.pc
+%{_pkgconfigdir}/libsvn_repos.pc
+%{_pkgconfigdir}/libsvn_subr.pc
+%{_pkgconfigdir}/libsvn_wc.pc
 %{_includedir}/%{name}-1
 %{_examplesdir}/%{name}-%{version}
 
@@ -864,7 +888,7 @@ fi
 %endif
 
 %if %{with kwallet}
-%files -n kde4-kwallet-subversion
+%files -n kde5-kwallet-subversion
 %defattr(644,root,root,755)
 %attr(755,root,root) %{_libdir}/libsvn_auth_kwallet-1.so.*.*.*
 %attr(755,root,root) %ghost %{_libdir}/libsvn_auth_kwallet-1.so.0
@@ -965,7 +989,7 @@ fi
 %dir %{perl_vendorarch}/auto/SVN
 %dir %{perl_vendorarch}/auto/SVN/*
 %attr(755,root,root) %{perl_vendorarch}/auto/SVN/*/*.so
-%{_mandir}/man3/*.3pm*
+%{_mandir}/man3/SVN::*.3pm*
 %endif
 
 %if %{with ruby}
This page took 0.086447 seconds and 4 git commands to generate.