]> git.pld-linux.org Git - packages/subversion.git/blobdiff - subversion.spec
update source url
[packages/subversion.git] / subversion.spec
index a5da29802e3b3baa3217cc8d99a18cb475562ade..9650f3c548627e996bff254ad0f3e519d3875d5a 100644 (file)
@@ -6,22 +6,34 @@
 %bcond_without neon                    # use serf instead of neon
 %bcond_without swig                    # disable bindings generation with Swig
 %bcond_without python                  # build without Python bindings (broken)
-%bcond_without csvn                    # build Python csvn bindings
 %bcond_without perl                    # build without Perl bindings
-%bcond_without ruby                    # build without Ruby bindings
 %bcond_without apache                  # build without Apache support (webdav, etc)
-%bcond_without javahl                  # build without javahl support (Java high-level bindings)
 %bcond_without tests                   # don't perform "make check"
 %bcond_without kwallet                 # build without kde4 wallet support
-%bcond_without kde                             # build without kde4 support (alias for kwallet)
-%bcond_without gnome                   # build without gnome keyring support
 %bcond_without db                              # disable Subversion Berkeley DB based filesystem library
 
+%if "%{pld_release}" == "ac"
+%bcond_with    csvn                    # build Python csvn bindings
+%bcond_with    gnome                   # build without gnome keyring support
+%bcond_with    javahl                  # build without javahl support (Java high-level bindings)
+%bcond_with    kde                             # build without kde4 support (alias for kwallet)
+%bcond_with    ruby                    # build without Ruby bindings
+%else
+%bcond_without csvn                    # build Python csvn bindings
+%bcond_without gnome                   # build without gnome keyring support
+%bcond_without javahl                  # build without javahl support (Java high-level bindings)
+%bcond_without kde                             # build without kde4 support (alias for kwallet)
+%bcond_without ruby                    # build without Ruby bindings
+%endif
+
 %if %{with net_client_only}
 %undefine      with_apache
 %undefine      with_db
 %undefine      with_swig
 %undefine      with_javahl
+%undefine      with_csvn
+%undefine      with_gnome
+%undefine      with_kde
 %endif
 
 %if %{without swig}
@@ -35,7 +47,7 @@
 %endif
 
 %if %{without python} && %{without perl} && %{without ruby}
-%define                without_swig    1
+%undefine      with_swig
 %endif
 
 %define        apxs    /usr/sbin/apxs
@@ -52,12 +64,12 @@ Summary:    A Concurrent Versioning system similar to but better than CVS
 Summary(pl.UTF-8):     System kontroli wersji podobny, ale lepszy, niż CVS
 Summary(pt_BR.UTF-8):  Sistema de versionamento concorrente
 Name:          subversion
-Version:       1.6.17
+Version:       1.6.23
 Release:       1
 License:       Apache/BSD-like
 Group:         Development/Version Control
-Source0:       http://subversion.tigris.org/downloads/%{name}-%{version}.tar.bz2
-# Source0-md5: 81e5dc5beee4b3fc025ac70c0b6caa14
+Source0:       http://archive.apache.org/dist/subversion/%{name}-%{version}.tar.bz2
+# Source0-md5: 5d621281ce9d3448e1437cb006331f57
 Source1:       %{name}-dav_svn.conf
 Source2:       %{name}-authz_svn.conf
 Source3:       %{name}-svnserve.init
@@ -71,12 +83,14 @@ Patch1:             %{name}-DESTDIR.patch
 Patch2:                %{name}-ruby-datadir-path.patch
 Patch3:                %{name}-tests.patch
 URL:           http://subversion.apache.org/
+%{?with_apache:BuildRequires:  apache-devel < 2.4}
 %{?with_apache:BuildRequires:  apache-devel >= 2.2.0-8}
 BuildRequires: autoconf
 BuildRequires: automake
 BuildRequires: db-devel >= 4.1.25
 BuildRequires: libtool
-BuildRequires: rpmbuild(macros) >= 1.583
+BuildRequires: rpm >= 4.4.9-56
+BuildRequires: rpmbuild(macros) >= 1.656
 %if %{with perl}
 BuildRequires: perl-devel >= 1:5.8.0
 BuildRequires: rpm-perlprov >= 4.1-13
@@ -127,7 +141,10 @@ BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
 %define                apacheconfdir   %(%{apxs} -q SYSCONFDIR 2>/dev/null)/conf.d
 %define                apachelibdir    %(%{apxs} -q LIBEXECDIR 2>/dev/null)
 
-%define                skip_post_check_so      libsvn_swig_py-1.so.* libsvn_swig_perl-1.so.*
+%define                skip_post_check_so      libsvn_swig_py-1.so.* libsvn_swig_perl-1.so.* libsvn_fs-1.so.0.0.0
+# libsvn_fs-1.so.0.0.0  - "apr_uuid_parse" symbol
+
+%define                filterout_ld    -Werror=format-security
 
 %description
 The goal of the Subversion project is to build a version control
@@ -250,8 +267,8 @@ Summary:    Subversion tools and scripts
 Summary(pl.UTF-8):     Narzędzia oraz skrypty dla subversion
 Summary(pt_BR.UTF-8):  Módulos python para acessar os recursos do Subversion
 Group:         Applications
-%pyrequires_eq python
 Requires:      %{name} = %{version}-%{release}
+Requires:      python
 Requires:      python-subversion = %{version}
 
 %description tools
@@ -298,8 +315,8 @@ Summary:    Subversion Python bindings
 Summary(pl.UTF-8):     Dowiązania do Subversion dla Pythona
 Summary(pt_BR.UTF-8):  Módulos Python para acessar os recursos do Subversion
 Group:         Development/Languages/Python
-%pyrequires_eq python
 Requires:      %{name}-libs = %{version}-%{release}
+Requires:      python
 Obsoletes:     subversion-python
 
 %description -n python-subversion
@@ -316,8 +333,8 @@ Summary:    CTypes Subversion Python bindings
 Summary(pl.UTF-8):     Dowiązania do Subversion dla Pythona
 Summary(pt_BR.UTF-8):  Módulos Python para acessar os recursos do Subversion
 Group:         Development/Languages/Python
-%pyrequires_eq python
 Requires:      %{name}-libs = %{version}-%{release}
+Requires:      python
 
 %description -n python-csvn
 Subversion CTypes Python bindings.
@@ -451,7 +468,11 @@ chmod +x ./autogen.sh && ./autogen.sh
 %if %{without swig}
        --without-swig \
 %endif
-%if %{without ruby}
+%if %{with ruby}
+       svn_cv_ruby_sitedir_libsuffix="" \
+       svn_cv_ruby_sitedir_archsuffix="" \
+       --with-ruby-sitedir=%{ruby_vendorarchdir} \
+%else
        ac_cv_path_RUBY=none \
 %endif
 %if %{with csvn}
@@ -605,7 +626,7 @@ cp -p tools/examples/*.c $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
 %if %{with swig}
 %{__rm} $RPM_BUILD_ROOT%{_libdir}/libsvn_swig*.{la,a}
 %if %{with ruby}
-%{__rm} $RPM_BUILD_ROOT%{_libdir}/ruby/site_ruby/*/*/svn/ext/*.la
+%{__rm} $RPM_BUILD_ROOT%{ruby_vendorarchdir}/svn/ext/*.la
 %endif
 %endif
 %if %{with gnome} || %{with kwallet}
@@ -886,11 +907,10 @@ fi
 %attr(755,root,root) %{_libdir}/libsvn_swig_ruby-1.so.*.*.*
 %attr(755,root,root) %ghost %{_libdir}/libsvn_swig_ruby-1.so.0
 %attr(755,root,root) %{_libdir}/libsvn_swig_ruby-1.so
-%dir %{ruby_sitelibdir}/svn
-%{ruby_sitelibdir}/svn/*.rb
-%dir %{ruby_sitearchdir}/svn
-%dir %{ruby_sitearchdir}/svn/ext
-%attr(755,root,root) %{ruby_sitearchdir}/svn/ext/*.so
+%dir %{ruby_vendorarchdir}/svn
+%{ruby_vendorarchdir}/svn/*.rb
+%dir %{ruby_vendorarchdir}/svn/ext
+%attr(755,root,root) %{ruby_vendorarchdir}/svn/ext/*.so
 %{ruby_ridir}/Svn
 %endif
 
This page took 0.045453 seconds and 4 git commands to generate.