]> git.pld-linux.org Git - packages/subversion.git/blobdiff - subversion.spec
- no ruby-devel on x32
[packages/subversion.git] / subversion.spec
index 22be99a02fd6e013411986e77d69281ade75244c..6165a066b002f33def27cfd14fcdaf584fd2792d 100644 (file)
@@ -6,20 +6,28 @@
 %bcond_without perl                    # build without Perl bindings
 %bcond_without ruby                    # build without Ruby bindings
 %bcond_without apache                  # build without Apache support (webdav, etc)
-%bcond_without javahl                  # build without javahl support (Java high-level bindings)
+%bcond_without java                    # build without javahl support (Java high-level bindings)
 %bcond_without tests                   # don't perform "make check"
 %bcond_without kwallet                 # build without kde4 wallet support
 %bcond_without kde                     # build without kde4 support (alias for kwallet)
 %bcond_without gnome                   # build without gnome keyring support
 %bcond_without db                      # disable Subversion Berkeley DB based filesystem library
+%bcond_with    db6                     # allow BDB6 (not tested by upstream, released on AGPL)
 
-# for AC: --without csvn,gnome,javahl,kde,ruby
+# for AC: --without csvn,gnome,java,kde,ruby
+
+%ifarch x32
+%undefine      with_ruby
+%endif
 
 %if %{with net_client_only}
 %undefine      with_apache
 %undefine      with_db
 %undefine      with_swig
-%undefine      with_javahl
+%undefine      with_java
+%undefine      with_csvn
+%undefine      with_gnome
+%undefine      with_kde
 %endif
 
 %if %{without swig}
@@ -45,12 +53,12 @@ Summary:    A Concurrent Versioning system similar to but better than CVS
 Summary(pl.UTF-8):     System kontroli wersji podobny, ale lepszy, niż CVS
 Summary(pt_BR.UTF-8):  Sistema de versionamento concorrente
 Name:          subversion
-Version:       1.8.1
+Version:       1.8.11
 Release:       1
 License:       Apache v2.0
 Group:         Development/Version Control
-Source0:       http://www.idg.pl/mirrors/apache/subversion/%{name}-%{version}.tar.bz2
-# Source0-md5: f2ee0471b8a560f5efa0f2349d9c9ab9
+Source0:       http://www.apache.org/dist/subversion/%{name}-%{version}.tar.bz2
+# Source0-md5: 766a89bbbb388f8eb76166672d3b9e49
 Source1:       %{name}-dav_svn.conf
 Source2:       %{name}-authz_svn.conf
 Source3:       %{name}-svnserve.init
@@ -75,8 +83,9 @@ BuildRequires:        cyrus-sasl-devel
 BuildRequires: dbus-devel
 %endif
 BuildRequires: db-devel >= 4.1.25
+%{!?with_db6:BuildRequires:    db-devel < 6}
 BuildRequires: expat-devel
-BuildRequires: gettext-devel
+BuildRequires: gettext-tools
 %{?with_kwallet:BuildRequires: kde4-kdelibs-devel}
 %{?with_gnome:BuildRequires:   libgnome-keyring-devel}
 BuildRequires: libmagic-devel
@@ -86,11 +95,11 @@ BuildRequires:      pkgconfig
 BuildRequires: rpm-pythonprov
 BuildRequires: rpmbuild(macros) >= 1.656
 BuildRequires: sed >= 4.0
+BuildRequires: serf-devel >= 1.2.1
 BuildRequires: sqlite3-devel >= 3.6.18
 BuildRequires: texinfo
 BuildRequires: which
-BuildRequires: serf-devel >= 1.2.1
-%if %{with javahl}
+%if %{with java}
 BuildRequires: jdk >= 1.5
 BuildRequires: libstdc++-devel
 %endif
@@ -106,6 +115,7 @@ BuildRequires:      swig-python >= 1.3.24
 %if %{with ruby}
 BuildRequires: rpm-rubyprov
 BuildRequires: ruby-devel >= 1:1.8.2
+BuildRequires: ruby-irb
 BuildRequires: ruby-rubygems
 BuildRequires: swig-ruby >= 1.3.24
 %endif
@@ -181,6 +191,7 @@ Summary(pt_BR.UTF-8):       Arquivos de desenvolvimento para o Subversion
 Group:         Development/Libraries
 Requires:      %{name}-libs = %{version}-%{release}
 Requires:      apr-util-devel >= 1:1.0.0
+Requires:      serf-devel >= 1.2.1
 Obsoletes:     libsubversion0-devel
 
 %description devel
@@ -256,6 +267,9 @@ Group:              Applications/Shells
 Requires:      %{name} = %{version}-%{release}
 Requires:      bash-completion
 Conflicts:     %{name}-tools <= 1.1.0-0.rc6.1
+%if "%{_rpmversion}" >= "5"
+BuildArch:     noarch
+%endif
 
 %description -n bash-completion-subversion
 Bash completion for subversion.
@@ -444,6 +458,7 @@ chmod +x ./autogen.sh && ./autogen.sh
        --disable-mod-activation \
 %if %{with db}
        --with-berkeley-db="db.h:%{_includedir}:%{_libdir}:db" \
+       %{?with_db6:--enable-bdb6} \
 %else
        --without-berkeley-db \
 %endif
@@ -466,7 +481,7 @@ chmod +x ./autogen.sh && ./autogen.sh
 %if %{with csvn}
        --with-ctypesgen=%{_bindir}/ctypesgen.py \
 %endif
-%if %{with javahl}
+%if %{with java}
        --enable-javahl \
        --with-jdk="%{java_home}" \
        --without-jikes \
@@ -505,7 +520,7 @@ cd subversion/bindings/swig/perl/native
 %{__make} -j1
 cd -
 %endif
-%if %{with javahl}
+%if %{with java}
 %{__make} -j1 javahl \
        javahl_javadir="%{_javadir}"
 %endif
@@ -543,7 +558,7 @@ install -d $RPM_BUILD_ROOT/etc/{rc.d/init.d,sysconfig,bash_completion.d} \
        toolsdir=%{_bindir} \
        DESTDIR=$RPM_BUILD_ROOT \
        APACHE_LIBEXECDIR="$(%{_sbindir}/apxs -q LIBEXECDIR)" \
-%if %{with javahl}
+%if %{with java}
        install-javahl \
        javahl_javadir="%{_javadir}" \
 %endif
@@ -559,12 +574,16 @@ install -d $RPM_BUILD_ROOT/etc/{rc.d/init.d,sysconfig,bash_completion.d} \
 
 %if %{with ruby}
 %{__make} install -j1 \
+       SWIG_RB_RI_DATADIR=$RPM_BUILD_ROOT%{ruby_ridir} \
        DESTDIR=$RPM_BUILD_ROOT \
-       install-swig-rb install-swig-rb-doc \
+       install-swig-rb install-swig-rb-doc
 
 # not our package
 %{__rm} -r $RPM_BUILD_ROOT%{ruby_ridir}/OptionParser
 %{__rm} -r $RPM_BUILD_ROOT%{ruby_ridir}/Time
+%if "%{ruby_version}" >= "2.0"
+%{__rm} -r $RPM_BUILD_ROOT%{ruby_ridir}/File
+%endif
 %{__rm} $RPM_BUILD_ROOT%{ruby_ridir}/cache.ri
 %{__rm} $RPM_BUILD_ROOT%{ruby_ridir}/created.rid
 %endif
@@ -609,7 +628,7 @@ cp -p tools/examples/*.py $RPM_BUILD_ROOT%{_examplesdir}/python-%{name}-%{versio
 cp -p tools/client-side/bash_completion $RPM_BUILD_ROOT/etc/bash_completion.d/%{name}
 cp -p tools/examples/*.c $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
 
-%if %{with javahl}
+%if %{with java}
 %{__rm} $RPM_BUILD_ROOT%{_libdir}/libsvnjavahl*.{la,a}
 %endif
 %if %{with swig}
@@ -873,7 +892,7 @@ fi
 
 %endif # net_client_only
 
-%if %{with javahl}
+%if %{with java}
 %files -n java-subversion
 %defattr(644,root,root,755)
 %attr(755,root,root) %{_libdir}/libsvnjavahl-1.so.*.*.*
@@ -921,7 +940,6 @@ fi
 %dir %{perl_vendorarch}/auto/SVN
 %dir %{perl_vendorarch}/auto/SVN/*
 %attr(755,root,root) %{perl_vendorarch}/auto/SVN/*/*.so
-%{perl_vendorarch}/auto/SVN/*/*.bs
 %{_mandir}/man3/*.3pm*
 %endif
 
This page took 0.032562 seconds and 4 git commands to generate.