]> git.pld-linux.org Git - packages/subversion.git/blame - subversion.spec
- rel 3
[packages/subversion.git] / subversion.spec
CommitLineData
1f630180 1# TODO:
1930bef0 2# - remove net_client_only and add db bcond (then without apache and
3# without db => net_client_only - spec will be more simpler, I think)
4#
bab73684 5# Conditional build:
bc526ca4 6%bcond_with net_client_only # build only net client
0905b458 7%bcond_without python # build without python bindings
8%bcond_without perl # build without perl bindings
9%bcond_without apache # build without apache support (webdav, etc)
7b27380f 10#
b56474ff 11%{!?with_net_client_only:%include /usr/lib/rpm/macros.perl}
f4070f5f 12%define apxs /usr/sbin/apxs
1f630180
ER
13%define pdir SVN
14%define pnam _Core
67cb9518 15Summary: A Concurrent Versioning system similar to but better than CVS
abe3c421
ER
16Summary(pl.UTF-8): System kontroli wersji podobny, ale lepszy, niż CVS
17Summary(pt_BR.UTF-8): Sistema de versionamento concorrente
93b78127 18Name: subversion
a98bac96 19Version: 1.4.3
1fbcfc84 20Release: 3
93b78127
AM
21License: Apache/BSD Style
22Group: Development/Version Control
e30588c4 23Source0: http://subversion.tigris.org/downloads/%{name}-%{version}.tar.gz
a98bac96 24# Source0-md5: 6b991b63e3e1f69670c9e15708e40176
93b78127 25Source1: %{name}-dav_svn.conf
65318afa 26Source2: %{name}-authz_svn.conf
b56474ff
AM
27Source3: %{name}-svnserve.init
28Source4: %{name}-svnserve.sysconfig
ed6210a2 29Patch0: %{name}-home_etc.patch
d4bccc60 30Patch1: %{name}-DESTDIR.patch
3eab78e4 31Patch2: %{name}-neon.patch
93b78127 32URL: http://subversion.tigris.org/
4945947e
AM
33%if %{with net_client_only}
34%global apache_modules_api 0
35%else
f2a757d6 36%{?with_apache:BuildRequires: apache-devel >= 2.2.0-8}
7b27380f 37BuildRequires: automake
3817faf5 38BuildRequires: db-devel >= 4.1.25
e8d9186f 39BuildRequires: rpmbuild(macros) >= 1.268
0905b458 40%if %{with perl}
522a69b4 41BuildRequires: perl-devel >= 1:5.8.0
42BuildRequires: rpm-perlprov >= 4.1-13
15f9818d 43BuildRequires: swig-perl >= 1.3.24
536b3fd3 44%endif
0905b458 45%endif
16429189 46BuildRequires: apr-devel >= 1:1.0.0
a6ecf312 47BuildRequires: apr-util-devel >= 1:1.2.8-3
b0a7a5b2 48BuildRequires: autoconf >= 2.59
79d8c53c 49BuildRequires: bison
93b78127 50BuildRequires: expat-devel
86ea8fde 51BuildRequires: gettext-devel
f4e6a380 52BuildRequires: libtool >= 1.4-9
bd3c99a8 53BuildRequires: neon-devel >= 0.26.0
0905b458 54%if %{with python}
53855fbf 55BuildRequires: python >= 2.2
500c99c5 56BuildRequires: python-devel >= 2.2
ed6210a2 57BuildRequires: python-modules >= 2.2
1f16145f 58BuildRequires: sed >= 4.0
15f9818d 59BuildRequires: swig-python >= 1.3.24
0905b458 60%endif
93b78127 61BuildRequires: texinfo
7b35d179 62BuildRequires: which
93794e7c
JR
63# update -neon patch before messing with this BC
64BuildConflicts: neon-devel > 0.26.3
027f8ebe 65Requires: %{name}-libs = %{version}-%{release}
93b78127
AM
66BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
67
f4070f5f
ER
68%define _apachelibdir %(%{apxs} -q LIBEXECDIR 2>/dev/null)
69%define _libexecdir %{_libdir}/svn
93b78127
AM
70
71%description
72The goal of the Subversion project is to build a version control
73system that is a compelling replacement for CVS in the open source
74community.
75
76Our goals are:
77- All current CVS features.
78- Directories, renames, and file meta-data are versioned.
79- Symbolic links, etc, are supported
80- Commits are truly atomic.
81- Branching and tagging are cheap (constant time) operations
82- Repeated merges are handled gracefully
83- Support for plug-in client side diff programs
84- Natively client/server
85- Client/server protocol sends diffs in both directions
86- Costs are proportional to change size, not project size
87- Internationalization
88- Progressive multi-lingual support
89
aa59005f 90%description -l pl.UTF-8
93b78127
AM
91Celem projektu Subversion jest stworzenie systemu kontroli wersji jako
92zamiennika dla CVS.
93
94Cele projektu to:
aa59005f
JR
95- Wszystkie aktualne możliwości CVS.
96- Katalogi, zmiany nazw oraz meta-dane plików są wersjonowane.
97- Wsparcie dla linków symbolicznych itp.
98- Commity są w pełni atomowe.
99- Branchowanie oraz tagowanie są tanimi (stałymi w czasie) operacjami.
100- Powtarzające merge.
101- Wsparcie dla pluginów diff'a po stronie klienta.
93b78127 102- Natywny klient/serwer.
aa59005f 103- Klient/Serwer przesyłają diffy w obu kierunkach.
93b78127
AM
104- Koszty proporcjonalne do rozmiaru zmiany, a nie rozmiaru projektu.
105- Internacjonalizacja.
aa59005f 106- Postępujące wsparcie dla wielu języków.
93b78127 107
aa59005f
JR
108%description -l pt_BR.UTF-8
109O objetivo do projeto Subversion é construir um sistema de controle de
110versões que seja um substituto para o CVS (Concurrent Versioning
92066deb 111System) na comunidade opensource, fornecendo grandes melhorias.
112
f4e6a380
AM
113%package libs
114Summary: Subversion libraries and modules
abe3c421 115Summary(pl.UTF-8): Biblioteka subversion oraz ładowalne moduły
f4e6a380 116Group: Libraries
e30588c4 117Requires: neon >= 0.24.7
53855fbf 118Obsoletes: libsubversion0
f4e6a380
AM
119
120%description libs
121Subversion libraries and modules.
122
aa59005f
JR
123%description libs -l pl.UTF-8
124Biblioteka subversion oraz ładowalne moduły.
f4e6a380 125
93b78127
AM
126%package devel
127Summary: Header files and develpment documentation for subversion
abe3c421
ER
128Summary(pl.UTF-8): Pliki nagłówkowe i dokumetacja do subversion
129Summary(pt_BR.UTF-8): Arquivos de desenvolvimento para o Subversion
93b78127 130Group: Development/Libraries
9cb7e099 131Requires: %{name}-libs = %{version}-%{release}
c5b1d686 132Requires: apr-util-devel >= 1:1.0.0
e30588c4 133Requires: neon-devel >= 0.24.7
12cf252c 134Obsoletes: libsubversion0-devel
93b78127
AM
135
136%description devel
137Header files and develpment documentation for subversion.
138
aa59005f
JR
139%description devel -l pl.UTF-8
140Pliki nagłówkowe i dokumetacja do subversion.
93b78127 141
aa59005f
JR
142%description devel -l pt_BR.UTF-8
143Este pacote provê os arquivos necessários para desenvolvedores
92066deb 144interagirem com o Subversion.
145
93b78127
AM
146%package static
147Summary: Static subversion library
abe3c421
ER
148Summary(pl.UTF-8): Biblioteka statyczna subversion
149Summary(pt_BR.UTF-8): Sistema de versionamento concorrente
93b78127
AM
150Group: Development/Libraries
151Requires: %{name}-devel = %{version}
12cf252c 152Obsoletes: libsubversion0-static-devel
93b78127
AM
153
154%description static
155Static subversion library.
156
aa59005f 157%description static -l pl.UTF-8
93b78127
AM
158Biblioteka statyczna subversion.
159
aa59005f
JR
160%description static -l pt_BR.UTF-8
161Este pacote provê um cliente estático do subversion.
92066deb 162
b56474ff
AM
163%package svnserve
164Summary: Subversion svnserve
abe3c421 165Summary(pl.UTF-8): Subversion svnserve
b56474ff 166Group: Networking/Daemons
3817faf5 167Requires(post,preun): /sbin/chkconfig
9cb7e099 168Requires: %{name} = %{version}-%{release}
7b27380f 169Requires: rc-scripts
b56474ff
AM
170
171%description svnserve
172Subversion svnserve server.
173
aa59005f 174%description svnserve -l pl.UTF-8
b56474ff
AM
175Serwer subversion svnserve.
176
4bbdbbf8
AM
177%package tools
178Summary: Subversion tools and scripts
abe3c421
ER
179Summary(pl.UTF-8): Narzędzia oraz skrypty dla subversion
180Summary(pt_BR.UTF-8): Módulos python para acessar os recursos do Subversion
4bbdbbf8 181Group: Applications
4bbdbbf8 182%pyrequires_eq python
7b27380f 183Requires: %{name} = %{version}-%{release}
1271c9bd 184Requires: python-rcsparse >= 0.1-0.20031026.0
4bbdbbf8
AM
185Requires: python-subversion = %{version}
186
187%description tools
188Subversion tools and scripts.
189
aa59005f
JR
190%description tools -l pl.UTF-8
191Narzędzia oraz skrypty dla subversion.
4bbdbbf8 192
fe5bb6bb 193%package -n bash-completion-subversion
194Summary: bash completion for subversion
abe3c421 195Summary(pl.UTF-8): Dopełnienia basha dla subversion
fe5bb6bb 196Group: Applications/Shells
e30588c4 197Requires: %{name} = %{version}-%{release}
53855fbf 198Requires: bash-completion
e30588c4 199Conflicts: %{name}-tools <= 1.1.0-0.rc6.1
fe5bb6bb 200
201%description -n bash-completion-subversion
202Bash completion for subversion.
203
aa59005f
JR
204%description -n bash-completion-subversion -l pl.UTF-8
205Dopełnienia basha dla subversion.
fe5bb6bb 206
fa3ff1b2 207%package -n python-subversion
f4e6a380 208Summary: Subversion python bindings
abe3c421
ER
209Summary(pl.UTF-8): Dowiązania do subversion dla pythona
210Summary(pt_BR.UTF-8): Módulos python para acessar os recursos do Subversion
f4e6a380 211Group: Development/Languages/Python
f4e6a380 212%pyrequires_eq python
9cb7e099 213Requires: %{name}-libs = %{version}-%{release}
53855fbf 214Obsoletes: subversion-python
f4e6a380 215
fa3ff1b2 216%description -n python-subversion
f4e6a380
AM
217Subversion python bindings.
218
aa59005f
JR
219%description -n python-subversion -l pl.UTF-8
220Dowiązania do subversion dla pythona.
f4e6a380 221
aa59005f
JR
222%description -n python-subversion -l pt_BR.UTF-8
223Módulos python para acessar os recursos do Subversion.
92066deb 224
b56474ff
AM
225%package -n perl-subversion
226Summary: Subversion perl bindings
abe3c421
ER
227Summary(pl.UTF-8): Dowiązania do subversion dla perla
228Summary(pt_BR.UTF-8): Módulos perl para acessar os recursos do Subversion
b56474ff 229Group: Development/Languages/Perl
9cb7e099 230Requires: %{name}-libs = %{version}-%{release}
53855fbf 231Obsoletes: subversion-perl
b56474ff
AM
232
233%description -n perl-subversion
234Subversion perl bindings.
235
aa59005f
JR
236%description -n perl-subversion -l pl.UTF-8
237Dowiązania do subversion dla perl.
b56474ff 238
aa59005f
JR
239%description -n perl-subversion -l pt_BR.UTF-8
240Módulos perl para acessar os recursos do Subversion.
b56474ff 241
93b78127
AM
242%package -n apache-mod_dav_svn
243Summary: Apache module: Subversion Server
abe3c421 244Summary(pl.UTF-8): Moduł apache: Serwer Subversion
93b78127 245Group: Networking/Daemons
7b27380f 246Requires: %{name} = %{version}-%{release}
53855fbf 247Requires: apache(modules-api) = %apache_modules_api
7887b1ac 248Requires: apache-mod_dav
93b78127
AM
249
250%description -n apache-mod_dav_svn
251Apache module: Subversion Server.
252
aa59005f
JR
253%description -n apache-mod_dav_svn -l pl.UTF-8
254Moduł apache: Serwer Subversion.
93b78127 255
65318afa
AF
256%package -n apache-mod_authz_svn
257Summary: Apache module: Subversion Server - path-based authorization
abe3c421 258Summary(pl.UTF-8): Moduł apache: autoryzacja na podstawie ścieżki dla serwera Subversion
65318afa 259Group: Networking/Daemons
53855fbf 260Requires: apache(modules-api) = %apache_modules_api
9cb7e099 261Requires: apache-mod_dav_svn = %{version}-%{release}
65318afa
AF
262
263%description -n apache-mod_authz_svn
264Apache module: Subversion Server - path-based authorization.
265
aa59005f
JR
266%description -n apache-mod_authz_svn -l pl.UTF-8
267Moduł apache: autoryzacja na podstawie ścieżki dla serwera Subversion.
e23909be 268
93b78127 269%prep
281e2246 270%setup -q
e30588c4 271rm -rf apr apr-util neon
ed6210a2 272%patch0 -p0
d4bccc60 273%patch1 -p1
3eab78e4 274%patch2 -p1
027f8ebe 275
93b78127 276%build
a7bcb345 277cp -f /usr/share/automake/config.sub ac-helpers
67cb9518 278chmod +x ./autogen.sh && ./autogen.sh
8a3d9172 279
fa3ff1b2 280# don't enable dso - currently it's broken
93b78127 281%configure \
5dfeafd7
AM
282 --with-editor=vi \
283 --with-zlib \
497058f9
AM
284 --with-python=%{_bindir}/python \
285 --with-perl5=%{_bindir}/perl \
536b3fd3
AM
286%if %{with net_client_only}
287 --without-apache \
288 --without-swig \
289 --without-apxs \
290 --without-berkeley-db \
291%else
227d7ab4 292 --disable-dso \
86ee97d3 293 --disable-mod-activation \
0905b458 294%if %{with apache}
536b3fd3 295 --with-apxs=%{_sbindir}/apxs \
0905b458 296%else
297 --without-apache \
298 --without-apxs \
536b3fd3 299 --with-berkeley-db=%{_includedir}/db4:%{_libdir} \
0905b458 300%endif
cf353d53 301%if !%{with python} && !%{with perl}
0905b458 302 --without-swig \
303%endif
536b3fd3 304%endif
e30588c4 305 --with-neon=%{_prefix} \
78f330c4 306 --disable-neon-version-check \
16429189 307 --with-apr=%{_bindir}/apr-1-config \
308 --with-apr-util=%{_bindir}/apu-1-config
536b3fd3 309
1f630180 310%{__make} -j1
536b3fd3 311
cf353d53 312%if !%{with net_client_only}
b56474ff 313# python
0905b458 314%if %{with python}
86a4919e 315%{__make} swig-py \
65318afa
AF
316 swig_pydir=%{py_sitedir}/libsvn \
317 swig_pydir_extra=%{py_sitedir}/svn
0905b458 318%endif
b56474ff 319# perl
0905b458 320%if %{with perl}
bf539998
AM
321%{__make} swig-pl-lib
322odir=$(pwd)
323cd subversion/bindings/swig/perl/native
324%{__perl} Makefile.PL INSTALLDIRS=vendor
325%{__make}
326cd $odir
536b3fd3 327%endif
0905b458 328%endif
93b78127
AM
329
330%install
331rm -rf $RPM_BUILD_ROOT
1326bb99
JK
332install -d $RPM_BUILD_ROOT/etc/{rc.d/init.d,sysconfig,bash_completion.d} \
333 $RPM_BUILD_ROOT{%{_sysconfdir}/httpd/httpd.conf,%{_apachelibdir},%{_infodir}} \
afb35189 334 $RPM_BUILD_ROOT%{_examplesdir}/{%{name}-%{version},python-%{name}-%{version}} \
a54611db 335 $RPM_BUILD_ROOT/home/services/subversion{,/repos}
93b78127 336
1f630180 337%{__make} install -j1 \
cf353d53 338%if !%{with net_client_only} && %{with python}
0905b458 339 install-swig-py \
340%endif
f2a757d6 341 APACHE_LIBEXECDIR="$(%{_sbindir}/apxs -q LIBEXECDIR)" \
86a4919e 342 DESTDIR=$RPM_BUILD_ROOT \
65318afa
AF
343 swig_pydir=%{py_sitedir}/libsvn \
344 swig_pydir_extra=%{py_sitedir}/svn
93b78127 345
cf353d53 346%if !%{with net_client_only} && %{with perl}
bf539998
AM
347%{__make} install-swig-pl-lib \
348 DESTDIR=$RPM_BUILD_ROOT
349odir=$(pwd)
350cd subversion/bindings/swig/perl/native
351%{__make} install \
352 DESTDIR=$RPM_BUILD_ROOT \
353 PREFIX=$RPM_BUILD_ROOT%{_prefix} \
354 LIBDIR=$RPM_BUILD_ROOT%{_libdir}
355cd $odir
356%endif
357
0905b458 358%if %{with apache}
23bc94fc 359install %{SOURCE1} $RPM_BUILD_ROOT%{_sysconfdir}/httpd/httpd.conf/65_mod_dav_svn.conf
65318afa 360install %{SOURCE2} $RPM_BUILD_ROOT%{_sysconfdir}/httpd/httpd.conf/66_mod_authz_svn.conf
b56474ff
AM
361install %{SOURCE3} $RPM_BUILD_ROOT/etc/rc.d/init.d/svnserve
362install %{SOURCE4} $RPM_BUILD_ROOT/etc/sysconfig/svnserve
0905b458 363%endif
93b78127 364
cf353d53 365%if !%{with net_client_only}
1326bb99 366install tools/backup/hot-backup.py $RPM_BUILD_ROOT%{_bindir}/svn-hot-backup
0905b458 367%if %{with python}
f4e6a380
AM
368%py_ocomp $RPM_BUILD_ROOT%{py_sitedir}
369%py_comp $RPM_BUILD_ROOT%{py_sitedir}
1326bb99
JK
370find $RPM_BUILD_ROOT%{py_sitedir} -name "*.py" -o -name "*.a" -o -name "*.la" | xargs rm -f
371install tools/examples/*.py $RPM_BUILD_ROOT%{_examplesdir}/python-%{name}-%{version}
536b3fd3 372%endif
0905b458 373%endif
f4e6a380 374
1326bb99
JK
375install tools/client-side/bash_completion $RPM_BUILD_ROOT/etc/bash_completion.d/%{name}
376install tools/examples/*.c $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
1326bb99 377
205a3ddc
AM
378%find_lang %{name}
379
a6ecf312 380rm -f $RPM_BUILD_ROOT%{_libdir}/lib*swig*.la
381
e23909be
JB
382%clean
383rm -rf $RPM_BUILD_ROOT
384
65318afa 385%post devel
93b78127
AM
386[ ! -x /usr/sbin/fix-info-dir ] || /usr/sbin/fix-info-dir -c %{_infodir} >/dev/null 2>&1
387
65318afa 388%postun devel
93b78127
AM
389[ ! -x /usr/sbin/fix-info-dir ] || /usr/sbin/fix-info-dir -c %{_infodir} >/dev/null 2>&1
390
e23909be
JB
391%post libs -p /sbin/ldconfig
392%postun libs -p /sbin/ldconfig
164f681b
AM
393%post -n python-subversion -p /sbin/ldconfig
394%postun -n perl-subversion -p /sbin/ldconfig
f4e6a380 395
b56474ff 396%post svnserve
e8d9186f
ER
397/sbin/chkconfig --add svnserve
398%service svnserve restart "svnserve daemon"
399
b56474ff
AM
400%preun svnserve
401if [ "$1" = "0" ]; then
e8d9186f
ER
402 %service svnserve stop
403 /sbin/chkconfig --del svnserve
b56474ff
AM
404fi
405
93b78127 406%post -n apache-mod_dav_svn
e8d9186f 407%service -q httpd restart
93b78127
AM
408
409%preun -n apache-mod_dav_svn
410if [ "$1" = "0" ]; then
e8d9186f 411 %service -q httpd restart
93b78127
AM
412fi
413
93b78127
AM
414%files
415%defattr(644,root,root,755)
983a49f6 416%doc BUGS CHANGES COPYING INSTALL README
d37298dc 417%doc doc/*/*.html
4bbdbbf8
AM
418%doc tools/hook-scripts/*.{pl,py,example}
419%doc tools/hook-scripts/mailer/*.{py,example}
1326bb99 420%doc tools/xslt/*
fa3ff1b2 421%attr(755,root,root) %{_bindir}/svn*
b56474ff 422%exclude %{_bindir}/svnserve
cf353d53 423%if !%{with net_client_only}
9cb7e099 424%exclude %{_bindir}/svn-hot-backup
d62de3c9 425%endif
f4e6a380 426%{_mandir}/man1/*
af654ba5
AM
427%{_mandir}/man5/*
428%{_mandir}/man8/*
b56474ff 429%exclude %{_mandir}/man?/svnserve*
f4e6a380 430
205a3ddc 431%files libs -f %{name}.lang
f4e6a380 432%defattr(644,root,root,755)
227d7ab4 433%attr(755,root,root) %{_libdir}/lib*.so.*
164f681b
AM
434%if %{with perl} || %{with python}
435%exclude %{_libdir}/lib*_swig_*.so.*
436%endif
93b78127
AM
437
438%files devel
439%defattr(644,root,root,755)
227d7ab4
AM
440%{_includedir}/%{name}*
441%attr(755,root,root) %{_libdir}/lib*.so
b2bcb22a 442%{_libdir}/lib*.la
b72a2fbb 443%if %{with perl} || %{with python}
c00fdf6f 444%exclude %{_libdir}/lib*_swig_*.so
b72a2fbb 445%endif
1326bb99 446%{_examplesdir}/%{name}-%{version}
93b78127
AM
447
448%files static
449%defattr(644,root,root,755)
450%{_libdir}/lib*.a
451
cf353d53 452%if !%{with net_client_only}
b56474ff
AM
453%files svnserve
454%defattr(644,root,root,755)
455%attr(755,root,root) %{_bindir}/svnserve
456%{_mandir}/man?/svnserve*
afb35189 457%dir /home/services/subversion
a54611db 458%dir /home/services/subversion/repos
0905b458 459%if %{with apache}
b56474ff 460%attr(754,root,root) /etc/rc.d/init.d/svnserve
86ea8fde 461%attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/sysconfig/svnserve
0905b458 462%endif
b56474ff 463
4bbdbbf8
AM
464%files tools
465%defattr(644,root,root,755)
1326bb99 466%attr(755,root,root) %{_bindir}/svn-hot-backup
fe5bb6bb 467
468%files -n bash-completion-subversion
101e74de 469%defattr(644,root,root,755)
1326bb99 470/etc/bash_completion.d/%{name}
536b3fd3 471
0905b458 472%if %{with python}
fa3ff1b2 473%files -n python-subversion
f4e6a380 474%defattr(644,root,root,755)
4bbdbbf8 475%doc tools/backup/*.py tools/examples/*.py
f4e6a380 476%dir %{py_sitedir}/svn
65318afa 477%dir %{py_sitedir}/libsvn
f4e6a380 478%{py_sitedir}/svn/*.py[co]
65318afa
AF
479%{py_sitedir}/libsvn/*.py[co]
480%attr(755,root,root) %{py_sitedir}/libsvn/*.so
1326bb99 481%{_examplesdir}/python-%{name}-%{version}
c00fdf6f 482%attr(755,root,root) %{_libdir}/lib*_swig_py*.so*
0905b458 483%endif
f4e6a380 484
0905b458 485%if %{with perl}
b56474ff
AM
486%files -n perl-subversion
487%defattr(644,root,root,755)
488%{perl_vendorarch}/SVN
489%dir %{perl_vendorarch}/auto/SVN
490%dir %{perl_vendorarch}/auto/SVN/*
491%attr(755,root,root) %{perl_vendorarch}/auto/SVN/*/*.so
492%{perl_vendorarch}/auto/SVN/*/*.bs
493%{_mandir}/man3/*.3pm*
c00fdf6f 494%attr(755,root,root) %{_libdir}/lib*_swig_perl*.so*
0905b458 495%endif
b56474ff 496
0905b458 497%if %{with apache}
93b78127
AM
498%files -n apache-mod_dav_svn
499%defattr(644,root,root,755)
86ea8fde 500%attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/httpd/httpd.conf/*_mod_dav_svn.conf
65318afa
AF
501%attr(755,root,root) %{_apachelibdir}/mod_dav_svn.so
502
503%files -n apache-mod_authz_svn
504%defattr(644,root,root,755)
505%doc subversion/mod_authz_svn/INSTALL
86ea8fde 506%attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/httpd/httpd.conf/*_mod_authz_svn.conf
65318afa 507%attr(755,root,root) %{_apachelibdir}/mod_authz_svn.so
536b3fd3 508%endif
7b27380f
ER
509
510%endif # net_client_only
This page took 0.119327 seconds and 4 git commands to generate.