]> git.pld-linux.org Git - packages/soprano.git/blame - soprano.spec
- 2.3.1
[packages/soprano.git] / soprano.spec
CommitLineData
dbea7b1e
ER
1# TODO
2# - missing deps:
3# * Sesame2 storage backend (java-based)
4# * Raptor RDF serializer
dbea7b1e
ER
5#
6# Conditional build:
7%bcond_without serializer # with raptor serializer. need to figure out proper BR
81788912 8%bcond_without sesame2 # with sesame2backend
c7018ab4 9
65e7106f 10%define qtbrver 4.6.0
ae3009f4 11%define svn 979183
855ec3f8 12
8667f3ab
JB
13Summary: Soprano - Qt wrapper API to librdf
14Summary(pl.UTF-8): Soprano - wrapper Qt do librdf
195f432c 15Name: soprano
65e7106f 16Version: 2.3.1
ae3009f4 17Release: 1
5b9e452e 18License: GPL v2
195f432c 19Group: X11/Applications
ae3009f4 20Source0: http://downloads.sourceforge.net/sourceforge/soprano/%{name}-%{version}.tar.bz2
65e7106f 21# Source0-md5: c9a2c008b80cd5d76599e9d48139dfe9
5a8ef18c 22URL: http://sourceforge.net/projects/soprano
855ec3f8 23BuildRequires: QtCore-devel >= %{qtbrver}
24BuildRequires: QtDBus-devel >= %{qtbrver}
25BuildRequires: QtNetwork-devel >= %{qtbrver}
26BuildRequires: QtTest-devel >= %{qtbrver}
2b1fcc2c 27BuildRequires: clucene-core-devel >= 0.9.16a-2
84df784d 28BuildRequires: cmake >= 2.6.2
29%{?with_sesame2:BuildRequires: libgcj-devel}
81788912 30%{?with_serializer:BuildRequires: libraptor-devel}
855ec3f8 31BuildRequires: qt4-build >= %{qtbrver}
32BuildRequires: qt4-qmake >= %{qtbrver}
dbea7b1e
ER
33BuildRequires: rasqal-devel
34BuildRequires: redland-devel >= 1.0.6
84df784d 35BuildRequires: rpmbuild(macros) >= 1.453
c4571e50 36BuildConflicts: java-sun
195f432c 37BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
38
39%description
8667f3ab
JB
40Soprano (formally known as QRDF) is a library which provides a Qt
41wrapper API to different RDF storage solutions. It features named
42graphs (contexts) and has a modular plug-in structure which allows to
43use different RDF storage implementations.
195f432c 44
8667f3ab 45%description -l pl.UTF-8
84df784d 46Soprano (wcześniej znane jako QRDF) to biblioteka udostępniająca
47API wrappera Qt do różnych rozwiązań przechowywania danych RDF.
48Obsługuje nazwane grafy (konteksty) i ma strukturę modularnych
49wtyczek, co pozwala na używanie różnych implementacji
50przechowywania danych RDF.
195f432c 51
52%package devel
53Summary: Header files for soprano
54Summary(pl.UTF-8): Pliki nagłówkowe dla soprano
55Group: Development/Libraries
56Requires: %{name} = %{version}-%{release}
57
58%description devel
59Header files for soprano.
60
61%description devel -l pl.UTF-8
62Pliki nagłówkowe dla soprano.
63
64%prep
a4a085c3 65%setup -q
435be701 66# Sesame2 backend doesn't really use the new JNI-1.6 feature -> GetObjectRefType.
84df784d 67#sed -i 's:JNI_VERSION_1_6:JNI_VERSION_1_4:g' CMakeLists.txt
435be701 68# cleanup.
84df784d 69#sed -i 's:${JAVA_INCLUDE_PATH2}::' backends/sesame2/CMakeLists.txt
195f432c 70
71%build
72install -d build
73cd build
84df784d 74# add this to get verbose output
75# -DCMAKE_VERBOSE_MAKEFILE=1
195f432c 76%cmake \
77 -DCMAKE_INSTALL_PREFIX=%{_prefix} \
5b9e452e 78 -DQT_QMAKE_EXECUTABLE=%{_bindir}/qmake-qt4 \
195f432c 79%if "%{_lib}" == "lib64"
80 -DLIB_SUFFIX=64 \
81%endif
84df784d 82 -DJAVA_INCLUDE_PATH=%{_libdir}/gcc/%{_target_platform}/%{cc_version}/include \
83 -DJAVA_INCLUDE_PATH2=%{_libdir}/gcc/%{_target_platform}/%{cc_version}/include \
ae3009f4 84%if "%{pld_release}" == "ti"
ad66f649 85 -DJAVA_JVM_LIBRARY=%{_libdir}/gcj-%{cc_version}-9/libjvm.so \
ae3009f4 86%else
d9b07975 87 -DJAVA_JVM_LIBRARY=%{_libdir}/gcj-%{cc_version}-10/libjvm.so \
ae3009f4 88%endif
84df784d 89 ../
195f432c 90
91%{__make}
92
93%install
94rm -rf $RPM_BUILD_ROOT
8667f3ab
JB
95
96%{__make} -C build install \
195f432c 97 DESTDIR=$RPM_BUILD_ROOT
98
99%clean
100rm -rf $RPM_BUILD_ROOT
101
102%post -p /sbin/ldconfig
103%postun -p /sbin/ldconfig
104
105%files
106%defattr(644,root,root,755)
2fc92623
RT
107%attr(755,root,root) %{_bindir}/sopranocmd
108%attr(755,root,root) %{_bindir}/sopranod
3dd5cf66 109%attr(755,root,root) %{_bindir}/onto2vocabularyclass
0b2cd574 110%attr(755,root,root) %{_libdir}/libsoprano.so.*.*.*
2fc92623 111%attr(755,root,root) %ghost %{_libdir}/libsoprano.so.4
5b9e452e 112%attr(755,root,root) %{_libdir}/libsopranoclient.so.*.*.*
2fc92623 113%attr(755,root,root) %ghost %{_libdir}/libsopranoclient.so.1
5b9e452e 114%attr(755,root,root) %{_libdir}/libsopranoserver.so.*.*.*
2fc92623 115%attr(755,root,root) %ghost %{_libdir}/libsopranoserver.so.1
3d311b00
RT
116%attr(755,root,root) %{_libdir}/libsopranoindex.so.*.*.*
117%attr(755,root,root) %ghost %{_libdir}/libsopranoindex.so.1
5b9e452e 118%dir %{_libdir}/soprano
0b2cd574 119%attr(755,root,root) %{_libdir}/soprano/libsoprano_redlandbackend.so
2fc92623
RT
120%attr(755,root,root) %{_libdir}/soprano/libsoprano_nquadparser.so
121%attr(755,root,root) %{_libdir}/soprano/libsoprano_nquadserializer.so
122%attr(755,root,root) %{_libdir}/soprano/libsoprano_raptorparser.so
c4571e50 123%{?with_sesame2:%attr(755,root,root) %{_libdir}/soprano/libsoprano_sesame2backend.so}
124%{?with_serializer:%attr(755,root,root) %{_libdir}/soprano/libsoprano_raptorserializer.so}
5b9e452e 125%{_datadir}/soprano
2fc92623
RT
126%{_datadir}/dbus-1/interfaces/org.soprano.Model.xml
127%{_datadir}/dbus-1/interfaces/org.soprano.NodeIterator.xml
128%{_datadir}/dbus-1/interfaces/org.soprano.QueryResultIterator.xml
129%{_datadir}/dbus-1/interfaces/org.soprano.Server.xml
130%{_datadir}/dbus-1/interfaces/org.soprano.StatementIterator.xml
131
195f432c 132%files devel
133%defattr(644,root,root,755)
0b2cd574 134%attr(755,root,root) %{_libdir}/libsoprano.so
2fc92623
RT
135%attr(755,root,root) %{_libdir}/libsopranoserver.so
136%attr(755,root,root) %{_libdir}/libsopranoclient.so
3d311b00 137%attr(755,root,root) %{_libdir}/libsopranoindex.so
195f432c 138%dir %{_includedir}/soprano
139%{_includedir}/soprano/*.h
2fc92623 140%{_includedir}/Soprano
5b9e452e 141%{_pkgconfigdir}/soprano.pc
This page took 0.502516 seconds and 4 git commands to generate.