]> git.pld-linux.org Git - packages/soprano.git/blame - soprano.spec
- rel 2
[packages/soprano.git] / soprano.spec
CommitLineData
dbea7b1e
ER
1# TODO
2# - missing deps:
3# * Sesame2 storage backend (java-based)
4# * Raptor RDF serializer
dbea7b1e
ER
5#
6# Conditional build:
7%bcond_without serializer # with raptor serializer. need to figure out proper BR
81788912 8%bcond_without sesame2 # with sesame2backend
c7018ab4 9
84df784d 10%define qtbrver 4.4.3
855ec3f8 11
8667f3ab
JB
12Summary: Soprano - Qt wrapper API to librdf
13Summary(pl.UTF-8): Soprano - wrapper Qt do librdf
195f432c 14Name: soprano
f93654c3 15Version: 2.2.3
cceb22cf 16Release: 2
5b9e452e 17License: GPL v2
195f432c 18Group: X11/Applications
16082c87 19Source0: http://dl.sourceforge.net/soprano/%{name}-%{version}.tar.bz2
f93654c3 20# Source0-md5: 22c992a252144ae0a3a964ba2f6f1933
5a8ef18c 21URL: http://sourceforge.net/projects/soprano
855ec3f8 22BuildRequires: QtCore-devel >= %{qtbrver}
23BuildRequires: QtDBus-devel >= %{qtbrver}
24BuildRequires: QtNetwork-devel >= %{qtbrver}
25BuildRequires: QtTest-devel >= %{qtbrver}
2b1fcc2c 26BuildRequires: clucene-core-devel >= 0.9.16a-2
84df784d 27BuildRequires: cmake >= 2.6.2
28%{?with_sesame2:BuildRequires: libgcj-devel}
81788912 29%{?with_serializer:BuildRequires: libraptor-devel}
855ec3f8 30BuildRequires: qt4-build >= %{qtbrver}
31BuildRequires: qt4-qmake >= %{qtbrver}
dbea7b1e
ER
32BuildRequires: rasqal-devel
33BuildRequires: redland-devel >= 1.0.6
84df784d 34BuildRequires: rpmbuild(macros) >= 1.453
c4571e50 35BuildConflicts: java-sun
195f432c 36BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
37
38%description
8667f3ab
JB
39Soprano (formally known as QRDF) is a library which provides a Qt
40wrapper API to different RDF storage solutions. It features named
41graphs (contexts) and has a modular plug-in structure which allows to
42use different RDF storage implementations.
195f432c 43
8667f3ab 44%description -l pl.UTF-8
84df784d 45Soprano (wcześniej znane jako QRDF) to biblioteka udostępniająca
46API wrappera Qt do różnych rozwiązań przechowywania danych RDF.
47Obsługuje nazwane grafy (konteksty) i ma strukturę modularnych
48wtyczek, co pozwala na używanie różnych implementacji
49przechowywania danych RDF.
195f432c 50
51%package devel
52Summary: Header files for soprano
53Summary(pl.UTF-8): Pliki nagłówkowe dla soprano
54Group: Development/Libraries
55Requires: %{name} = %{version}-%{release}
56
57%description devel
58Header files for soprano.
59
60%description devel -l pl.UTF-8
61Pliki nagłówkowe dla soprano.
62
63%prep
a4a085c3 64%setup -q
435be701 65# Sesame2 backend doesn't really use the new JNI-1.6 feature -> GetObjectRefType.
84df784d 66#sed -i 's:JNI_VERSION_1_6:JNI_VERSION_1_4:g' CMakeLists.txt
435be701 67# cleanup.
84df784d 68#sed -i 's:${JAVA_INCLUDE_PATH2}::' backends/sesame2/CMakeLists.txt
195f432c 69
70%build
71install -d build
72cd build
84df784d 73# add this to get verbose output
74# -DCMAKE_VERBOSE_MAKEFILE=1
195f432c 75%cmake \
76 -DCMAKE_INSTALL_PREFIX=%{_prefix} \
5b9e452e 77 -DQT_QMAKE_EXECUTABLE=%{_bindir}/qmake-qt4 \
195f432c 78%if "%{_lib}" == "lib64"
79 -DLIB_SUFFIX=64 \
80%endif
84df784d 81 -DJAVA_INCLUDE_PATH=%{_libdir}/gcc/%{_target_platform}/%{cc_version}/include \
82 -DJAVA_INCLUDE_PATH2=%{_libdir}/gcc/%{_target_platform}/%{cc_version}/include \
d9b07975 83 -DJAVA_JVM_LIBRARY=%{_libdir}/gcj-%{cc_version}-10/libjvm.so \
84df784d 84 ../
195f432c 85
86%{__make}
87
88%install
89rm -rf $RPM_BUILD_ROOT
8667f3ab
JB
90
91%{__make} -C build install \
195f432c 92 DESTDIR=$RPM_BUILD_ROOT
93
94%clean
95rm -rf $RPM_BUILD_ROOT
96
97%post -p /sbin/ldconfig
98%postun -p /sbin/ldconfig
99
100%files
101%defattr(644,root,root,755)
2fc92623
RT
102%attr(755,root,root) %{_bindir}/sopranocmd
103%attr(755,root,root) %{_bindir}/sopranod
3dd5cf66 104%attr(755,root,root) %{_bindir}/onto2vocabularyclass
0b2cd574 105%attr(755,root,root) %{_libdir}/libsoprano.so.*.*.*
2fc92623 106%attr(755,root,root) %ghost %{_libdir}/libsoprano.so.4
5b9e452e 107%attr(755,root,root) %{_libdir}/libsopranoclient.so.*.*.*
2fc92623 108%attr(755,root,root) %ghost %{_libdir}/libsopranoclient.so.1
5b9e452e 109%attr(755,root,root) %{_libdir}/libsopranoserver.so.*.*.*
2fc92623 110%attr(755,root,root) %ghost %{_libdir}/libsopranoserver.so.1
3d311b00
RT
111%attr(755,root,root) %{_libdir}/libsopranoindex.so.*.*.*
112%attr(755,root,root) %ghost %{_libdir}/libsopranoindex.so.1
5b9e452e 113%dir %{_libdir}/soprano
0b2cd574 114%attr(755,root,root) %{_libdir}/soprano/libsoprano_redlandbackend.so
2fc92623
RT
115%attr(755,root,root) %{_libdir}/soprano/libsoprano_nquadparser.so
116%attr(755,root,root) %{_libdir}/soprano/libsoprano_nquadserializer.so
117%attr(755,root,root) %{_libdir}/soprano/libsoprano_raptorparser.so
c4571e50 118%{?with_sesame2:%attr(755,root,root) %{_libdir}/soprano/libsoprano_sesame2backend.so}
119%{?with_serializer:%attr(755,root,root) %{_libdir}/soprano/libsoprano_raptorserializer.so}
5b9e452e 120%{_datadir}/soprano
2fc92623
RT
121%{_datadir}/dbus-1/interfaces/org.soprano.Model.xml
122%{_datadir}/dbus-1/interfaces/org.soprano.NodeIterator.xml
123%{_datadir}/dbus-1/interfaces/org.soprano.QueryResultIterator.xml
124%{_datadir}/dbus-1/interfaces/org.soprano.Server.xml
125%{_datadir}/dbus-1/interfaces/org.soprano.StatementIterator.xml
126
195f432c 127%files devel
128%defattr(644,root,root,755)
0b2cd574 129%attr(755,root,root) %{_libdir}/libsoprano.so
2fc92623
RT
130%attr(755,root,root) %{_libdir}/libsopranoserver.so
131%attr(755,root,root) %{_libdir}/libsopranoclient.so
3d311b00 132%attr(755,root,root) %{_libdir}/libsopranoindex.so
195f432c 133%dir %{_includedir}/soprano
134%{_includedir}/soprano/*.h
2fc92623 135%{_includedir}/Soprano
5b9e452e 136%{_pkgconfigdir}/soprano.pc
This page took 0.09032 seconds and 4 git commands to generate.