]> git.pld-linux.org Git - packages/qemu.git/blobdiff - qemu.spec
- macros for kernel not userspace
[packages/qemu.git] / qemu.spec
index d8238133664dd54ef11c06fdbd41d45fa0085363..f3a738a7a34ba848c8bbe6354d671ad5ab8fd496 100644 (file)
--- a/qemu.spec
+++ b/qemu.spec
@@ -1,34 +1,35 @@
 #
 # TODO:
 # - wait till the gcc bug http://gcc.gnu.org/PR16185 is fixed.
-# - kqemu could be distributable if somebody bothers to contact qemu
+# - kqemu module could be distributable if somebody bothers to contact qemu
 #   author http://fabrice.bellard.free.fr/qemu/qemu-accel.html
+#   (but only in source form as distribution of linked module would be
+#    violation of GPL)
 #
 # Conditional build:
 %bcond_without kqemu                   # disable QEMU accelerator support
 %bcond_with    cflags_passing          # with passing rpmcflags to Makefiles
 %bcond_with    nosdlgui                # do not use SDL gui (use X11 instead)
-%bcond_with    gcc4                    # use gcc4 patches (broke build on gcc33)
+%bcond_without gcc4                    # use gcc4 patches (broke build on gcc33)
 %bcond_without dist_kernel             # without distribution kernel
-%bcond_with    kernel                  # build kqemu kernel modules
+%bcond_with    kernel                  # build kqemu kernel modules (see License)
 %bcond_without smp                     # don't build SMP module
 %bcond_without userspace               # don't build userspace utilities
 #
-%define        _kqemu_version  1.3.0pre7
-%define                _rel    0.4
+%define        _kqemu_version  1.3.0pre9
+%define                _rel    1
 Summary:       QEMU CPU Emulator
 Summary(pl):   QEMU - emulator procesora
 Name:          qemu
-Version:       0.8.1
+Version:       0.8.2
 Release:       %{_rel}%{?with_kqemu:k}
 License:       GPL
 Group:         Applications/Emulators
 #Source0Download: http://fabrice.bellard.free.fr/qemu/download.html
 Source0:       http://fabrice.bellard.free.fr/qemu/%{name}-%{version}.tar.gz
-# Source0-md5: 67d924324a5ab79d017bd97a1e767285
+# Source0-md5: 5b3a89eb2f256a8a6f3bb07f7b3f1b07
 Source1:       http://fabrice.bellard.free.fr/qemu/k%{name}-%{_kqemu_version}.tar.gz
-# NoSource1-md5:       3b77edbada790f924456aa4675edd0be
-NoSource:      1
+# Source1-md5: 27888c3220844ad360a6a23345fa1bcb
 Patch0:                %{name}-nostatic.patch
 Patch1:                %{name}-cc.patch
 Patch2:                %{name}-longjmp.patch
@@ -37,24 +38,33 @@ Patch4:             %{name}-gcc4_x86.patch
 Patch5:                %{name}-gcc4_ppc.patch
 Patch6:                %{name}-nosdlgui.patch
 Patch7:                %{name}-ifup.patch
-Patch8:        %{name}-gcc33.patch
-Patch9:                %{name}-parallel.patch
+# Proof of concept, for reference, do not remove
+Patch8:                %{name}-kde_virtual_workspaces_hack.patch
+# http://gwenole.beauchesne.info/en/projects/qemu
+Patch9:                %{name}-0.8.0-gcc4-hacks.patch
+Patch10:       %{name}-0.7.0-gcc4.patch
+Patch11:       %{name}-0.7.2-gcc4-opts.patch
+Patch12:       %{name}-0.7.2-dyngen-check-stack-clobbers.patch
 URL:           http://fabrice.bellard.free.fr/qemu/
+%if %{with kernel} && %{with dist_kernel}
+BuildRequires: kernel%{_alt_kernel}-module-build >= 3:2.6.7
+BuildRequires: rpmbuild(macros) >= 1.330
+%endif
+%if %{with userspace}
 BuildRequires: SDL-devel >= 1.2.1
 BuildRequires: alsa-lib-devel
 %{!?with_gcc4:BuildRequires:   gcc < 5:4.0}
-%if %{with kqemu} && %{with dist_kernel}
-BuildRequires: kernel-module-build >= 3:2.6.7
-%endif
-BuildRequires: rpmbuild(macros) >= 1.217
+BuildRequires: perl-tools-pod
+BuildRequires: tetex
 BuildRequires: sed >= 4.0
+%endif
 Requires:      SDL >= 1.2.1
 # sparc is currently unsupported (missing cpu_get_real_ticks() impl in vl.c)
 ExclusiveArch: %{ix86} %{x8664} %{!?with_kqemu:ppc}
 BuildRoot:     %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
 
 # some SPARC boot image in ELF format
-%define                _noautostrip    .*%{_datadir}/qemu/proll.elf
+%define                _noautostrip    .*%{_datadir}/qemu/openbios-sparc32
 
 %description
 QEMU is a FAST! processor emulator. By using dynamic translation it
@@ -87,7 +97,7 @@ aby dzia
   u¿ywane do wirtualnego hostowania kilku wirtualnych pecetów na
   pojedynczym serwerze.
 
-%package -n kernel-misc-kqemu
+%package -n kernel%{_alt_kernel}-misc-kqemu
 Summary:       kqemu - kernel module
 Summary(pl):   kqemu - modu³ j±dra
 Version:       %{_kqemu_version}
@@ -98,27 +108,27 @@ License:   Free to use, non-distributable
 Requires(post,postun): /sbin/depmod
 Requires:      module-init-tools >= 3.2.2-2
 
-%description -n kernel-misc-kqemu
+%description -n kernel%{_alt_kernel}-misc-kqemu
 kqemu - kernel module.
 
-%description -n kernel-misc-kqemu -l pl
+%description -n kernel%{_alt_kernel}-misc-kqemu -l pl
 kqemu - modu³ j±dra.
 
-%package -n kernel-smp-misc-kqemu
+%package -n kernel%{_alt_kernel}-smp-misc-kqemu
 Summary:       kqemu - SMP kernel module
 Summary(pl):   kqemu - modu³ j±dra SMP
 Version:       %{_kqemu_version}
 Release:       %{_rel}@%{_kernel_ver_str}
 Group:         Base/Kernel
-%{?with_dist_kernel:%requires_releq_kernel_up}
+%{?with_dist_kernel:%requires_releq_kernel_smp}
 License:       Free to use, non-distributable
 Requires(post,postun): /sbin/depmod
 Requires:      module-init-tools >= 3.2.2-2
 
-%description -n kernel-smp-misc-kqemu
+%description -n kernel%{_alt_kernel}-smp-misc-kqemu
 kqemu - SMP kernel module.
 
-%description -n kernel-smp-misc-kqemu -l pl
+%description -n kernel%{_alt_kernel}-smp-misc-kqemu -l pl
 kqemu - modu³ j±dra SMP.
 
 %prep
@@ -128,14 +138,16 @@ kqemu - modu
 %patch2 -p1
 %patch3 -p1
 %if %{with gcc4}
-%patch4 -p0
+%patch9 -p1
+%patch10 -p1
+%patch11 -p1
+%patch12 -p1
+#%patch4 -p0
 %patch5 -p1
 %endif
 %{?with_nosdlgui:%patch6 -p1}
 %patch7 -p1
-%patch8 -p1
-# probably not needed
-#%%patch9 -p1
+#%patch8 -p1
 
 %{__sed} -i -e 's/sdl_static=yes/sdl_static=no/' configure
 %{__sed} -i 's/.*MAKE) -C kqemu$//' Makefile
@@ -165,35 +177,26 @@ EOF
 %build
 %if %{with kernel}
 cd kqemu-%{_kqemu_version}
+
+mv -f kqemu-mod-i386.o{,.bin}
+mv -f kqemu-mod-x86_64.o{,.bin}
 mv -f kqemu-linux.c{,.orig}
-for cfg in %{?with_dist_kernel:%{?with_smp:smp} up}%{!?with_dist_kernel:nondist}; do
-       if [ ! -r "%{_kernelsrcdir}/config-$cfg" ]; then
-               exit 1
-       fi
-       install -d o/include/linux
-       ln -sf %{_kernelsrcdir}/config-$cfg o/.config
-       ln -sf %{_kernelsrcdir}/Module.symvers-$cfg o/Module.symvers
-       ln -sf %{_kernelsrcdir}/include/linux/autoconf-$cfg.h o/include/linux/autoconf.h
-%if %{with dist_kernel}
-       %{__make} -C %{_kernelsrcdir} O=$PWD/o prepare scripts
-%else
-       install -d o/include/config
-       touch o/include/config/MARKER
-       ln -sf %{_kernelsrcdir}/scripts o/scripts
-%endif
-       if grep -q "^CONFIG_PREEMPT_RT=y$" o/.config; then
-               sed 's/SPIN_LOCK_UNLOCKED/SPIN_LOCK_UNLOCKED(kqemu_lock)/' \
-                       kqemu-linux.c.orig > kqemu-linux.c
-       else
-               cat kqemu-linux.c.orig > kqemu-linux.c
-       fi
-
-       %{__make} -C %{_kernelsrcdir} modules \
-               CC="%{__cc}" CPP="%{__cpp}" \
-               M=$PWD O=$PWD/o \
-               %{?with_verbose:V=1}
-       mv kqemu.ko kqemu-mod-$cfg.ko
-done
+cat > Makefile <<'EOF'
+obj-m := kqemu.o
+kqemu-objs:= kqemu-linux.o kqemu-mod.o
+
+$(obj)/kqemu-mod.o: $(src)/kqemu-mod-$(ARCH).o.bin
+       cp $< $@
+EOF
+
+%build_kernel_modules -m kqemu <<'EOF'
+if grep -q "CONFIG_PREEMPT_RT" o/.config; then
+       sed 's/SPIN_LOCK_UNLOCKED/SPIN_LOCK_UNLOCKED(kqemu_lock)/' \
+               kqemu-linux.c.orig > kqemu-linux.c
+else
+       cat kqemu-linux.c.orig > kqemu-linux.c
+fi
+EOF
 cd -
 %endif
 
@@ -235,12 +238,10 @@ EOF
 %endif
 
 %if %{with kernel}
-install -d $RPM_BUILD_ROOT/lib/modules/%{_kernel_ver}{,smp}/misc
+%install_kernel_modules -m kqemu-%{_kqemu_version}/kqemu -d misc
 install -d $RPM_BUILD_ROOT/etc/{modprobe.d/%{_kernel_ver}{,smp},udev/rules.d}
-install kqemu-%{_kqemu_version}/kqemu-mod-up.ko $RPM_BUILD_ROOT/lib/modules/%{_kernel_ver}/misc/kqemu.ko
 install modprobe.conf $RPM_BUILD_ROOT/etc/modprobe.d/%{_kernel_ver}/kqemu.conf
 %if %{with smp} && %{with dist_kernel}
-install kqemu-%{_kqemu_version}/kqemu-mod-smp.ko $RPM_BUILD_ROOT/lib/modules/%{_kernel_ver}smp/misc/kqemu.ko
 install modprobe.conf $RPM_BUILD_ROOT/etc/modprobe.d/%{_kernel_ver}smp/kqemu.conf
 %endif
 install udev.conf $RPM_BUILD_ROOT/etc/udev/rules.d/kqemu.rules
@@ -260,16 +261,16 @@ modprobe kqemu
 EOF
 %endif
 
-%post  -n kernel-misc-kqemu
+%post  -n kernel%{_alt_kernel}-misc-kqemu
 %depmod %{_kernel_ver}
 
-%postun -n kernel-misc-kqemu
+%postun -n kernel%{_alt_kernel}-misc-kqemu
 %depmod %{_kernel_ver}
 
-%post  -n kernel-smp-misc-kqemu
+%post  -n kernel%{_alt_kernel}-smp-misc-kqemu
 %depmod %{_kernel_ver}smp
 
-%postun -n kernel-smp-misc-kqemu
+%postun -n kernel%{_alt_kernel}-smp-misc-kqemu
 %depmod %{_kernel_ver}smp
 
 %if %{with userspace}
@@ -284,7 +285,7 @@ EOF
 %endif
 
 %if %{with kernel}
-%files -n kernel-misc-kqemu
+%files -n kernel%{_alt_kernel}-misc-kqemu
 %defattr(644,root,root,755)
 %doc kqemu-%{_kqemu_version}/LICENSE
 %config(noreplace) %verify(not md5 mtime size) /etc/udev/rules.d/kqemu.rules
@@ -292,7 +293,7 @@ EOF
 /lib/modules/%{_kernel_ver}/misc/kqemu.ko*
 
 %if %{with smp} && %{with dist_kernel}
-%files -n kernel-smp-misc-kqemu
+%files -n kernel%{_alt_kernel}-smp-misc-kqemu
 %defattr(644,root,root,755)
 %doc kqemu-%{_kqemu_version}/LICENSE
 %config(noreplace) %verify(not md5 mtime size) /etc/udev/rules.d/kqemu.rules
This page took 0.036521 seconds and 4 git commands to generate.