]> git.pld-linux.org Git - packages/python3.git/blobdiff - python3-multilib.patch
- enhanced multilib patch to adjust venv lib symlinking; release 2
[packages/python3.git] / python3-multilib.patch
index b8e2fbdbfadf0e156ecd37d18b0719659a7c3907..83174c620b410ec19e09ad285488a787ff3c21ac 100644 (file)
@@ -160,3 +160,19 @@ diff -urNp -x '*.orig' Python-3.9.2.org/setup.py Python-3.9.2/setup.py
                  self.assertEqual(user_path, expected)
  
      def test_main(self):
+--- Python-3.10.13/Lib/venv/__init__.py.orig   2023-08-24 14:46:25.000000000 +0200
++++ Python-3.10.13/Lib/venv/__init__.py        2023-09-23 12:30:09.948046280 +0200
+@@ -137,10 +137,9 @@ class EnvBuilder:
+         context.inc_path = path = os.path.join(env_dir, incpath)
+         create_if_needed(path)
+         create_if_needed(libpath)
+-        # Issue 21197: create lib64 as a symlink to lib on 64-bit non-OS X POSIX
+-        if ((sys.maxsize > 2**32) and (os.name == 'posix') and
+-            (sys.platform != 'darwin')):
+-            link_path = os.path.join(env_dir, 'lib64')
++        # Issue 21197: create lib<qual> as a symlink to lib on 64-bit non-OS X POSIX
++        if sys.platlibdir != 'lib':
++            link_path = os.path.join(env_dir, sys.platlibdir)
+             if not os.path.exists(link_path):   # Issue #21643
+                 os.symlink('lib', link_path)
+         context.bin_path = binpath = os.path.join(env_dir, binname)
This page took 0.135992 seconds and 4 git commands to generate.