]> git.pld-linux.org Git - packages/python3.git/blobdiff - python3-db.patch
- build with libtirpc+libnsl 1.x; release 2
[packages/python3.git] / python3-db.patch
index 34939eed8eb6ab13d780f86aa2f78fa2e296dc64..928aa6229110b6b546c938909ee2183cb7f75c73 100644 (file)
@@ -5,7 +5,27 @@
          # versions of BerkeleyDB already installed.
  
 -        max_db_ver = (5, 3)
-+        max_db_ver = (6, 0)
++        max_db_ver = (6, 2)
          min_db_ver = (3, 3)
          db_setup_debug = False   # verbose debug prints from this script?
  
+--- Python-3.8.0/setup.py~     2019-10-15 10:03:10.000000000 +0200
++++ Python-3.8.0/setup.py      2019-10-15 10:03:52.493993277 +0200
+@@ -1275,16 +1275,7 @@ class PyBuildExt(build_ext):
+             for cand in dbm_order:
+                 if cand == "ndbm":
+                     if find_file("ndbm.h", self.inc_dirs, []) is not None:
+-                        # Some systems have -lndbm, others have -lgdbm_compat,
+-                        # others don't have either
+-                        if self.compiler.find_library_file(self.lib_dirs,
+-                                                               'ndbm'):
+-                            ndbm_libs = ['ndbm']
+-                        elif self.compiler.find_library_file(self.lib_dirs,
+-                                                             'gdbm_compat'):
+-                            ndbm_libs = ['gdbm_compat']
+-                        else:
+-                            ndbm_libs = []
++                        ndbm_libs = ['gdbm_compat']
+                         if dbm_setup_debug: print("building dbm using ndbm")
+                         dbmext = Extension('_dbm', ['_dbmmodule.c'],
+                                            define_macros=[
This page took 0.028499 seconds and 4 git commands to generate.