]> git.pld-linux.org Git - packages/python3.git/blobdiff - python3-db.patch
- up to 3.7.4
[packages/python3.git] / python3-db.patch
index 34939eed8eb6ab13d780f86aa2f78fa2e296dc64..567410802ddf42324c760211bfae758fd2839477 100644 (file)
@@ -5,7 +5,27 @@
          # versions of BerkeleyDB already installed.
  
 -        max_db_ver = (5, 3)
-+        max_db_ver = (6, 0)
++        max_db_ver = (6, 2)
          min_db_ver = (3, 3)
          db_setup_debug = False   # verbose debug prints from this script?
  
+--- Python-3.6.0/setup.py~     2016-12-27 23:21:52.000000000 +0100
++++ Python-3.6.0/setup.py      2016-12-27 23:28:54.720208583 +0100
+@@ -1252,16 +1252,7 @@ class PyBuildExt(build_ext):
+             for cand in dbm_order:
+                 if cand == "ndbm":
+                     if find_file("ndbm.h", inc_dirs, []) is not None:
+-                        # Some systems have -lndbm, others have -lgdbm_compat,
+-                        # others don't have either
+-                        if self.compiler.find_library_file(lib_dirs,
+-                                                               'ndbm'):
+-                            ndbm_libs = ['ndbm']
+-                        elif self.compiler.find_library_file(lib_dirs,
+-                                                             'gdbm_compat'):
+-                            ndbm_libs = ['gdbm_compat']
+-                        else:
+-                            ndbm_libs = []
++                        ndbm_libs = ['gdbm_compat']
+                         if dbm_setup_debug: print("building dbm using ndbm")
+                         dbmext = Extension('_dbm', ['_dbmmodule.c'],
+                                            define_macros=[
This page took 0.038526 seconds and 4 git commands to generate.