]> git.pld-linux.org Git - packages/python3-setuptools.git/blame - python3-setuptools.spec
- updated to 69.2.0, use pypi release tarball
[packages/python3-setuptools.git] / python3-setuptools.spec
CommitLineData
2f649423
MK
1#
2# Conditional build:
300f73bb 3%bcond_with apidocs # Sphinx based documentation
dbaf506a 4%bcond_with system_libs # use system modules (appdirs, jaraco.text, packaging...) # TODO
6502ae9a 5%bcond_with tests # py.test tests (few failures)
2f5fae83 6%bcond_with bootstrap # no system modules, bootstrap egg-info without system setuptools
25fb9ea9 7
744badc2
JB
8%if %{with bootstrap}
9%undefine with_apidocs
10%undefine with_system_libs
11%undefine with_tests
12%endif
2f649423 13
744badc2 14%define module setuptools
9fded6eb 15%define pypi_name setuptools
b79e62bc 16Summary: A collection of enhancements to the Python distutils
e4a6c4e2 17Summary(pl.UTF-8): Zestaw rozszerzeń dla pythonowych distutils
34676580 18Name: python3-setuptools
dbaf506a 19Version: 69.2.0
2f5fae83 20Release: 1
67093d8e 21Epoch: 1
744badc2 22License: MIT
b79e62bc 23Group: Development/Languages/Python
744badc2 24#Source0Download: https://pypi.org/simple/setuptools/
dbaf506a
JB
25Source0: https://files.pythonhosted.org/packages/source/s/setuptools/%{pypi_name}-%{version}.tar.gz
26# Source0-md5: 940ffdb3a2ce4f6a5ee80032aa115fc7
828f076c 27Patch0: setuptools-missing.patch
80225079 28Patch1: multilib.patch
1ca207b5 29URL: https://github.com/pypa/setuptools
744badc2 30%if %(locale -a | grep -q '^C\.utf8$'; echo $?)
c034c756
JB
31BuildRequires: glibc-localedb-all
32%endif
9195227e 33BuildRequires: python3-modules >= 1:3.8
2f5fae83 34%{!?with_bootstrap:BuildRequires: python3-setuptools >= 1:54}
744badc2 35%if %{with system_libs}
2f5fae83 36# versions from pkg_resources/_vendor/vendored.txt and setuptools/_vendor/vendored.txt
dbaf506a
JB
37BuildRequires: python3-importlib_metadata >= 6.0.0
38BuildRequires: python3-importlib_resources >= 5.10.2
2f5fae83
JB
39BuildRequires: python3-jaraco.text >= 3.7.0
40BuildRequires: python3-ordered-set >= 3.1.1
dbaf506a 41BuildRequires: python3-platformdirs >= 2.6.2
2f5fae83 42BuildRequires: python3-more_itertools >= 8.8.0
dbaf506a 43BuildRequires: python3-packaging >= 23.1
2f5fae83 44BuildRequires: python3-tomli >= 2.0.1
dbaf506a 45BuildRequires: python3-typing_extensions >= 4.4.0
2f5fae83 46BuildRequires: python3-zipp >= 3.7.0
744badc2 47%endif
b6cbc91d 48BuildConflicts: python3-distribute < 0.7
e2cd79ed 49%if %{with tests}
2f5fae83 50BuildRequires: python3-build
744badc2 51BuildRequires: python3-coverage >= 4.5.1
2f5fae83 52BuildRequires: python3-filelock >= 3.4.0
dbaf506a 53BuildRequires: python3-importlib_metadata
2f5fae83 54BuildRequires: python3-ini2toml >= 0.9
dbaf506a 55BuildRequires: python3-jaraco.develop >= 7.21
2f5fae83 56BuildRequires: python3-jaraco.envs >= 2.2
828f076c 57BuildRequires: python3-jaraco.path >= 3.2.0
dbaf506a
JB
58BuildRequires: python3-mypy >= 1.9
59BuildRequires: python3-packaging >= 23.2
403a922f 60BuildRequires: python3-pip >= 19.1
2f5fae83
JB
61BuildRequires: python3-pip_run >= 8.8
62BuildRequires: python3-pytest >= 6
828f076c 63BuildRequires: python3-pytest-checkdocs >= 2.4
744badc2 64BuildRequires: python3-pytest-cov >= 2.5.1
dbaf506a
JB
65BuildRequires: python3-pytest-enabler >= 2.2
66BuildRequires: python3-pytest-home
2f5fae83
JB
67BuildRequires: python3-pytest-mypy >= 0.9.1
68BuildRequires: python3-pytest-perf
dbaf506a
JB
69BuildRequires: python3-pytest-ruff >= 0.2.1
70BuildRequires: python3-pytest-timeout
71BuildRequires: python3-pytest-xdist >= 3
744badc2 72BuildRequires: python3-virtualenv >= 13.0.0
2f5fae83
JB
73BuildRequires: python3-tomli
74BuildRequires: python3-tomli-w >= 1.0.0
744badc2 75BuildRequires: python3-wheel
e2cd79ed 76%endif
5c02125b 77%if %{with apidocs}
dbaf506a
JB
78BuildRequires: python3-Sphinx >= 3.5
79BuildRequires: python3-Sphinx < 7.2.5
a57a3e11 80BuildRequires: python3-furo
be14e546 81BuildRequires: python3-jaraco
dbaf506a 82BuildRequires: python3-jaraco.packaging >= 9.3
2f5fae83
JB
83BuildRequires: python3-jaraco.tidelift >= 1.4
84BuildRequires: python3-pygments-github-lexers >= 0.0.5
744badc2 85BuildRequires: python3-rst.linker >= 1.9
828f076c
JB
86# specified but not required(?)
87#BuildRequires: python3-pygments-github-lexers >= 0.0.5
88BuildRequires: python3-setuptools >= 1:34
2f5fae83 89BuildRequires: python3-sphinx-hoverxref
dbaf506a
JB
90BuildRequires: python3-sphinx-notfound-page >= 1
91BuildRequires: python3-sphinx-notfound-page < 2
2f5fae83 92BuildRequires: python3-sphinx-reredirects
a57a3e11 93BuildRequires: python3-sphinx_favicon
828f076c 94BuildRequires: python3-sphinx_inline_tabs
a57a3e11 95BuildRequires: python3-sphinxcontrib-towncrier
dbaf506a 96BuildRequires: python3-tomli
5c02125b 97%endif
20a0801e 98%{!?with_bootstrap:BuildRequires: rpm-pythonprov}
6502ae9a 99BuildRequires: rpmbuild(macros) >= 1.714
6ef7e1f8 100BuildRequires: unzip
9195227e 101Requires: python3-modules >= 1:3.8
744badc2 102%if %{with system_libs}
2f5fae83 103# versions from pkg_resources/_vendor/vendored.txt and setuptools/_vendor/vendored.txt
dbaf506a
JB
104Requires: python3-importlib_metadata >= 6.0.0
105Requires: python3-importlib_resources >= 5.10.2
2f5fae83
JB
106Requires: python3-jaraco.text >= 3.7.0
107Requires: python3-ordered-set >= 3.1.1
dbaf506a 108Requires: python3-platformdirs >= 2.6.2
2f5fae83 109Requires: python3-more_itertools >= 8.8.0
dbaf506a 110Requires: python3-packaging >= 23.1
2f5fae83 111Requires: python3-tomli >= 2.0.1
dbaf506a 112Requires: python3-typing_extensions >= 4.4.0
2f5fae83 113Requires: python3-zipp >= 3.7.0
744badc2 114%endif
b79e62bc
AM
115BuildArch: noarch
116BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
117
118%description
119setuptools is a collection of enhancements to the Python distutils
c034c756
JB
120that allow you to more easily build and distribute Python 2.x
121packages, especially ones that have dependencies on other packages.
b79e62bc 122
1c17442b 123%description -l pl.UTF-8
d539774b 124setuptools to zestaw rozszerzeń do pythonowych distutils umożliwiający
c034c756
JB
125łatwiejsze budowanie i rozprowadzanie pakietów Pythona 2.x,
126szczególnie tych mających zależności od innych pakietów.
d539774b
JB
127
128Ten pakiet zawiera składniki uruchomieniowe setuptools, potrzebne do
c034c756
JB
129uruchamiania kodu wymagającego pkg_resources.py, przeznaczone dla
130Pythona 2.x.
eadb908c 131
2f649423
MK
132%package apidocs
133Summary: %{module} API documentation
134Summary(pl.UTF-8): Dokumentacja API %{module}
135Group: Documentation
136
137%description apidocs
138API documentation for %{module}.
139
140%description apidocs -l pl.UTF-8
141Dokumentacja API %{module}.
142
b79e62bc 143%prep
2f649423 144%setup -q -n %{module}-%{version}
828f076c 145%patch0 -p1
80225079 146%patch1 -p1
b79e62bc 147
744badc2
JB
148%if %{with system_libs}
149exit 1 # TODO: unvendor modules from pkg_resources/_vendor
150%endif
151
b79e62bc 152%build
2f5fae83
JB
153%if %{with bootstrap}
154%{__python3} setup.py egg_info
155%endif
156
6502ae9a
JB
157LC_ALL=C.UTF-8 \
158%py3_build
159
160%{?with_tests:%{__python3} -m pytest pkg_resources/tests setuptools/tests tests}
b79e62bc 161
c034c756 162%if %{with apidocs}
828f076c
JB
163cd docs
164%{__python3} -m sphinx -W . build/html
c034c756
JB
165%endif
166
b79e62bc
AM
167%install
168rm -rf $RPM_BUILD_ROOT
169
a21b5be7 170%py3_install
991fba2b 171
9195227e
AM
172#???
173rm -r $RPM_BUILD_ROOT%{py3_sitescriptdir}/build-3/
174
b79e62bc
AM
175%clean
176rm -rf $RPM_BUILD_ROOT
177
178%files
179%defattr(644,root,root,755)
9195227e 180%doc LICENSE NEWS.rst README.rst
6a8a63ea 181%{py3_sitescriptdir}/_distutils_hack
828f076c 182%{py3_sitescriptdir}/distutils-precedence.pth
5c02125b
JB
183%{py3_sitescriptdir}/pkg_resources
184%{py3_sitescriptdir}/setuptools
a57a3e11 185%{py3_sitescriptdir}/%{module}-%{version}*py*.egg-info
2f649423 186
c034c756 187%if %{with apidocs}
2f649423
MK
188%files apidocs
189%defattr(644,root,root,755)
828f076c 190%doc docs/build/html/{_static,deprecated,development,references,userguide,*.html,*.js}
2f649423 191%endif
This page took 0.384282 seconds and 4 git commands to generate.