]> git.pld-linux.org Git - packages/python-wxPython.git/blame - python-wxPython.spec
- release 5
[packages/python-wxPython.git] / python-wxPython.spec
CommitLineData
9859b6af 1# TODO:
9859b6af 2# - Editra plugins are not installed, do it manually?
2d9bbbc5 3%define module wxPython
2d9bbbc5 4Summary: Cross platform GUI toolkit for Python
e11767f5 5Summary(pl.UTF-8): Wieloplatformowe narzędzie GUI dla Pythona
2d9bbbc5 6Name: python-%{module}
9e94b181 7Version: 2.8.9.1
47e38ea5 8Release: 5
9859b6af 9License: wxWindows Library Licence 3.1 (LGPL v2+ with exception)
2d9bbbc5 10Group: Libraries/Python
a1de01e5 11Source0: http://dl.sourceforge.net/wxpython/%{module}-src-%{version}.tar.bz2
9e94b181 12# Source0-md5: 4ad9a64e05529097618c7e48fbb10a84
80e800ed 13Source1: %{name}-wxversion-null.py
efd75bb2 14Patch0: %{name}-CFLAGS.patch
41bbfc6a 15URL: http://wxpython.org/
9859b6af 16BuildRequires: gtk+2-devel >= 1:2.0.0
dbb01471 17BuildRequires: pkgconfig
cf488c94
JB
18BuildRequires: python >= 1:2.5
19BuildRequires: python-devel >= 1:2.5
dbb01471 20BuildRequires: python-modules
c7e90457 21BuildRequires: rpm-pythonprov
9e94b181 22BuildRequires: wxGTK2-unicode-gl-devel >= 2.8.9
c7e90457 23# optional: libgnomeprint >= 2.8 (if wx uses it), gstreamer 0.8
dbb01471 24%pyrequires_eq python-modules
9e94b181 25Requires: wxGTK2-unicode-gl >= 2.8.9
2d9bbbc5 26BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
2d9bbbc5 27
28%description
29wxPython is a GUI toolkit for Python that is a wrapper around the
89ed416b 30wxWidgets C++ GUI library. wxPython provides a large variety of window
2d9bbbc5 31types and controls, all implemented with a native look and feel (and
32native runtime speed) on the platforms it is supported on.
33
11382b1e
JR
34%description -l pl.UTF-8
35wxPython jest narzędziem GUI dla Pythona będącym nakładką na
36bibliotekę GUI napisaną w C++ o nazwie wxWidgets. wxPython dostarcza
37dużą liczbę typów okien, kontrolek.
2d9bbbc5 38
9859b6af
JB
39%package devel
40Summary: Header and SWIG files for wxPython
41Summary(pl.UTF-8): Pliki nagłówkowe i SWIG dla wxPythona
42Group: Development/Libraries
43Requires: %{name} = %{version}-%{release}
44Requires: wxWidgets-devel >= 2.8.7
45
46%description devel
47Header and SWIG files for wxPython.
48
49%description devel -l pl.UTF-8
50Pliki nagłówkowe i SWIG dla wxPythona.
51
52%package editra
53Summary: Editra editor
54Summary(pl.UTF-8): Edytor Editra
55Group: Development/Tools
56URL: http://editra.org/
57Requires: %{name} = %{version}-%{release}
58
59%description editra
60Editra is a multi-platform text editor with an implementation that
61focuses on creating an easy to use interface and features that aid in
62code development. Currently it supports syntax highlighting and
63variety of other useful features for over 50 programming languages.
64
65%description editra -l pl.UTF-8
66Editra to wieloplatformowy edytor tekstu, którego implementacja skupia
67się na stworzeniu łatwego w użyciu interfejsu i możliwościach
68pomagających w tworzeniu kodu. Aktualnie obsługuje podświetlanie
69składni i różne przydatne ułatwienia dla ponad 50 języków
70programowania.
71
72%package xrced
73Summary: XRCed - XRC files editor
74Summary(pl.UTF-8): XRCed - edytor plików XRC
75License: BSD
76Group: Development/Tools
77URL: http://xrced.sourceforge.net/
78Requires: %{name} = %{version}-%{release}
79
80%description xrced
81XRCed is a simple resource editor for wxWidgets/wxPython GUI
82development which supports creating and editing files in XRC format.
83It is written in Python and uses wxPython GUI toolkit.
84
85%description xrced -l pl.UTF-8
86XRCed to prosty edytor zasobów do programowania w środowisku
87graficznym wxWidgets/wxPython, pozwalający na tworzenie i
88modyfikowanie plików w formacie XRC. Został napisany w Pythonie i
89wykorzystuje toolkit graficzny wxPython.
90
2d9bbbc5 91%package examples
92Summary: wxPython example programs
e11767f5 93Summary(pl.UTF-8): Przykładowe programy wxPython
2d9bbbc5 94Group: Libraries/Python
e89df15f 95Requires: %{name} = %{version}-%{release}
2d9bbbc5 96
97%description examples
89ed416b 98wxPython example programs.
2d9bbbc5 99
11382b1e
JR
100%description examples -l pl.UTF-8
101Przykładowe programy w wxPythonie.
2d9bbbc5 102
103%prep
e9736c06 104%setup -q -n %{module}-src-%{version}
efd75bb2 105%patch0 -p1
4c99c19b 106
2d9bbbc5 107%build
d53fabac
AF
108cd wxPython
109CFLAGS="%{rpmcflags}" python setup.py build \
e9736c06
KK
110 WX_CONFIG=%{_bindir}/wx-gtk2-unicode-config \
111 UNICODE=1
2d9bbbc5 112
113%install
114rm -rf $RPM_BUILD_ROOT
787efee9 115cd wxPython
2d9bbbc5 116
117python setup.py install \
e9736c06
KK
118 WX_CONFIG=%{_bindir}/wx-gtk2-unicode-config \
119 INSTALL_MULTIVERSION=0 \
120 UNICODE=1 \
121 --optimize 2 \
7e78df0d 122 --root=$RPM_BUILD_ROOT
2d9bbbc5 123
80e800ed
AM
124install %{SOURCE1} $RPM_BUILD_ROOT%{py_sitedir}/wxversion.py
125
2d9bbbc5 126install -d $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
127cp -a demo samples $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
5a3cc61d 128rm -f $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}/samples/embedded/embedded
129rm -f $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}/samples/embedded/embedded.o
130
9859b6af
JB
131mv $RPM_BUILD_ROOT%{py_sitedir}/wx/lib/editor/README.txt README.editor.txt
132rm -r $RPM_BUILD_ROOT%{py_sitedir}/wx/tools/Editra/{AUTHORS,CHANGELOG,COPYING,FAQ,INSTALL,MANIFEST.in,NEWS,README,THANKS,TODO,docs/*.txt,setup.py*,tests,plugins/*.egg}
133
80e800ed
AM
134%py_ocomp $RPM_BUILD_ROOT%{py_sitedir}
135%py_comp $RPM_BUILD_ROOT%{py_sitedir}
136%py_postclean
2d9bbbc5 137
138%clean
139rm -rf $RPM_BUILD_ROOT
140
141%files
142%defattr(644,root,root,755)
9859b6af 143%doc wxPython/docs/{CHANGES.txt,MigrationGuide.txt,README.txt} wxPython/README.editor.txt
d53fabac
AF
144#don't remove this files, because this is licensing information
145%doc docs/{licence.txt,licendoc.txt,preamble.txt}
9859b6af
JB
146%attr(755,root,root) %{_bindir}/helpviewer
147%attr(755,root,root) %{_bindir}/img2png
148%attr(755,root,root) %{_bindir}/img2py
149%attr(755,root,root) %{_bindir}/img2xpm
150%attr(755,root,root) %{_bindir}/pyalacarte
151%attr(755,root,root) %{_bindir}/pyalamode
152%attr(755,root,root) %{_bindir}/pycrust
153%attr(755,root,root) %{_bindir}/pyshell
154%attr(755,root,root) %{_bindir}/pywrap
155%attr(755,root,root) %{_bindir}/pywxrc
80e800ed
AM
156
157%{py_sitedir}/wxversion.py[co]
158
6aacdda9 159%dir %{py_sitedir}/%{module}
2d9bbbc5 160%{py_sitedir}/%{module}/*.py[co]
6aacdda9 161%dir %{py_sitedir}/%{module}/lib
2d9bbbc5 162%{py_sitedir}/%{module}/lib/*.py[co]
6aacdda9 163%dir %{py_sitedir}/%{module}/lib/colourchooser
d53fabac 164%{py_sitedir}/%{module}/lib/colourchooser/*.py[co]
6aacdda9 165%dir %{py_sitedir}/%{module}/lib/editor
2d9bbbc5 166%{py_sitedir}/%{module}/lib/editor/*.py[co]
6aacdda9 167%dir %{py_sitedir}/%{module}/lib/mixins
2d9bbbc5 168%{py_sitedir}/%{module}/lib/mixins/*.py[co]
6aacdda9 169%dir %{py_sitedir}/%{module}/tools
d53fabac 170%{py_sitedir}/%{module}/tools/*.py[co]
1ab6ba2b
AF
171
172%dir %{py_sitedir}/wx
e9736c06 173%attr(755,root,root) %{py_sitedir}/wx/*.so
1ab6ba2b 174%{py_sitedir}/wx/*.py[co]
89ed416b
MC
175%dir %{py_sitedir}/wx/build
176%{py_sitedir}/wx/build/*.py[co]
1ab6ba2b
AF
177%dir %{py_sitedir}/wx/lib
178%{py_sitedir}/wx/lib/*.py[co]
a5bf25b4
JB
179%dir %{py_sitedir}/wx/lib/analogclock
180%{py_sitedir}/wx/lib/analogclock/*.py[co]
181%dir %{py_sitedir}/wx/lib/analogclock/lib_setup
182%{py_sitedir}/wx/lib/analogclock/lib_setup/*.py[co]
7f7e4110
AM
183%dir %{py_sitedir}/wx/lib/art
184%{py_sitedir}/wx/lib/art/*.py[co]
1ab6ba2b
AF
185%dir %{py_sitedir}/wx/lib/colourchooser
186%{py_sitedir}/wx/lib/colourchooser/*.py[co]
187%dir %{py_sitedir}/wx/lib/editor
188%{py_sitedir}/wx/lib/editor/*.py[co]
e9736c06
KK
189%dir %{py_sitedir}/wx/lib/floatcanvas
190%{py_sitedir}/wx/lib/floatcanvas/*.py[co]
9859b6af
JB
191%dir %{py_sitedir}/wx/lib/floatcanvas/Utilities
192%{py_sitedir}/wx/lib/floatcanvas/Utilities/*.py[co]
e9736c06
KK
193%dir %{py_sitedir}/wx/lib/masked
194%{py_sitedir}/wx/lib/masked/*.py[co]
1ab6ba2b
AF
195%dir %{py_sitedir}/wx/lib/mixins
196%{py_sitedir}/wx/lib/mixins/*.py[co]
e9736c06
KK
197%dir %{py_sitedir}/wx/lib/ogl
198%{py_sitedir}/wx/lib/ogl/*.py[co]
1ab6ba2b 199%dir %{py_sitedir}/wx/py
e9736c06 200%{py_sitedir}/wx/py/*.ico
1ab6ba2b 201%{py_sitedir}/wx/py/*.py[co]
e9736c06 202%doc %{py_sitedir}/wx/py/*.txt
1ab6ba2b
AF
203%dir %{py_sitedir}/wx/tools
204%{py_sitedir}/wx/tools/*.py[co]
205%dir %{py_sitedir}/wx/tools/XRCed
206%{py_sitedir}/wx/tools/XRCed/*.py[co]
e9736c06
KK
207%doc %{py_sitedir}/wx/tools/XRCed/*.txt
208%{py_sitedir}/wx/tools/XRCed/*.xrc
2d9bbbc5 209
7f7e4110
AM
210%dir %{py_sitescriptdir}/wxaddons
211%{py_sitescriptdir}/wxaddons/*.py[co]
212
9859b6af
JB
213%{py_sitedir}/wxPython-*.egg-info
214%{py_sitescriptdir}/wxaddons-*.egg-info
215
216%files devel
217%defattr(644,root,root,755)
218%{_includedir}/wx-2.8/wx/wxPython
219
220%files editra
221%defattr(644,root,root,755)
222%doc wxPython/wx/tools/Editra/{AUTHORS,CHANGELOG,COPYING,FAQ,NEWS,README,THANKS,TODO,docs/*.txt}
223%attr(755,root,root) %{_bindir}/editra
224%dir %{py_sitedir}/wx/tools/Editra
225%attr(755,root,root) %{py_sitedir}/wx/tools/Editra/Editra
226%{py_sitedir}/wx/tools/Editra/__init__.py[co]
e34ba184 227%{py_sitedir}/wx/tools/Editra/launcher.py[co]
9859b6af
JB
228%dir %{py_sitedir}/wx/tools/Editra/locale
229%lang(en) %{py_sitedir}/wx/tools/Editra/locale/en_US
230%lang(es) %{py_sitedir}/wx/tools/Editra/locale/es_ES
231%lang(ja) %{py_sitedir}/wx/tools/Editra/locale/ja_JP
232%lang(ru) %{py_sitedir}/wx/tools/Editra/locale/ru_RU
233%{py_sitedir}/wx/tools/Editra/pixmaps
234%dir %{py_sitedir}/wx/tools/Editra/src
235%{py_sitedir}/wx/tools/Editra/src/*.py[co]
236%dir %{py_sitedir}/wx/tools/Editra/src/autocomp
237%{py_sitedir}/wx/tools/Editra/src/autocomp/*.py[co]
e34ba184 238%dir %{py_sitedir}/wx/tools/Editra/src/eclib
239%{py_sitedir}/wx/tools/Editra/src/eclib/*.py[co]
9859b6af
JB
240%dir %{py_sitedir}/wx/tools/Editra/src/extern
241%{py_sitedir}/wx/tools/Editra/src/extern/*.py[co]
242%dir %{py_sitedir}/wx/tools/Editra/src/syntax
243%{py_sitedir}/wx/tools/Editra/src/syntax/*.py[co]
244%{py_sitedir}/wx/tools/Editra/styles
7f7e4110 245
9859b6af
JB
246%files xrced
247%defattr(644,root,root,755)
248%doc wxPython/wx/tools/XRCed/{CHANGES.txt,ChangeLog,README.txt,TODO.txt,license.txt}
249%attr(755,root,root) %{_bindir}/xrced
250%dir %{py_sitedir}/wx/tools/XRCed
251%{py_sitedir}/wx/tools/XRCed/misc
252%dir %{py_sitedir}/wx/tools/XRCed/plugins
253%{py_sitedir}/wx/tools/XRCed/plugins/*.py[co]
254%{py_sitedir}/wx/tools/XRCed/plugins/bitmaps
255%{py_sitedir}/wx/tools/XRCed/plugins/gizmos.crx
256%{py_sitedir}/wx/tools/XRCed/xrced.htb
a5bf25b4 257
2d9bbbc5 258%files examples
16bda523 259%defattr(644,root,root,755)
2d9bbbc5 260%{_examplesdir}/%{name}-%{version}
This page took 0.199269 seconds and 4 git commands to generate.