]> git.pld-linux.org Git - packages/python-serial.git/blame - python-serial.spec
- release 2
[packages/python-serial.git] / python-serial.spec
CommitLineData
e08ccba4 1
5dd0867a 2%define module serial
e08ccba4 3
6489d097 4Summary: Serial port interface module
612b0b56 5Summary(pl.UTF-8): Moduł interfejsu do portu szeregowego
e08ccba4 6Name: python-serial
379e2312 7Version: 2.4
bcdaf5cd 8Release: 2
e08ccba4 9License: GPL
5dd0867a 10Group: Development/Languages/Python
379e2312 11Source0: http://dl.sourceforge.net/pyserial/pyserial-%{version}.tar.gz
12# Source0-md5: eec19df59fd75ba5a136992897f8e468
13URL: http://pyserial.wiki.sourceforge.net/pySerial
e08ccba4 14%pyrequires_eq python
e08ccba4 15BuildRequires: python-devel
608b1f52 16BuildRequires: unzip
e08ccba4 17BuildArch: noarch
18BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
19
20%description
21This module encapsulates the access for the serial port. It provides
22backends for Python running on Windows, Linux, BSD (possibly any POSIX
23compilant system) and Jython. The module named "serial" automatically
24selects the appropriate backend.
25
f04dc3d2
JR
26%description -l pl.UTF-8
27Ten moduł opakowuje dostęp do portu szeregowego. Dostarcza backendy
28dla Pythona działającego na Windows, Linuksie, BSD (być może dowolnym
29systemie zgodnym z POSIX) oraz Jythona. Moduł o nazwie "serial"
30automatycznie wybiera właściwy backend.
e08ccba4 31
32%prep
33%setup -q -n pyserial-%{version}
34
35%build
36python ./setup.py build
37
38%install
39rm -rf $RPM_BUILD_ROOT
a1aab51a 40install -d $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
e08ccba4 41
6489d097
JB
42python ./setup.py install \
43 --optimize 2 \
44 --root=$RPM_BUILD_ROOT
e08ccba4 45
a1aab51a
JK
46mv examples/*.py $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
47
7d5fe39c
MG
48find $RPM_BUILD_ROOT%{py_sitescriptdir} -name "*serialjava*" -exec rm {} \;
49find $RPM_BUILD_ROOT%{py_sitescriptdir} -name "*serialwin*" -exec rm {} \;
50find $RPM_BUILD_ROOT%{py_sitescriptdir} -name \*.py -exec rm {} \;
51
e08ccba4 52%clean
53rm -rf $RPM_BUILD_ROOT
54
55%files
56%defattr(644,root,root,755)
a1aab51a
JK
57%doc CHANGES.txt LICENSE.txt README.txt
58%{_examplesdir}/%{name}-%{version}
59%dir %{py_sitescriptdir}/%{module}
379e2312 60%{py_sitescriptdir}/%{module}/*.py[co]
61%{py_sitescriptdir}/*egg-info
This page took 0.100052 seconds and 4 git commands to generate.