]> git.pld-linux.org Git - packages/python-pytest-fixture-config.git/blame - python-pytest-fixture-config.spec
- rebuild with python 3.8
[packages/python-pytest-fixture-config.git] / python-pytest-fixture-config.spec
CommitLineData
0e6224fe
JB
1#
2# Conditional build:
3%bcond_without tests # unit tests
4%bcond_without python2 # CPython 2.x module
5%bcond_without python3 # CPython 3.x module
6
7Summary: Fixture configuration utils for py.test
8Summary(pl.UTF-8): Narzędzia do konfiguracji osprzętu dla py.test
9Name: python-pytest-fixture-config
10Version: 1.3.0
04958af9 11Release: 2
0e6224fe
JB
12License: MIT
13Group: Libraries/Python
14#Source0Download: https://pypi.org/simple/pytest-fixture-config/
15Source0: https://files.pythonhosted.org/packages/source/p/pytest-fixture-config/pytest-fixture-config-%{version}.tar.gz
16# Source0-md5: 7d0a9c60fccf700d68b5e6596ac81eba
17URL: https://github.com/manahl/pytest-plugins
18BuildRequires: rpm-pythonprov
19BuildRequires: rpmbuild(macros) >= 1.714
20%if %{with python2}
21BuildRequires: python-modules >= 1:2.7
22BuildRequires: python-setuptools
23BuildRequires: python-setuptools_git
24%if %{with tests}
25BuildRequires: python-pytest
26BuildRequires: python-six
27%endif
28%endif
29%if %{with python3}
30BuildRequires: python3-modules >= 1:3.4
31BuildRequires: python3-setuptools
32BuildRequires: python3-setuptools_git
33%if %{with tests}
34BuildRequires: python-pytest
35BuildRequires: python-six
36%endif
37%endif
38Requires: python-modules >= 1:2.7
39BuildArch: noarch
40BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
41
42%description
43Simple configuration objects for Py.test fixtures. Allows you to skip
44tests when their required config variables aren't set.
45
46%description -l pl.UTF-8
47Proste obiekty konfiguracyjne do osprzętu (fixtures) Py.test.
48Pozwalają pomijać testy, kiedy wymagane przez nie zmienne nie są
49ustawione.
50
51%package -n python3-pytest-fixture-config
52Summary: Fixture configuration utils for py.test
53Summary(pl.UTF-8): Narzędzia do konfiguracji osprzętu dla py.test
54Group: Libraries/Python
55Requires: python3-modules >= 1:3.4
56
57%description -n python3-pytest-fixture-config
58Simple configuration objects for Py.test fixtures. Allows you to skip
59tests when their required config variables aren't set.
60
61%description -n python3-pytest-fixture-config -l pl.UTF-8
62Proste obiekty konfiguracyjne do osprzętu (fixtures) Py.test.
63Pozwalają pomijać testy, kiedy wymagane przez nie zmienne nie są
64ustawione.
65
66%prep
67%setup -q -n pytest-fixture-config-%{version}
68
69%build
70%if %{with python2}
71%py_build %{?with_tests:test}
72%endif
73
74%if %{with python3}
75%py3_build %{?with_tests:test}
76%endif
77
78%install
79rm -rf $RPM_BUILD_ROOT
80
81%if %{with python2}
82%py_install
83
84%py_postclean
85%endif
86
87%if %{with python3}
88%py3_install
89%endif
90
91%clean
92rm -rf $RPM_BUILD_ROOT
93
94%if %{with python2}
95%files
96%defattr(644,root,root,755)
97%doc CHANGES.md LICENSE README.md
98%{py_sitescriptdir}/pytest_fixture_config.py[co]
99%{py_sitescriptdir}/pytest_fixture_config-%{version}-py*.egg-info
100%endif
101
102%if %{with python3}
103%files -n python3-pytest-fixture-config
104%defattr(644,root,root,755)
105%doc CHANGES.md LICENSE README.md
106%{py3_sitescriptdir}/pytest_fixture_config.py
107%{py3_sitescriptdir}/__pycache__/pytest_fixture_config.cpython-*.py[co]
108%{py3_sitescriptdir}/pytest_fixture_config-%{version}-py*.egg-info
109%endif
This page took 0.141458 seconds and 4 git commands to generate.