]> git.pld-linux.org Git - packages/python-psycopg.git/blobdiff - python-psycopg.spec
- release 8 (by relup.sh)
[packages/python-psycopg.git] / python-psycopg.spec
index 31e97fc7c4124c6f7f3b32e0610d65fdd79821d4..011ee67c959a3b7de901436318a61576a7c502c9 100644 (file)
@@ -1,32 +1,29 @@
 
-%include       /usr/lib/rpm/macros.python
-%define        module psycopg
+%define        module  psycopg
 
 Summary:       psycopg is a PostgreSQL database adapter for Python
-Summary(pl):   psycopg jest przeznaczonym dla Pythona interfejsem do bazy PostgreSQL
+Summary(pl.UTF-8):     psycopg jest przeznaczonym dla Pythona interfejsem do bazy PostgreSQL
 Name:          python-%{module}
-Version:       1.1.10
-Release:       1
+Version:       1.1.21
+Release:       8
 License:       GPL
 Group:         Libraries/Python
-Source0:       http://initd.org/pub/software/%{module}/%{module}-%{version}.tar.gz
-# Source0-md5: 2279a6aaddf8a8fbec44f782e5cdaa02
-Patch0:                %{name}-dumb-ac-fix.patch
+Source0:       http://initd.org/pub/software/psycopg/%{module}-%{version}.tar.gz
+# Source0-md5: a31f79f68d6d32898d6f24e11369a106
+Patch0:                %{name}-lib64.patch
 URL:           http://www.initd.org/software/psycopg/
+BuildRequires: autoconf
 BuildRequires: postgresql-backend-devel
+BuildRequires: postgresql-devel
 BuildRequires: python-devel
 BuildRequires: python-mx-DateTime-devel
+BuildRequires: rpm-pythonprov
 Requires:      postgresql-libs
 %pyrequires_eq python-modules
 Requires:      python-mx-DateTime
 BuildRoot:     %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
 
-%define prod_name ZPsycopgDA
-%define zope_dir          %{_libdir}/zope
-%define zope_productsdir   %{zope_dir}/Products
-%define python_compile_opt python -O -c "import compileall; compileall.compile_dir('.')"
-%define python_compile     python -c "import compileall; compileall.compile_dir('.')"
-
+%define zope_subname ZPsycopgDA
 
 %description
 psycopg is a PostgreSQL database adapter for the Python programming
@@ -35,31 +32,31 @@ with the aim of being very small and fast, and stable as a rock. The
 main advantages of psycopg are that it supports the full Python
 DBAPI-2.0 and being thread safe at level 2.
 
-%description -l pl
+%description -l pl.UTF-8
 psycopg jest przeznaczonym dla Pythona interfejsem do bazy danych
-PostgreSQL (tak jak pygresql i popy). Zosta³ zakodowany od pocz±tku
-z za³o¿eniem ¿e ma byæ bardzo ma³y, szybki i stabilny. G³ówna zalet±
-psycopg jest, ¿e w jest pe³ni zgodny z standardem DBAPI-2.0 i jest
+PostgreSQL (tak jak pygresql i popy). Został zakodowany od początku z
+założeniem że ma być bardzo mały, szybki i stabilny. Główna zaletą
+psycopg jest, że w jest pełni zgodny z standardem DBAPI-2.0 i jest
 'thread safe' na poziomie 2.
 
-%package -n Zope-%{prod_name}
+%package -n Zope-%{zope_subname}
 Summary:       Zope PostgreSQL database adapter
-Summary(pl):   Interfejs bazy danych PostgreSQL do Zope
+Summary(pl.UTF-8):     Interfejs bazy danych PostgreSQL do Zope
 Group:         Development/Languages/Python
+Requires:      %{name} = %{version}-%{release}
 Requires:      Zope
-Requires:      %{name} = %{version}
-BuildArch:     noarch
-BuildRoot:     %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
 
-%description -n Zope-%{prod_name}
+%description -n Zope-%{zope_subname}
 Zope PostgreSQL database adapter.
 
-%description -n Zope-%{prod_name} -l pl
+%description -n Zope-%{zope_subname} -l pl.UTF-8
 Interfejs bazy danych PostgreSQL do Zope.
 
 %prep
 %setup -q -n %{module}-%{version}
+%if "%{_lib}" == "lib64"
 %patch0 -p1
+%endif
 
 %build
 %{__autoconf}
@@ -70,28 +67,39 @@ Interfejs bazy danych PostgreSQL do Zope.
        --with-postgres-includes=%{_includedir}/postgresql/server
 %{__make}
 
-cd %{prod_name}
-%{python_compile}
-%{python_compile_opt}
-cd ..
-
 %install
 rm -rf $RPM_BUILD_ROOT
-install -d $RPM_BUILD_ROOT{%{py_sitedir},%{zope_productsdir}/%{prod_name}}
+install -d $RPM_BUILD_ROOT{%{py_sitedir},%{_datadir}/Zope-%{zope_subname}}
 
 install psycopgmodule.so $RPM_BUILD_ROOT%{py_sitedir}
 
-cp -ar %{prod_name}/* $RPM_BUILD_ROOT%{zope_productsdir}/%{prod_name}
-rm -f $RPM_BUILD_ROOT%{zope_productsdir}/%{prod_name}/*.py
+cp -a %{zope_subname}/* $RPM_BUILD_ROOT%{_datadir}/Zope-%{zope_subname}
+%py_comp $RPM_BUILD_ROOT%{_datadir}/Zope-%{zope_subname}
+%py_ocomp $RPM_BUILD_ROOT%{_datadir}/Zope-%{zope_subname}
+rm -f $RPM_BUILD_ROOT%{_datadir}/Zope-%{zope_subname}/*.py
 
 %clean
 rm -rf $RPM_BUILD_ROOT
 
+%post -n Zope-%{zope_subname}
+/usr/sbin/installzopeproduct %{_datadir}/Zope-%{zope_subname} %{zope_subname}
+if [ -f /var/lock/subsys/zope ]; then
+       /etc/rc.d/init.d/zope restart >&2
+fi
+
+%postun -n Zope-%{zope_subname}
+if [ "$1" = "0" ]; then
+       /usr/sbin/installzopeproduct -d %{zope_subname}
+       if [ -f /var/lock/subsys/zope ]; then
+               /etc/rc.d/init.d/zope restart >&2
+       fi
+fi
+
 %files
 %defattr(644,root,root,755)
 %doc AUTHORS CREDITS FAQ NEWS README RELEASE-1.0 SUCCESS TODO doc
 %attr(755,root,root) %{py_sitedir}/*.so
 
-%files -n Zope-%{prod_name}
+%files -n Zope-%{zope_subname}
 %defattr(644,root,root,755)
-%{zope_productsdir}/%{prod_name}
+%{_datadir}/Zope-%{zope_subname}
This page took 0.400292 seconds and 4 git commands to generate.