]> git.pld-linux.org Git - packages/python-nagiosplugin.git/blame - python-nagiosplugin.spec
cleanups
[packages/python-nagiosplugin.git] / python-nagiosplugin.spec
CommitLineData
7b621577
MK
1# TODO:
2# Split examplest to separate module
63ec028d 3#
7b621577
MK
4# Conditional build:
5%bcond_with doc # don't build doc
6%bcond_without tests # do not perform "make test"
7%bcond_without python2 # CPython 2.x module
8%bcond_without python3 # CPython 3.x module
9
10%define module nagiosplugin
11Summary: Python class library which helps writing Nagios (or Icinga) compatible plugins easily in Python
12Summary(pl.UTF-8): Biblioteka klas Pythona pomagająca łatwo pisać wtyczki dla Nagiosa (lub Icingi) w Pythonie
7b621577
MK
13Name: python-%{module}
14Version: 1.2.2
15Release: 1
16License: ZPL 2.1
17Group: Libraries/Python
7b621577
MK
18Source0: https://pypi.python.org/packages/source/n/%{module}/%{module}-%{version}.tar.gz
19# Source0-md5: c85e1641492d606d929b02aa262bf55d
20URL: nagiosplugin
21BuildRequires: rpm-pythonprov
7b621577 22BuildRequires: rpmbuild(macros) >= 1.219
7b621577
MK
23%if %{with python2}
24BuildRequires: python-devel
25BuildRequires: python-setuptools
26%endif
27%if %{with python3}
28BuildRequires: python3-devel
29BuildRequires: python3-modules
30BuildRequires: python3-setuptools
31%endif
7b621577
MK
32Requires: python-modules
33BuildArch: noarch
34BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
35
36%description
37nagiosplugin is a Python class library which helps writing Nagios (or
38Icinga) compatible plugins easily in Python. It cares for much of the
39boilerplate code and default logic commonly found in Nagios checks
40
41%description -l pl.UTF-8
42nagiosplugin jest biblioteką klas Pythona pomagającą łatwo pisać
43wtyczki dla Nagiosa (lub Icingi) w Pythonie. Dostarcza większość
44typowego kodu i domyślna logikę zawartą w testach Nagiosa.
45
46%package -n python3-%{module}
63ec028d
ER
47Summary: Python class library which helps writing Nagios (or Icinga) compatible plugins easily in Python
48Summary(pl.UTF-8): Biblioteka klas Pythona pomagająca łatwo pisać wtyczki dla Nagiosa (lub Icingi) w Pythonie
7b621577
MK
49Group: Libraries/Python
50Requires: python3-modules
51
52%description -n python3-%{module}
53nagiosplugin is a Python class library which helps writing Nagios (or
54Icinga) compatible plugins easily in Python. It cares for much of the
55boilerplate code and default logic commonly found in Nagios checks
56
57%description -n python3-%{module} -l pl.UTF-8
58nagiosplugin jest biblioteką klas Pythona pomagającą łatwo pisać
59wtyczki dla Nagiosa (lub Icingi) w Pythonie. Dostarcza większość
60typowego kodu i domyślna logikę zawartą w testach Nagiosa.
61
62%package apidocs
63Summary: %{module} API documentation
64Summary(pl.UTF-8): Dokumentacja API %{module}
65Group: Documentation
66
67%description apidocs
68API documentation for %{module}.
69
70%description apidocs -l pl.UTF-8
71Dokumentacja API %{module}.
72
73%prep
74%setup -q -n %{module}-%{version}
75
7b621577
MK
76%build
77%if %{with python2}
78%{__python} setup.py build --build-base build-2 %{?with_tests:test}
79%endif
80
81%if %{with python3}
82%{__python3} setup.py build --build-base build-3 %{?with_tests:test}
83%endif
84
85%if %{with doc}
86cd docs
87%{__make} -j1 html
88rm -rf _build/html/_sources
89%endif
90
91%install
92rm -rf $RPM_BUILD_ROOT
93
94%if %{with python2}
95%{__python} setup.py \
96 build --build-base build-2 \
97 install --skip-build \
98 --optimize=2 \
99 --root=$RPM_BUILD_ROOT
100
63ec028d
ER
101%{__rm} -r $RPM_BUILD_ROOT%{py_sitescriptdir}/%{module}/examples
102%{__rm} -r $RPM_BUILD_ROOT%{py_sitescriptdir}/%{module}/tests
103
7b621577
MK
104%py_postclean
105%endif
106
107%if %{with python3}
108%{__python3} setup.py \
109 build --build-base build-3 \
110 install --skip-build \
111 --optimize=2 \
112 --root=$RPM_BUILD_ROOT
7b621577 113
63ec028d
ER
114%{__rm} -r $RPM_BUILD_ROOT%{py3_sitescriptdir}/%{module}/examples
115%{__rm} -r $RPM_BUILD_ROOT%{py3_sitescriptdir}/%{module}/tests
116%endif
7b621577
MK
117
118%clean
119rm -rf $RPM_BUILD_ROOT
120
121%if %{with python2}
122%files
123%defattr(644,root,root,755)
124%doc HACKING.txt CONTRIBUTORS.txt HISTORY.txt README.txt
63ec028d 125%{py_sitescriptdir}/%{module}
7b621577
MK
126%{py_sitescriptdir}/%{module}-%{version}-py*.egg-info
127%endif
7b621577
MK
128
129%if %{with python3}
130%files -n python3-%{module}
131%defattr(644,root,root,755)
132%doc HACKING.txt CONTRIBUTORS.txt HISTORY.txt README.txt
133%{py3_sitescriptdir}/%{module}
134%{py3_sitescriptdir}/%{module}-%{version}-py*.egg-info
7b621577
MK
135%endif
136
137%if %{with doc}
138%files apidocs
139%defattr(644,root,root,755)
140%doc docs/_build/html/*
141%endif
This page took 0.130013 seconds and 4 git commands to generate.