]> git.pld-linux.org Git - packages/python-keystoneclient.git/blame - python-keystoneclient.spec
rebuild with python 3.10
[packages/python-keystoneclient.git] / python-keystoneclient.spec
CommitLineData
466ceb55
JK
1#
2# Conditional build:
3%bcond_with doc # do build doc (missing deps)
4%bcond_with tests # do perform "make test" (missing deps)
5%bcond_without python2 # CPython 2.x module
6%bcond_without python3 # CPython 3.x module
7
8Summary: Client Library for OpenStack Identity
9Name: python-keystoneclient
10Version: 3.13.0
4cc731df 11Release: 6
466ceb55
JK
12License: Apache
13Group: Libraries/Python
14Source0: https://files.pythonhosted.org/packages/source/p/python-keystoneclient/%{name}-%{version}.tar.gz
15# Source0-md5: e9f5d8f1476be5fb835e074b79557c64
16URL: https://pypi.python.org/pypi/python-keystoneclient
17BuildRequires: rpm-pythonprov
18BuildRequires: rpmbuild(macros) >= 1.714
19%if %{with python2}
20BuildRequires: python-pbr >= 2.0.0
21BuildRequires: python-setuptools
22%endif
23%if %{with python3}
24BuildRequires: python3-pbr >= 2.0.0
25BuildRequires: python3-setuptools
26%endif
27Requires: python-debtcollector >= 1.2.0
28Requires: python-keystoneauth1 >= 3.0.1
29Requires: python-oslo.config >= 4.0.0
30Requires: python-oslo.i18n >= 2.1.0
31Requires: python-oslo.serialization >= 1.10.0
32Requires: python-oslo.utils >= 3.20.0
33Requires: python-pbr >= 2.0.0
34Requires: python-positional >= 1.1.1
35Requires: python-requests >= 2.14.2
36Requires: python-six >= 1.9.0
37Requires: python-stevedore >= 1.20.0
38BuildArch: noarch
39BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
40
41%description
42This is a client for the OpenStack Identity API, implemented by the
43Keystone team; it contains a Python API (the keystoneclient module)
44for OpenStack's Identity Service.
45
46%package -n python3-keystoneclient
47Summary: Client Library for OpenStack Identity
48Group: Libraries/Python
49Requires: python3-debtcollector >= 1.2.0
50Requires: python3-keystoneauth1 >= 3.0.1
51Requires: python3-oslo.config >= 4.0.0
52Requires: python3-oslo.i18n >= 2.1.0
53Requires: python3-oslo.serialization >= 1.10.0
54Requires: python3-oslo.utils >= 3.20.0
55Requires: python3-pbr >= 2.0.0
56Requires: python3-positional >= 1.1.1
57Requires: python3-requests >= 2.14.2
58Requires: python3-six >= 1.9.0
59Requires: python3-stevedore >= 1.20.0
60
61%description -n python3-keystoneclient
62This is a client for the OpenStack Identity API, implemented by the
63Keystone team; it contains a Python API (the keystoneclient module)
64for OpenStack's Identity Service.
65
66%package apidocs
67Summary: API documentation for Python keystoneclient module
68Summary(pl.UTF-8): Dokumentacja API modułu Pythona keystoneclient
69Group: Documentation
70
71%description apidocs
72API documentation for Pythona keystoneclient module.
73
74%description apidocs -l pl.UTF-8
75Dokumentacja API modułu Pythona keystoneclient.
76
77%prep
78%setup -q
79
80%build
81%if %{with python2}
82%py_build %{?with_tests:test}
83%endif
84
85%if %{with python3}
86%py3_build %{?with_tests:test}
87%endif
88
89%if %{with doc}
90cd doc
91%{__make} -j1 html
92rm -rf _build/html/_sources
93%endif
94
95%install
96rm -rf $RPM_BUILD_ROOT
97
98%if %{with python2}
99%py_install
100
101%py_postclean
102%endif
103
104%if %{with python3}
105%py3_install
106%endif
107
108%clean
109rm -rf $RPM_BUILD_ROOT
110
111%if %{with python2}
112%files
113%defattr(644,root,root,755)
114%doc AUTHORS ChangeLog README.rst
115%{py_sitescriptdir}/keystoneclient
116%{py_sitescriptdir}/python_keystoneclient-%{version}-py*.egg-info
117%endif
118
119%if %{with python3}
120%files -n python3-keystoneclient
121%defattr(644,root,root,755)
122%doc AUTHORS ChangeLog README.rst
123%{py3_sitescriptdir}/keystoneclient
124%{py3_sitescriptdir}/python_keystoneclient-%{version}-py*.egg-info
125%endif
126
127%if %{with doc}
128%files apidocs
129%defattr(644,root,root,755)
130%doc doc/_build/html/*
131%endif
This page took 0.085501 seconds and 4 git commands to generate.