]> git.pld-linux.org Git - packages/python-egenix-mx-base.git/blobdiff - python-egenix-mx-base.spec
- release 2.
[packages/python-egenix-mx-base.git] / python-egenix-mx-base.spec
index 66308f3dba29d6029850b623d31a8a4fb1e54ac6..2016a8858de7c3afda4af4e05344f1f263992066 100644 (file)
@@ -3,18 +3,19 @@
 %define python_sitepkgsdir %(echo `python -c "import sys; print (sys.prefix + '/lib/python' + sys.version[:3] + '/site-packages/')"`)
 %define mxdir %{python_sitepkgsdir}/mx
 
-Summary:       eGenix mx-Extensions for Python - BASE package
+Summary:       eGenix mx-Extensions for Python
+Summary(pl):   eGenix mx-Extensions dla jêzyka Python
 Name:          python-%{module}
 Version:       2.0.1
-Release:       1
-URL:           http://www.lemburg.com/python/mxExtensions.html
+Release:       2
+License:       Distributable
 Group:         Development/Languages/Python
 Group(de):     Entwicklung/Sprachen/Python
 Group(pl):     Programowanie/Jêzyki/Python
-License:       Distributable
 Source0:       http://www.lemburg.com/python/%{module}-%{version}.tar.gz
-Requires:      python
-BuildRequires: python-devel
+URL:           http://www.lemburg.com/python/eGenix-mx-Extensions.html
+BuildRequires: python-devel >= 2.1
+%requires_eq   python
 BuildRoot:     %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
 
 %description
@@ -22,11 +23,15 @@ The eGenix mx Extension Series are a collection of Python extensions
 written in ANSI C and Python which provide a large spectrum of useful
 additions to everyday Python programming.
 
-The BASE package includes the Open Source subpackages of the series
-and is needed by all other add-on packages of the series.
+This package includes the Open Source subpackages of the series and is
+needed by all other add-on packages of the series.
+
+%description -l pl
+eGenix mx Extensions Series jest zestawem modu³ów, u³atwiaj±cych ¿ycie
+ka¿demu programi¶cie pisz±cemu w jêzyku Python, napisanych w ANSI C i
+Pythonie.
 
-This software is brought to you by eGenix.com and distributed under
-the eGenix.com Public License.
+Ten pakiet zawiera podstawowe modu³y wymagane przez inne pakiety.
 
 %package -n python-mx-DateTime
 Summary:       Date and time Python extension
@@ -34,14 +39,15 @@ Summary(pl):        Obiekty daty i czasu dla j
 Group:         Development/Languages/Python
 Group(de):     Entwicklung/Sprachen/Python
 Group(pl):     Programowanie/Jêzyki/Python
+%requires_eq   python
 Requires:      python-%{module} = %{version}
 
 %description -n python-mx-DateTime
 mxDateTime is an extension package that provides three new object
-types, DateTime, DateTimeDelta and RelativeDateTime, which let you
+types - DateTime, DateTimeDelta and RelativeDateTime, which let you
 store and handle date/time values in a much more natural way than by
-using ticks (seconds since 1.1.70 0:00 UTC; the encoding used by the
-time module).
+using ticks (seconds since 01.01.1970 0:00 UTC; the encoding used by
+the time module).
 
 You can add, subtract and even multiply instances, pickle and copy
 them and convert the results to strings, COM dates, ticks and some
@@ -56,7 +62,23 @@ which often have to deal with date/time values (the mxODBC package is
 one example of an extension using this interface).
 
 %description -l pl -n python-mx-DateTime
-N/A
+mxDateTime jest pakietem modu³ów, które definiuj± trzy nowe klasy -
+DateTime, DateTimeDelta oraz RelativeDateTime. Umo¿liwiaj± one
+przechowywanie oraz operowanie na dacie i czasie w bardziej naturalny
+sposób ni¿ za pomoc± sekund od pocz±tku 1 stycznia 1970 (tak jak w
+module time).
+
+Programista mo¿e dodawaæ, odejmowaæ, mno¿yæ (w sensie arytmetycznym),
+serializowaæ, a tak¿e mno¿yæ (w sesnie rozmna¿ania :-) obiekty.
+Instancje w/w klas mog± byæ konwertowane do napisów i sekund.
+Dodatkowo modu³ zawiera kilka u¿ytecznych funkcji do tworzenia nowych
+obiektów i ich formatowania.
+
+Oprócz, ³atwych w u¿yciu, klas jêzyka Python, pakiet dostarcza tak¿e
+bardzo wygodny interfejs w C, który mo¿e byæ wykorzystany do tworzenia
+innych rozszerzeñ (np.: pakiet mxODBC). W szczególno¶ci, cecha ta jest
+interesuj±ca w przypadku aplikacji bazodanowych, które operuj± na
+dacie i czasie.
 
 %package -n python-mx-TextTools
 Summary:       Efficient text manipulation extensions for Python
@@ -64,6 +86,7 @@ Summary(pl):  Wydajne manipulowanie tekstem w j
 Group:         Development/Languages/Python
 Group(de):     Entwicklung/Sprachen/Python
 Group(pl):     Programowanie/Jêzyki/Python
+%requires_eq   python
 Requires:      python-%{module} = %{version}
 
 %description -n python-mx-TextTools
@@ -81,7 +104,15 @@ text (either exact or using translation tables) and recombining
 strings to form new text.
 
 %description -l pl -n python-mx-TextTools
-N/A
+Pakiet mxTextTools dostarcza szereg u¿ytecznych typów i funkcji, które
+implementuj± wysokiej jako¶ci algorytmy do wyszukiwania i manipulacji
+tekstu. Programista dostaje wydajne (na poziomie kodu napisanego w
+jêzyku C) narzêdzie bez potrzeby kompilacji i konsolidacji, kiedy
+zajdzie potrzeba zmiany sposobu interpretacji tekstu.
+
+Pakiet mo¿e mieæ zastosowanie w aplikacjach, które musz± interpretowaæ
+tekst zadany w konkretnym formacie, a tak¿e wyszukiwaæ, pobieraæ i
+manipulowaæ tekstem.
 
 %package -n python-mx-Stack
 Summary:       Stack implementation for Python
@@ -89,6 +120,7 @@ Summary(pl): Implementacja stosu dla j
 Group:         Development/Languages/Python
 Group(de):     Entwicklung/Sprachen/Python
 Group(pl):     Programowanie/Jêzyki/Python
+%requires_eq   python
 Requires:      python-%{module} = %{version}
 
 %description -n python-mx-Stack
@@ -98,27 +130,37 @@ having .push() and .pop() methods and focusses on obtaining maximum
 speed at low memory costs.
 
 %description -l pl -n python-mx-Stack
-N/A
+Pakiet mxStack zawiera implementacjê stosu, która zawiera typowe
+metody takie jak pop() czy push(). Mechanizm zosta³ napisany tak by,
+przy minimalnym zu¿yciu pamiêci, by³ bardzo wydajny.
 
 %package -n python-mx-Queue
 Summary:       Queue implementation for Python
-Summary(pl):   Implementacja stosu dla jêzyka Python
+Summary(pl):   Implementacja kolejki dla jêzyka Python
 Group:         Development/Languages/Python
 Group(de):     Entwicklung/Sprachen/Python
 Group(pl):     Programowanie/Jêzyki/Python
+%requires_eq   python
 Requires:      python-%{module} = %{version}
 
 %description -n python-mx-Queue
-N/A
+mxQueue is an extension package that provides a new object type called
+Queue. It works much like what you would expect from such a type,
+having .push() and .pop() methods and focusses on obtaining maximum
+speed at low memory costs.
 
 %description -l pl -n python-mx-Queue
-N/A
+Pakiet mxQueue zawiera implementacjê kolejki, która zawiera typowe
+metody takie jak pop() czy push(). Mechanizm zosta³ napisany tak by,
+przy minimalnym zu¿yciu pamiêci, by³ bardzo wydajny.
 
 %package -n python-mx-Tools
 Summary:       Some handy functions and objects which provides new builtins for Python
+Summary(pl):   Kilka u¿ytecznych klas i funkcji w postaci wew. mechanizmów Pythona
 Group:         Development/Languages/Python
 Group(de):     Entwicklung/Sprachen/Python
 Group(pl):     Programowanie/Jêzyki/Python
+%requires_eq   python
 Requires:      python-%{module} = %{version}
 
 %description -n python-mx-Tools
@@ -134,13 +176,25 @@ be available to all users at your site as if they were installed in
 the Python interpreter itself.
 
 %description -l pl -n python-mx-Tools
-N/A
+Pakiet mxTools zawiera kilka u¿ytecznych klas i funkcji, które daj±
+wiêcej mo¿liwo¶ci programi¶cie, w postaci wewnêtrznych mechanizmów
+jêzyka Python.
+
+Pakiet ten instaluje, jako mechanizmy wewnêtrzne Pythona, wszystkie
+funkcje i klasy po ich pierwszym do³±czeniu do kodu. Oznacza to, ¿e s±
+one dostêpne dla innych modu³ów bez jakichkolwiek dodatkowych
+zabiegów. Wystarczy dodaæ liniê "import mx.Tools.NewBuiltins" do
+odpowiedniego skryptu (site.py) i zdefiniowane funkcje oraz klasy bêd±
+widoczne dla wszystkich u¿ytkowników tak, jak by by³y wbudowane w
+jêzyk Python.
 
 %package -n python-mx-Proxy
 Summary:       Support for Bastion like implementations for Python
+Summary(pl):   Wsparcie dla implementacji typu Bastion dla jêzyka Python
 Group:         Development/Languages/Python
 Group(de):     Entwicklung/Sprachen/Python
 Group(pl):     Programowanie/Jêzyki/Python
+%requires_eq   python
 Requires:      python-%{module} = %{version}
 
 %description -n python-mx-Proxy
@@ -159,13 +213,26 @@ references which help you work with circular references in a way that
 doesn't cause memory leakage in a Python system.
 
 %description -l pl -n python-mx-Proxy
-N/A
+Pakiet mxProxy dostarcza nowe klasy, które implementuj± funkcjonalno¶æ
+typu Bastion bez potrzeby ograniczania ¶rodowiska, w którym jest
+wykonywana aplikacja.
+
+Podstawowymi zaletami s±: bezpieczne obudowywanie danych (ukryte
+obiekty nie s± dostêpne z poziomu Pythona, poniewa¿ s± one
+przechowywane w wewnêtrznych strukturach jêzyka C), konfigurowalne
+metody do pobierania warto¶ci atrybutów oraz protokó³, który pomaga w
+rozbijaniu zapêtlonych referencji podczas usuwania obiektów.
+
+Ostatnia wersja pakietu implementuje tzw. s³abe referencje, które nie
+powoduj± wycieków pamiêci w przypadku referencji zapêtlonych.
 
 %package -n python-mx-BeeBase
 Summary:       High performance construction kit for disk based indexed databases (B+Tree)
+Summary(pl):   Wysokiej jako¶ci pakiet do tworzenia indeksowanych baz danych (B+Tree)
 Group:         Development/Languages/Python
 Group(de):     Entwicklung/Sprachen/Python
 Group(pl):     Programowanie/Jêzyki/Python
+%requires_eq   python
 Requires:      python-%{module} = %{version}
 
 %description -n python-mx-BeeBase
@@ -183,7 +250,17 @@ optimized B+Tree implementation built on top of Thomas Niemann's
 Cookbook B+Tree implementation.
 
 %description -l pl -n python-mx-BeeBase
-N/A
+mxBeeBase jest wysokiej jako¶ci pakietem do tworzenia indeksowanych
+baz danych. Zawiera komponenty, które mo¿na razem ³±czyæ w celu
+zbudowania w³asnej bazy. Obecny limit ilo¶ci danych wynosi 2GB (max.
+warto¶æ liczby ca³kowitej typu long na platformach 32 bitowych).
+
+Dwoma podstawowymi komponentami w tym pakiecie s± indeksy oraz
+rekordy. Rekord mo¿e byæ zmiennej d³ugo¶ci i zawiera mechanizmy
+ochrony, automatycznego odzyskiwania, blokowania, a tak¿e
+wieloprocesowego dostêpu do danych. Do indeksowania s± u¿ywane bardzo
+wydajne B-drzewa zaimplementowane na podstawie Cookbook B+Tree Thomasa
+Newmanna.
 
 %prep
 %setup -q -n %{module}-%{version}
@@ -204,80 +281,80 @@ rm -rf $RPM_BUILD_ROOT
 %defattr(644,root,root,755)
 %doc *.gz mx/*.gz mx/Doc/*.gz mx/Doc/mx{Extensions,License}.html
 %dir %{mxdir}
-%{mxdir}/*.py?
+%{mxdir}/*.py[co]
 
 %dir %{mxdir}/Misc
-%{mxdir}/Misc/*.py?
+%{mxdir}/Misc/*.py[co]
 
 %files -n python-mx-DateTime
 %defattr(644,root,root,755)
 %doc mx/DateTime/Doc/*.html
 %dir %{mxdir}/DateTime
-%{mxdir}/DateTime/*.py?
+%{mxdir}/DateTime/*.py[co]
 
 %dir %{mxdir}/DateTime/mxDateTime
-%{mxdir}/DateTime/mxDateTime/*.py?
+%{mxdir}/DateTime/mxDateTime/*.py[co]
 %attr(755,root,root) %{mxdir}/DateTime/mxDateTime/*.so
 
 %files -n python-mx-TextTools
 %defattr(644,root,root,755)
 %doc mx/TextTools/Doc/*.html
 %dir %{mxdir}/TextTools
-%{mxdir}/TextTools/*.py?
+%{mxdir}/TextTools/*.py[co]
 
 %dir %{mxdir}/TextTools/mxTextTools
-%{mxdir}/TextTools/mxTextTools/*.py?
+%{mxdir}/TextTools/mxTextTools/*.py[co]
 %attr(755,root,root) %{mxdir}/TextTools/mxTextTools/*.so
 
 %dir %{mxdir}/TextTools/Constants
-%{mxdir}/TextTools/Constants/*.py?
+%{mxdir}/TextTools/Constants/*.py[co]
 
 %files -n python-mx-Stack
 %defattr(644,root,root,755)
 %doc mx/Stack/Doc/*.html
 %dir %{mxdir}/Stack
-%{mxdir}/Stack/*.py?
+%{mxdir}/Stack/*.py[co]
 
 %dir %{mxdir}/Stack/mxStack
-%{mxdir}/Stack/mxStack/*.py?
+%{mxdir}/Stack/mxStack/*.py[co]
 %attr(755,root,root) %{mxdir}/Stack/mxStack/*.so
 
 %files -n python-mx-Queue
 %defattr(644,root,root,755)
 %doc mx/Queue/Doc/*.html
 %dir %{mxdir}/Queue
-%{mxdir}/Queue/*.py?
+%{mxdir}/Queue/*.py[co]
 
 %dir %{mxdir}/Queue/mxQueue
-%{mxdir}/Queue/mxQueue/*.py?
+%{mxdir}/Queue/mxQueue/*.py[co]
 %attr(755,root,root) %{mxdir}/Queue/mxQueue/*.so
 
 %files -n python-mx-Tools
 %defattr(644,root,root,755)
 %doc mx/Tools/Doc/*.html
 %dir %{mxdir}/Tools
-%{mxdir}/Tools/*.py?
+%{mxdir}/Tools/*.py[co]
 
 %dir %{mxdir}/Tools/mxTools
-%{mxdir}/Tools/mxTools/*.py?
+%{mxdir}/Tools/mxTools/*.py[co]
 %attr(755,root,root) %{mxdir}/Tools/mxTools/*.so
 
 %files -n python-mx-Proxy
 %defattr(644,root,root,755)
 %doc mx/Proxy/Doc/*.html
 %dir %{mxdir}/Proxy
-%{mxdir}/Proxy/*.py?
+%{mxdir}/Proxy/*.py[co]
 
 %dir %{mxdir}/Proxy/mxProxy
-%{mxdir}/Proxy/mxProxy/*.py?
+%{mxdir}/Proxy/mxProxy/*.py[co]
 %attr(755,root,root) %{mxdir}/Proxy/mxProxy/*.so
 
 %files -n python-mx-BeeBase
 %defattr(644,root,root,755)
 %doc mx/BeeBase/Doc/*.html
 %dir %{mxdir}/BeeBase
-%{mxdir}/BeeBase/*.py?
+%{mxdir}/BeeBase/*.py[co]
 
 %dir %{mxdir}/BeeBase/mxBeeBase
-%{mxdir}/BeeBase/mxBeeBase/*.py?
+%{mxdir}/BeeBase/mxBeeBase/*.py[co]
 %attr(755,root,root) %{mxdir}/BeeBase/mxBeeBase/*.so
This page took 0.30532 seconds and 4 git commands to generate.