]> git.pld-linux.org Git - packages/python-alabaster.git/blame_incremental - python-alabaster.spec
- rebuild with python 3.8
[packages/python-alabaster.git] / python-alabaster.spec
... / ...
CommitLineData
1#
2# Conditional build:
3%bcond_without python2 # CPython 2.x module
4%bcond_without python3 # CPython 3.x module
5
6%define module alabaster
7Summary: A configurable sidebar-enabled Sphinx theme
8Summary(pl.UTF-8): Konfigurowany motyw z bocznym panelem dla Sphinksa
9Name: python-%{module}
10Version: 0.7.11
11Release: 2
12License: BSD
13Group: Libraries/Python
14#Source0Download: https://pypi.org/simple/alabaster/
15Source0: https://files.pythonhosted.org/packages/source/a/alabaster/%{module}-%{version}.tar.gz
16# Source0-md5: a23493869f819326a7f62deb7dbdb849
17URL: https://pypi.org/project/alabaster/
18BuildRequires: rpm-pythonprov
19BuildRequires: rpmbuild(macros) >= 1.714
20%if %{with python2}
21BuildRequires: python-devel >= 1:2.6
22BuildRequires: python-setuptools >= 7.0
23%endif
24%if %{with python3}
25BuildRequires: python3-devel >= 1:3.2
26BuildRequires: python3-modules >= 1:3.2
27BuildRequires: python3-setuptools >= 7.0
28%endif
29Requires: python-modules >= 1:2.6
30BuildArch: noarch
31BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
32
33%description
34A configurable sidebar-enabled Sphinx theme.
35
36This theme is a modified "Kr" Sphinx theme from @kennethreitz
37(especially as used in his Requests project), which was itself
38originally based on @mitsuhiko's theme used for Flask & related
39projects.
40
41%description -l pl.UTF-8
42Konfigurowany motyw z bocznym panelem (sidebarem) dla Sphinksa.
43
44Motyw ten to zmodyfikowany motyw Sphinksa "Kr" od @kennethreitz
45(konkretnie wersja używana w jego projekcie Requests), pierwotnie
46oparty na motywie @mitsuhiko używanym w projekcie Flash i powiązanych
47z nim.
48
49%package -n python3-%{module}
50Summary: A configurable sidebar-enabled Sphinx theme
51Summary(pl.UTF-8): Konfigurowany motyw z bocznym panelem dla Sphinksa
52Group: Libraries/Python
53Requires: python3-modules >= 1:3.2
54
55%description -n python3-%{module}
56A configurable sidebar-enabled Sphinx theme
57
58This theme is a modified "Kr" Sphinx theme from @kennethreitz
59(especially as used in his Requests project), which was itself
60originally based on @mitsuhiko's theme used for Flask & related
61projects.
62
63%description -n python3-%{module} -l pl.UTF-8
64Konfigurowany motyw z bocznym panelem (sidebarem) dla Sphinksa.
65
66Motyw ten to zmodyfikowany motyw Sphinksa "Kr" od @kennethreitz
67(konkretnie wersja używana w jego projekcie Requests), pierwotnie
68oparty na motywie @mitsuhiko używanym w projekcie Flash i powiązanych
69z nim.
70
71%prep
72%setup -q -n %{module}-%{version}
73
74%build
75%if %{with python2}
76%py_build %{?with_tests:test}
77%endif
78
79%if %{with python3}
80%py3_build %{?with_tests:test}
81%endif
82
83%install
84rm -rf $RPM_BUILD_ROOT
85
86%if %{with python2}
87%py_install
88
89%py_postclean
90%endif
91
92%if %{with python3}
93%py3_install
94%endif
95
96%clean
97rm -rf $RPM_BUILD_ROOT
98
99%if %{with python2}
100%files
101%defattr(644,root,root,755)
102%doc LICENSE README.rst
103%{py_sitescriptdir}/%{module}
104%{py_sitescriptdir}/%{module}-%{version}-py*.egg-info
105%endif
106
107%if %{with python3}
108%files -n python3-%{module}
109%defattr(644,root,root,755)
110%doc LICENSE README.rst
111%{py3_sitescriptdir}/%{module}
112%{py3_sitescriptdir}/%{module}-%{version}-py*.egg-info
113%endif
This page took 0.141278 seconds and 4 git commands to generate.