]> git.pld-linux.org Git - packages/pth.git/blame - pth.spec
- builds on th
[packages/pth.git] / pth.spec
CommitLineData
2ce2ce2f
PS
1#
2# Conditional build:
3%bcond_without tests # don't perform "make test"
b3f5b1d2 4%bcond_with pthread # build pthread library (POSIX.1c threading API of GNU Pth)
2ce2ce2f 5#
ca78a697 6Summary: The GNU portable threads
b683f2cb 7Summary(pl.UTF-8): Przenośne wątki GNU
ca78a697 8Name: pth
baa86086 9Version: 2.0.7
7b9d8103 10Release: 5
9cb3b0d1 11Epoch: 1
f618825c 12License: LGPL
ca78a697 13Group: Libraries
5b420f4c 14Source0: http://ftp.gnu.org/gnu/pth/%{name}-%{version}.tar.gz
baa86086 15# Source0-md5: 9cb4a25331a4c4db866a31cbe507c793
1666767f 16Patch0: %{name}-nolibs.patch
726cbc64 17URL: http://www.gnu.org/software/pth/
1666767f 18BuildRequires: autoconf >= 2.52
10cfbc5d 19BuildRequires: automake
1666767f 20BuildRequires: libtool
ca78a697
JK
21BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
22
baa86086
JB
23# -fno-strict-aliasing" because mainly pth_mctx.c contains important
24# and correct pointer casting constructs which are not acceptable
25# in "strict aliasing" for GCC.
26%define specflags -fno-strict-aliasing
27
ca78a697
JK
28%description
29Pth is a very portable POSIX/ANSI-C based library for Unix platforms
30which provides non-preemptive priority-based scheduling for multiple
31threads of execution (aka `multithreading') inside event-driven
32applications. All threads run in the same address space of the server
33application, but each thread has its own individual program-counter,
34run-time stack, signal mask and errno variable.
35
5a6ec335
JR
36%description -l pl.UTF-8
37pth jest bardzo przenośną biblioteką bazującą na POSIX/ANSI-C dla
38platform uniksowych, bazujące na priorytetach dzielenie czasu bez
39wywłaszczenia dla wielu wątków (czyli wielowątkowość) wewnątrz
40aplikacji sterowanych zdarzeniami. Wszystkie wątki działają w tej
41samej przestrzeni adresowej aplikacji serwera, ale każdy ma swój
42własny licznik instrukcji, stos, maski sygnałów i zmienną errno.
0cde0dbe 43
ca78a697
JK
44%package devel
45Summary: Header files and development documentation for pth
b683f2cb 46Summary(pl.UTF-8): Pliki nagłówkowe i dokumentacja do pth
ca78a697 47Group: Development/Libraries
b3f5b1d2 48Requires: %{name} = %{epoch}:%{version}-%{release}
ca78a697
JK
49
50%description devel
51Header files and development documentation for pth.
52
5a6ec335
JR
53%description devel -l pl.UTF-8
54Pliki nagłówkowe i dokumentacja programisty do pth.
0cde0dbe 55
ca78a697
JK
56%package static
57Summary: Static version of the GNU portable threads library
b683f2cb 58Summary(pl.UTF-8): Statyczna wersja biblioteki pth
ca78a697 59Group: Development/Libraries
b3f5b1d2 60Requires: %{name}-devel = %{epoch}:%{version}-%{release}
ca78a697
JK
61
62%description static
63Static version of the GNU portable threads library.
64
5a6ec335
JR
65%description static -l pl.UTF-8
66Statyczna wersja biblioteki przenośnych wątków GNU.
0cde0dbe 67
ca78a697 68%prep
3ef7f27f 69%setup -q
1666767f 70%patch0 -p1
ad21a392
JB
71# no aclocal call: aclocal.m4 contains only local macros, libtool.m4 is included from configure.in
72cp -f /usr/share/automake/config.* /usr/share/aclocal/libtool.m4 .
7b9d8103
PZ
73mv aclocal.m4 local.m4
74
75%build
1666767f 76%{__libtoolize}
7b9d8103 77%{__aclocal} -I.
1666767f
JB
78%{__autoheader}
79%{__autoconf}
726cbc64
PS
80%configure \
81 %{?with_pthread:--enable-pthread} \
82 --enable-optimize
83
ca78a697 84%{__make}
2ce2ce2f 85%{?with_tests:%{__make} test}
ca78a697
JK
86
87%install
88rm -rf $RPM_BUILD_ROOT
89
745f1dd0 90%{__make} -j1 install \
b3f5b1d2 91 DESTDIR=$RPM_BUILD_ROOT
ca78a697 92
ca78a697
JK
93%clean
94rm -rf $RPM_BUILD_ROOT
95
c0c70046 96%post -p /sbin/ldconfig
97%postun -p /sbin/ldconfig
ca78a697
JK
98
99%files
100%defattr(644,root,root,755)
b3f5b1d2
JB
101# COPYING contains not only LGPL text
102%doc ANNOUNCE AUTHORS COPYING ChangeLog HISTORY NEWS README SUPPORT TESTS THANKS USERS
7b9d8103
PZ
103%attr(755,root,root) %{_libdir}/libpth.so.*.*.*
104%attr(755,root,root) %ghost %{_libdir}/libpth.so.20
ca78a697
JK
105
106%files devel
107%defattr(644,root,root,755)
b3f5b1d2 108%doc HACKING
ca78a697 109%attr(755,root,root) %{_bindir}/*
7b9d8103 110%attr(755,root,root) %{_libdir}/libpth.so
db221ef2 111%{_libdir}/lib*.la
726cbc64
PS
112%{_aclocaldir}/pth.m4
113%{_includedir}/*.h
ca78a697
JK
114%{_mandir}/man3/*
115%{_mandir}/man1/*
116
117%files static
118%defattr(644,root,root,755)
119%{_libdir}/lib*.a
This page took 0.081542 seconds and 4 git commands to generate.