]> git.pld-linux.org Git - packages/procps.git/blobdiff - procps.spec
- versioned Obsoletes
[packages/procps.git] / procps.spec
index 3e6ed9f3ac5bd5319c34b723e73e9411e83e9c03..9dc1b6ef89cd8ab9e9190cdba83606915bad36e7 100644 (file)
@@ -6,6 +6,7 @@
 # Conditional build:
 %bcond_without systemd         # systemd support
 %bcond_with    elogind         # elogind support (instead of systemd)
+%bcond_with    pidof           # include pidof here [see also SysVinit.spec:SysVinit-tools
 %bcond_with    selinux         # libselinux support (get ps context values from dynamically loaded libselinux.so.1 instead of /proc/*/attr/current)
 %bcond_with    tests           # run tests. The testsuite is unsuitable for running on buildsystems
 
@@ -20,20 +21,20 @@ Summary(pl.UTF-8):  Narzędzia do monitorowania procesów
 Summary(pt_BR.UTF-8):  Utilitários de monitoração de processos
 Summary(tr.UTF-8):     Süreç izleme araçları
 Name:          procps
-Version:       3.3.15
+Version:       4.0.4
 Release:       1
 Epoch:         1
 License:       GPL v2+
 Group:         Applications/System
-Source0:       http://downloads.sourceforge.net/procps-ng/%{name}-ng-%{version}.tar.xz
-# Source0-md5: 2b0717a7cb474b3d6dfdeedfbad2eccc
+Source0:       https://downloads.sourceforge.net/procps-ng/%{name}-ng-%{version}.tar.xz
+# Source0-md5: 2f747fc7df8ccf402d03e375c565cf96
 Source1:       %{name}-non-english-man-pages.tar.bz2
 # Source1-md5: 60d24720b76c10553ed4abf68b76e079
 Source2:       top.desktop
 Source3:       top.png
 # Source3-md5: 5f0133b3c18000116ca48381eecc07af
 Source4:       XConsole.sh
-Patch0:                %{name}-missing-symbol.patch
+
 Patch1:                %{name}-FILLBUG_backport.patch
 Patch2:                %{name}-pl.po-update.patch
 URL:           https://gitlab.com/procps-ng/procps
@@ -48,12 +49,13 @@ BuildRequires:      ncurses-devel >= 5.1
 BuildRequires: pkgconfig
 BuildRequires: rpmbuild(macros) >= 1.402
 BuildRequires: sed >= 4.0
-%{?with_systemd:BuildRequires: systemd-devel >= 1:206}
+%{?with_systemd:BuildRequires: systemd-devel >= 1:254}
 BuildRequires: tar >= 1:1.22
 BuildRequires: xz
 Requires:      /sbin/ldconfig
 Requires:      fileutils
-Obsoletes:     procps-X11
+%{?with_systemd:Requires:      systemd-libs >= 1:254}
+Obsoletes:     procps-X11 < 2.0.2
 BuildRoot:     %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
 
 %description
@@ -144,8 +146,8 @@ Static version of libproc library.
 Statyczna wersja biblioteki libproc.
 
 %prep
-%setup -qn %{name}-ng-%{version}
-%patch0 -p1
+%setup -q -n %{name}-ng-%{version}
+
 %patch1 -p1
 %patch2 -p1
 
@@ -162,8 +164,9 @@ Statyczna wersja biblioteki libproc.
        --disable-silent-rules \
        %{?with_elogind:--with-elogind} \
        %{?with_systemd:--with-systemd} \
+       --disable-kill \
        %{?with_selinux:--enable-libselinux} \
-       --disable-pidof \
+       %{!?with_pidof:--disable-pidof} \
        --enable-sigwinch \
        --enable-skill \
        --enable-w-from \
@@ -183,26 +186,26 @@ install -d $RPM_BUILD_ROOT{%{_desktopdir},%{_pixmapsdir},/%{_lib},/bin}
        DESTDIR=$RPM_BUILD_ROOT \
        pkgconfigdir=%{_pkgconfigdir}
 
-# identical binaries are copied, not linked:
+# identical programs are built independently, not hard- or symlinked:
 ln -f $RPM_BUILD_ROOT%{_bindir}/{pkill,pgrep}
 ln -f $RPM_BUILD_ROOT%{_bindir}/{snice,skill}
 
 %{__mv} $RPM_BUILD_ROOT{%{_bindir},/bin}/ps
+%if %{with pidof}
+%{__mv} $RPM_BUILD_ROOT{%{_bindir},/bin}/pidof
+%endif
 
 install -d $RPM_BUILD_ROOT/%{_lib}
-%{__mv} $RPM_BUILD_ROOT{%{_libdir}/libprocps.so.*,/%{_lib}}
-ln -sf /%{_lib}/$(basename $RPM_BUILD_ROOT/%{_lib}/libprocps.so.*.*.*) \
-        $RPM_BUILD_ROOT%{_libdir}/libprocps.so
+%{__mv} $RPM_BUILD_ROOT{%{_libdir}/libproc2.so.*,/%{_lib}}
+ln -sf /%{_lib}/$(basename $RPM_BUILD_ROOT/%{_lib}/libproc2.so.*.*.*) \
+        $RPM_BUILD_ROOT%{_libdir}/libproc2.so
 
 cp -p %{SOURCE2} $RPM_BUILD_ROOT%{_desktopdir}
 cp -p %{SOURCE3} $RPM_BUILD_ROOT%{_pixmapsdir}
 install -p %{SOURCE4} $RPM_BUILD_ROOT%{_bindir}/XConsole
 
-# PLD: kill is packaged in util-linux
-%{__rm} $RPM_BUILD_ROOT%{_bindir}/kill
-%{__rm} $RPM_BUILD_ROOT%{_mandir}/man1/kill.1
 # obsoleted by pkg-config
-%{__rm} $RPM_BUILD_ROOT%{_libdir}/libprocps.la
+%{__rm} $RPM_BUILD_ROOT%{_libdir}/libproc2.la
 # packaged as doc
 %{__rm} -r $RPM_BUILD_ROOT%{_docdir}/procps-ng
 
@@ -220,16 +223,20 @@ rm -rf $RPM_BUILD_ROOT
 
 %files -f procps-ng.lang
 %defattr(644,root,root,755)
-%doc AUTHORS Documentation/{FAQ,TODO,bugs.md} NEWS
-%attr(755,root,root) /%{_lib}/libprocps.so.*.*
-%ghost %attr(755,root,root) /%{_lib}/libprocps.so.7
+%doc AUTHORS doc/{FAQ,TODO,bugs.md} NEWS
+%attr(755,root,root) /%{_lib}/libproc2.so.*.*
+%ghost %attr(755,root,root) /%{_lib}/libproc2.so.0
 %attr(755,root,root) /bin/ps
+%if %{with pidof}
+%attr(755,root,root) /bin/pidof
+%endif
 %attr(755,root,root) /sbin/sysctl
 %attr(755,root,root) %{_bindir}/XConsole
 %attr(755,root,root) %{_bindir}/free
 %attr(755,root,root) %{_bindir}/pgrep
 %attr(755,root,root) %{_bindir}/pkill
 %attr(755,root,root) %{_bindir}/pmap
+%attr(755,root,root) %{_bindir}/pidwait
 %attr(755,root,root) %{_bindir}/pwdx
 %attr(755,root,root) %{_bindir}/skill
 %attr(755,root,root) %{_bindir}/slabtop
@@ -243,11 +250,14 @@ rm -rf $RPM_BUILD_ROOT
 %{_desktopdir}/top.desktop
 %{_pixmapsdir}/top.png
 %{_mandir}/man1/free.1*
+%if %{with pidof}
+%{_mandir}/man1/pidof.1*
+%endif
 %{_mandir}/man1/pgrep.1*
 %{_mandir}/man1/pkill.1*
 %{_mandir}/man1/pmap.1*
-%{_mandir}/man1/procps.1*
 %{_mandir}/man1/ps.1*
+%{_mandir}/man1/pidwait.1*
 %{_mandir}/man1/pwdx.1*
 %{_mandir}/man1/skill.1*
 %{_mandir}/man1/slabtop.1*
@@ -271,16 +281,32 @@ rm -rf $RPM_BUILD_ROOT
 %lang(ko) %{_mandir}/ko/man[158]/*
 %lang(nl) %{_mandir}/nl/man[158]/*
 %lang(pl) %{_mandir}/pl/man[158]/*
+%lang(pt_BR) %{_mandir}/pt_BR/man[158]/*
+%lang(ro) %{_mandir}/ro/man[158]/*
+%lang(sv) %{_mandir}/sv/man[158]/*
+%lang(uk) %{_mandir}/uk/man[158]/*
 
 %files devel
 %defattr(644,root,root,755)
-%attr(755,root,root) %{_libdir}/libprocps.so
-%{_includedir}/proc
-%{_pkgconfigdir}/libprocps.pc
-%{_mandir}/man3/openproc.3*
-%{_mandir}/man3/readproc.3*
-%{_mandir}/man3/readproctab.3*
+%attr(755,root,root) %{_libdir}/libproc2.so
+%{_includedir}/libproc2
+%{_pkgconfigdir}/libproc2.pc
+%{_mandir}/man3/procps.3*
+%{_mandir}/man3/procps_misc.3*
+%{_mandir}/man3/procps_pids.3*
+%lang(pl) %{_mandir}/pl/man3/procps.3*
+%lang(pl) %{_mandir}/pl/man3/procps_misc.3*
+%lang(pl) %{_mandir}/pl/man3/procps_pids.3*
+%lang(ro) %{_mandir}/ro/man3/procps.3*
+%lang(ro) %{_mandir}/ro/man3/procps_misc.3*
+%lang(ro) %{_mandir}/ro/man3/procps_pids.3*
+%lang(sv) %{_mandir}/sv/man3/procps.3*
+%lang(sv) %{_mandir}/sv/man3/procps_misc.3*
+%lang(sv) %{_mandir}/sv/man3/procps_pids.3*
+%lang(uk) %{_mandir}/uk/man3/procps.3*
+%lang(uk) %{_mandir}/uk/man3/procps_misc.3*
+%lang(uk) %{_mandir}/uk/man3/procps_pids.3*
 
 %files static
 %defattr(644,root,root,755)
-%{_libdir}/libprocps.a
+%{_libdir}/libproc2.a
This page took 0.176536 seconds and 4 git commands to generate.