]> git.pld-linux.org Git - packages/postgresql.git/blobdiff - postgresql-link.patch
- llvm bcond
[packages/postgresql.git] / postgresql-link.patch
index 98cfb56c45944cfe260df5079f119634a228fa65..032f381e2a173a484b92ed655b943247fbf2a6cd 100644 (file)
@@ -1,36 +1,39 @@
---- postgresql-7.4beta1/configure.in.orig      2003-08-05 00:30:30.000000000 +0200
-+++ postgresql-7.4beta1/configure.in   2003-08-09 08:01:18.000000000 +0200
-@@ -614,12 +614,13 @@
+--- postgresql-9.5.0/configure.in.orig   2018-02-21 03:23:25.335399998 +0100
++++ postgresql-9.5.0/configure.in        2018-02-21 03:28:24.392066743 +0100
+@@ -1203,6 +1203,7 @@
  
- if test "$PORTNAME" != "aix" -a "$PORTNAME" != "alpha"
- then
--      AC_CHECK_LIB(bsd,      main)
-+:
-+dnl   AC_CHECK_LIB(bsd,      main)
+ if test "$with_bonjour" = yes ; then
+   AC_CHECK_HEADER(dns_sd.h, [], [AC_MSG_ERROR([header file <dns_sd.h> is required for Bonjour])])
++  AC_CHECK_LIB(dns_sd, DNSServiceRegister, [BONJOUR_LIBS=-ldns_sd])
+ dnl At some point we might add something like
+ dnl AC_SEARCH_LIBS(DNSServiceRegister, dns_sd)
+ dnl but right now, what that would mainly accomplish is to encourage
+@@ -1210,6 +1211,7 @@
+ dnl If you want to use Apple's own Bonjour code on another platform,
+ dnl just add -ldns_sd to LIBS manually.
  fi
- AC_CHECK_LIB(util,     setproctitle)
- AC_CHECK_LIB(m,        main)
- AC_CHECK_LIB(dl,       main)
--AC_CHECK_LIB(nsl,      main)
-+dnl AC_CHECK_LIB(nsl,      main)
- AC_CHECK_LIB(socket,   main)
- AC_CHECK_LIB(ipc,      main)
- AC_CHECK_LIB(IPC,      main)
-@@ -630,6 +631,6 @@
- AC_CHECK_LIB(BSD,      main)
- AC_CHECK_LIB(gen,      main)
- AC_CHECK_LIB(PW,       main)
--AC_CHECK_LIB(resolv,   main)
-+dnl AC_CHECK_LIB(resolv,   main)
- AC_SEARCH_LIBS(getopt_long, [getopt gnugetopt])
- # QNX:
-@@ -639,7 +640,8 @@
- # BeOS:
- if test "$PORTNAME" = "beos"
- then
--      AC_CHECK_LIB(bind, __inet_ntoa)
-+      dnl AC_CHECK_LIB(bind, __inet_ntoa)
-+      AC_CHECK_FUNC(inet_ntoa, ,[AC_CHECK_LIB(bind,     __inet_ntoa)]) 
- fi
- # Solaris:
- AC_SEARCH_LIBS(fdatasync, [rt posix4])
++AC_SUBST([BONJOUR_LIBS])
+ # for contrib/uuid-ossp
+ if test "$with_uuid" = bsd ; then
+--- postgresql-9.5.0/src/backend/Makefile.orig 2016-01-04 22:29:34.000000000 +0100
++++ postgresql-9.5.0/src/backend/Makefile      2016-01-14 21:10:48.093976872 +0100
+@@ -54,7 +54,7 @@
+ ifneq ($(PORTNAME), aix)
+ postgres: $(OBJS)
+-      $(CC) $(CFLAGS) $(LDFLAGS) $(LDFLAGS_EX) $(export_dynamic) $(call expand_subsys,$^) $(LIBS) -o $@
++      $(CC) $(CFLAGS) $(LDFLAGS) $(LDFLAGS_EX) $(export_dynamic) $(call expand_subsys,$^) $(LIBS) $(BONJOUR_LIBS) -o $@
+ endif
+ endif
+--- postgresql-9.5.0/src/Makefile.global.in.orig       2016-01-04 22:29:34.000000000 +0100
++++ postgresql-9.5.0/src/Makefile.global.in    2016-01-14 21:11:50.820640805 +0100
+@@ -216,6 +216,7 @@
+ PTHREAD_CFLAGS                = @PTHREAD_CFLAGS@
+ PTHREAD_LIBS          = @PTHREAD_LIBS@
++BONJOUR_LIBS            = @BONJOUR_LIBS@
+ ##########################################################################
+ #
This page took 0.100054 seconds and 4 git commands to generate.