]> git.pld-linux.org Git - packages/poldek.git/blobdiff - poldek.spec
disable "auto directory dependencies" on rpm.org
[packages/poldek.git] / poldek.spec
index 9f8a89e9aa3e49937093f74f1cf082704f6d0610..e9ed27e359900d9e607e2ab253a1b27c33d333fc 100644 (file)
@@ -5,13 +5,13 @@
 # Conditional build:
 %bcond_with    static  # don't use shared libraries
 %bcond_without imode   # don't build interactive mode
-%bcond_without python  # don't build python bindings
+%bcond_with    python  # don't build python bindings
 %bcond_with    snap    # install configs for official Th snapshot
 %bcond_with    rpm4    # use rpm4 instead of rpm5
 %bcond_with    tests   # tests
 
 # current snapshot name
-%define                SNAP    2019
+%define                SNAP    2020
 
 # required versions (forced to avoid SEGV with mixed db used by rpm and poldek)
 %if %{with rpm4}
@@ -25,7 +25,7 @@
 %define                ver_rpm         5.4.10
 %endif
 
-%define                rel     2
+%define                rel     4
 Summary:       RPM packages management helper tool
 Summary(hu.UTF-8):     RPM csomagkezelést segítő eszköz
 Summary(pl.UTF-8):     Pomocnicze narzędzie do zarządzania pakietami RPM
@@ -55,6 +55,17 @@ Patch0:              %{name}-config.patch
 Patch1:                pm-hooks.patch
 Patch2:                %{name}-ext-down-enable.patch
 Patch3:                %{name}-pc.patch
+Patch4:                %{name}-info.patch
+Patch5:                %{name}-multiarch-x32.patch
+Patch6:                rpm-4.15.patch
+Patch7:                db-index-format.patch
+Patch8:                rpm4-uname-deps.patch
+Patch9:                sqlite-rpmdb.patch
+Patch10:       rpm4-cpuinfo-deps.patch
+Patch11:       rpm4-no-dir-deps.patch
+Patch12:       rpm4-rpmvercmp.patch
+Patch13:       trurlib-shared.patch
+Patch14:       rpm4-script-req-workaround.patch
 URL:           http://poldek.pld-linux.org/
 BuildRequires: %{db_pkg}-devel >= %{ver_db}
 BuildRequires: autoconf >= 2.63
@@ -62,6 +73,7 @@ BuildRequires:        automake >= 1:1.11
 BuildRequires: bzip2-devel
 BuildRequires: check-devel
 BuildRequires: docbook-dtd412-xml
+BuildRequires: docbook2X
 BuildRequires: gettext-tools >= 0.11.5
 BuildRequires: libgomp-devel
 BuildRequires: libtool
@@ -69,6 +81,9 @@ BuildRequires:        libxml2-devel >= 2
 BuildRequires: ncurses-devel
 BuildRequires: openssl-devel >= 0.9.7d
 BuildRequires: pcre-devel
+BuildRequires: perl-XML-Simple
+BuildRequires: perl-base
+BuildRequires: perl-modules
 BuildRequires: pkgconfig
 BuildRequires: popt-devel
 %{?with_python:BuildRequires:  python-devel}
@@ -76,6 +91,7 @@ BuildRequires:        readline-devel >= 5.0
 BuildRequires: rpm-devel >= %{ver_rpm}
 %{?with_python:BuildRequires:  rpm-pythonprov}
 BuildRequires: tar >= 1:1.22
+BuildRequires: texinfo
 BuildRequires: xmlto
 BuildRequires: xz
 BuildRequires: zlib-devel
@@ -94,8 +110,8 @@ BuildRequires:       rpm-static
 BuildRequires: zlib-static
 BuildRequires: zstd-static
 %endif
-Requires(triggerpostun):       awk
-Requires(triggerpostun):       sed >= 4.0
+Requires(postun):      awk
+Requires(postun):      sed >= 4.0
 %if %{with rpm4}
 Requires:      %{db_pkg} >= %{ver_db_devel}
 %else
@@ -227,7 +243,21 @@ Moduły języka Python dla poldka.
 %patch1 -p1
 %patch2 -p1
 %patch3 -p1
+%patch4 -p1
+%patch5 -p1
+%patch6 -p1
+%patch7 -p1
+%patch8 -p1
+%patch9 -p1
+%patch10 -p1
+%patch11 -p1
+%patch12 -p1
+cd trurlib
+%patch13 -p1
+cd ..
+%patch14 -p1
 
+%{__rm} doc/poldek.info
 %{__rm} m4/libtool.m4 m4/lt*.m4
 
 # cleanup backups after patching
@@ -263,6 +293,8 @@ cd ..
        %{?with_python:--with-python}
 %{__make}
 
+%{__make} -C doc poldek.info
+
 %if %{with python}
 %{__make} -C python
 %endif
@@ -288,7 +320,7 @@ install -p %{SOURCE3} $RPM_BUILD_ROOT%{_bindir}/poldek-config
 
 %{?with_static:%{__rm} $RPM_BUILD_ROOT%{_bindir}/rpmvercmp}
 
-%ifarch i486 i686 ppc sparc alpha athlon
+%ifarch i486 i686 ppc sparc alpha athlon aarch64
        %define         ftp_arch        %{_target_cpu}
 %endif
 %ifarch %{x8664}
@@ -441,7 +473,8 @@ fi
 %post  libs -p /sbin/ldconfig
 %postun        libs -p /sbin/ldconfig
 
-%triggerpostun -- poldek < 0.30-0.20080225.00.1
+%triggerpostun -- poldek < 0.30.1-8
+# poldek < 0.30-0.20080225.00.1
 if ! grep -q '^%%includedir repos.d' %{_sysconfdir}/%{name}/poldek.conf; then
        %{__sed} -i -e '/^%%include source.conf/{
                a
@@ -464,8 +497,7 @@ if [ -f %{_sysconfdir}/%{name}/pld-multilib-source.conf.rpmsave ]; then
        %{__mv} -v %{_sysconfdir}/%{name}/pld-multilib-source.conf.rpmsave %{_sysconfdir}/%{name}/repos.d/pld-multilib.conf
 fi
 %endif
-
-%triggerpostun -- poldek < 0.30.1-3
+# poldek < 0.30.1-3
 if [ -f %{_sysconfdir}/%{name}/repos.d/pld-multilib.conf.rpmsave ]; then
        %{__mv} -f %{_sysconfdir}/%{name}/repos.d/pld-%{ftp_alt_arch}.conf{,.rpmnew}
        %{__mv} -v %{_sysconfdir}/%{name}/repos.d/pld-multilib.conf.rpmsave %{_sysconfdir}/%{name}/repos.d/pld-%{ftp_alt_arch}.conf
@@ -474,8 +506,7 @@ if [ -f %{_sysconfdir}/%{name}/repos.d/pld-%{SNAP}-multilib.conf.rpmsave ]; then
        %{__mv} -f %{_sysconfdir}/%{name}/repos.d/pld-%{SNAP}-%{ftp_alt_arch}.conf{,.rpmnew}
        %{__mv} -v %{_sysconfdir}/%{name}/repos.d/pld-%{SNAP}-multilib.conf.rpmsave %{_sysconfdir}/%{name}/repos.d/pld-%{SNAP}-%{ftp_alt_arch}.conf
 fi
-
-%triggerpostun -- %{name} < 0.30.1-8
+# poldek < 0.30.1-8
 if [ $1 -le 1 ]; then
        # revert change on  --downgrade
        %{__sed} -i -re 's,^pm command = %{pkglibexecdir}/pm-command.sh,#&,' %{_sysconfdir}/%{name}/%{name}.conf
This page took 0.118086 seconds and 4 git commands to generate.