]> git.pld-linux.org Git - packages/poldek.git/blobdiff - poldek.spec
- take rpm-db-ver from rpm-lib instead from rpm package
[packages/poldek.git] / poldek.spec
index 393a9ba8ee1a663df48a816f68ed4a5972008f45..55802ae93bca32066a38ed26b9633b45ae536200 100644 (file)
@@ -8,7 +8,7 @@
 %bcond_without python  # don't build python bindings
 %bcond_with    snap    # install configs for official Th snapshot
 %bcond_with    rpm4    # use rpm4 instead of rpm5
-%bcond_without tests   # tests
+%bcond_with    tests   # tests
 
 # current snapshot name
 %define                SNAP    2019
@@ -20,7 +20,7 @@
 %define                ver_rpm         1:4.14
 %define                ver_db_devel    %(rpm -q --qf '%|E?{%{E}:}|%{V}-%{R}' --what-provides db-devel)
 %else
-%define                ver_db          %(rpm -q --provides rpm | %{__sed} -ne 's/^rpm-db-ver = \\([.0-9]*\\)$/\\1/p')
+%define                ver_db          %(rpm -q --provides rpm-lib | %{__sed} -ne 's/^rpm-db-ver = \\([.0-9]*\\)$/\\1/p')
 %define                db_pkg          db%{ver_db}
 %define                ver_rpm         5.4.10
 %endif
@@ -30,13 +30,13 @@ Summary:    RPM packages management helper tool
 Summary(hu.UTF-8):     RPM csomagkezelést segítő eszköz
 Summary(pl.UTF-8):     Pomocnicze narzędzie do zarządzania pakietami RPM
 Name:          poldek
-Version:       0.42.0
+Version:       0.42.1
 Release:       %{rel}%{?with_snap:.%{SNAP}}
 License:       GPL v2
 Group:         Applications/System
 #Source0:      http://poldek.pld-linux.org/download/snapshots/%{name}-%{version}-cvs%{snap}.tar.bz2
 Source0:       https://github.com/poldek-pm/poldek/releases/download/v%{version}/%{name}-%{version}.tar.xz
-# Source0-md5: f224a4f62cdedf0d8bcfe0ce6dd533b2
+# Source0-md5: 528a7678db243f4e09fa77682d00852a
 Source1:       %{name}.conf
 Source2:       %{name}-multilib.conf
 Source3:       %{name}-config.sh
@@ -73,7 +73,6 @@ BuildRequires:        pkgconfig
 BuildRequires: popt-devel
 %{?with_python:BuildRequires:  python-devel}
 BuildRequires: readline-devel >= 5.0
-BuildRequires: rpm >= %{ver_rpm}
 BuildRequires: rpm-devel >= %{ver_rpm}
 %{?with_python:BuildRequires:  rpm-pythonprov}
 BuildRequires: tar >= 1:1.22
@@ -111,7 +110,8 @@ Requires:   sed
 Conflicts:     etckeeper < 1.18-2
 BuildRoot:     %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
 
-%define                _libexecdir     %{_prefix}/lib/%{name}
+# it could be %{_libexecdir}/%{name}, but beware of compatibility (path hardcoded in configurations)
+%define                pkglibexecdir   %{_prefix}/lib/%{name}
 
 %description
 poldek is an RPM package management tool which allows you to easily
@@ -258,11 +258,10 @@ cd ..
 %configure \
        %{?with_static:--enable-static --disable-shared} \
        %{!?with_imode:--disable-imode} \
-       --with-pkglibdir=%{_libexecdir} \
+       --with-pkglibdir=%{pkglibexecdir} \
        --enable-nls \
        %{?with_python:--with-python}
 %{__make}
-#      --enable-trace
 
 %if %{with python}
 %{__make} -C python
@@ -479,10 +478,10 @@ fi
 %triggerpostun -- %{name} < 0.30.1-8
 if [ $1 -le 1 ]; then
        # revert change on  --downgrade
-       %{__sed} -i -re 's,^pm command = %{_libexecdir}/pm-command.sh,#&,' %{_sysconfdir}/%{name}/%{name}.conf
+       %{__sed} -i -re 's,^pm command = %{pkglibexecdir}/pm-command.sh,#&,' %{_sysconfdir}/%{name}/%{name}.conf
 else
        # setup pm command
-       %{__sed} -i -re 's,#?(pm command =).*,\1 %{_libexecdir}/pm-command.sh,' %{_sysconfdir}/%{name}/%{name}.conf
+       %{__sed} -i -re 's,#?(pm command =).*,\1 %{pkglibexecdir}/pm-command.sh,' %{_sysconfdir}/%{name}/%{name}.conf
 fi
 
 %files -f %{name}.lang
@@ -500,13 +499,13 @@ fi
 %attr(755,root,root) %{_bindir}/poldek
 %attr(755,root,root) %{_bindir}/poldek-config
 %attr(755,root,root) %{_bindir}/rpmvercmp
-%dir %{_libexecdir}
-%attr(755,root,root) %{_libexecdir}/pm-command.sh
-%attr(755,root,root) %{_libexecdir}/poldekuser-setup.sh
-%attr(755,root,root) %{_libexecdir}/vfcompr
-%attr(755,root,root) %{_libexecdir}/vfjuggle
-%attr(755,root,root) %{_libexecdir}/vfsmb
-%attr(755,root,root) %{_libexecdir}/zlib-in-rpm.sh
+%dir %{pkglibexecdir}
+%attr(755,root,root) %{pkglibexecdir}/pm-command.sh
+%attr(755,root,root) %{pkglibexecdir}/poldekuser-setup.sh
+%attr(755,root,root) %{pkglibexecdir}/vfcompr
+%attr(755,root,root) %{pkglibexecdir}/vfjuggle
+%attr(755,root,root) %{pkglibexecdir}/vfsmb
+%attr(755,root,root) %{pkglibexecdir}/zlib-in-rpm.sh
 %{_mandir}/man1/%{name}*.1*
 %lang(pl) %{_mandir}/pl/man1/%{name}*
 %{_infodir}/poldek.info*
This page took 0.033795 seconds and 4 git commands to generate.