]> git.pld-linux.org Git - packages/poldek.git/blame - poldek.spec
- release 4 (by relup.sh)
[packages/poldek.git] / poldek.spec
CommitLineData
7638abfc 1#
de1099c4 2# Conditional build:
9fe14a3f 3%bcond_with static # don't use shared libraries
4%bcond_without imode # don't build interactive mode
58c31de0 5%bcond_without python # don't build python bindings
cf6c3a30 6%bcond_with snap # install configs for official Th snapshot
6e185c37 7%bcond_with db60 # DB 6.0 instead of 5.2
7000d724 8
e1015166 9# current snapshot name
eb211d09 10%define SNAP 2013
a584c5c5 11
373c6f03 12# required versions (forced to avoid SEGV with mixed db used by rpm and poldek)
6e185c37
JB
13# NOTE: poldek links with "system db" (-ldb) anyway if it exists
14%if %{with db60}
15%define db_pkg db6.0
16%define ver_db 6.0
17%define ver_db_rel 1
18%else
ff4e68af 19%define db_pkg db5.2
376a705c 20%define ver_db 5.2
19e679c6 21%define ver_db_rel 3
6e185c37 22%endif
a17726b5 23%define ver_rpm 5.4.10
7000d724 24
6a81b7fe 25%define rel 4
b44549bf 26Summary: RPM packages management helper tool
9c03ea8f 27Summary(hu.UTF-8): RPM csomagkezelést segítő eszköz
9faf625a 28Summary(pl.UTF-8): Pomocnicze narzędzie do zarządzania pakietami RPM
b44549bf 29Name: poldek
c9a1a81d 30Version: 0.30.0
9c1c2b52 31Release: %{rel}%{?with_snap:.%{SNAP}}
9f931ada 32License: GPL v2
8efee472 33Group: Applications/System
85398bac 34#Source0: http://poldek.pld-linux.org/download/snapshots/%{name}-%{version}-cvs%{snap}.tar.bz2
e5009a66
MB
35Source0: http://carme.pld-linux.org/~megabajt/releases/poldek/%{name}-%{version}.tar.xz
36# Source0-md5: 392cfa125912fbedb6cc6d54dfbb80e3
911a8560 37Source1: %{name}.conf
b25cb9a7 38Source2: %{name}-multilib.conf
2ccd5d66 39Source5: %{name}-aliases.conf
40Source6: %{name}.desktop
41Source7: %{name}.png
171e07f6 42Source8: %{name}-debuginfo.conf
652b5bc5 43Source9: %{name}-aidath.conf
44Source10: %{name}-multilib-aidath.conf
8db66c11 45Source11: %{name}-archive.conf
a584c5c5
JR
46Source100: %{name}-snap.conf
47Source101: %{name}-multilib-snap.conf
48Source102: %{name}-debuginfo-snap.conf
e5009a66
MB
49Patch0: %{name}-size-type.patch
50Patch1: %{name}-Os-fail-workaround.patch
9c1c2b52 51Patch2: %{name}-config.patch
39ca2371 52URL: http://poldek.pld-linux.org/
340a1e21 53BuildRequires: %{db_pkg}-devel >= %{ver_db}-%{ver_db_rel}
a4268952 54BuildRequires: autoconf
4d0dcbcf 55BuildRequires: automake >= 1:1.11
373c6f03 56BuildRequires: bzip2-devel
065b86e0 57BuildRequires: check-devel
1d67e563 58BuildRequires: docbook-dtd412-xml
f77a8b4c 59BuildRequires: gettext-devel
b25cb9a7
JB
60BuildRequires: libtool
61BuildRequires: libxml2-devel
fc37ede0 62BuildRequires: neon-devel
cbc6f56b 63BuildRequires: openssl-devel >= 0.9.7d
13fd950e 64BuildRequires: pcre-devel
b3ea4b51 65BuildRequires: pkgconfig
13fd950e 66BuildRequires: popt-devel
58c31de0 67%{?with_python:BuildRequires: python-devel}
b25cb9a7 68BuildRequires: readline-devel >= 5.0
373c6f03 69BuildRequires: rpm-devel >= %{ver_rpm}
300927eb 70%{?with_python:BuildRequires: rpm-pythonprov}
65a99b8b 71BuildRequires: swig-python
340a1e21 72BuildRequires: tar >= 1:1.22
77cfda6e 73BuildRequires: xmlto
340a1e21 74BuildRequires: xz
96475e5e 75BuildRequires: zlib-devel
373c6f03 76%if %{with static}
ff4e68af 77BuildRequires: %{db_pkg}-static >= %{ver_db}-%{ver_db_rel}
340a1e21 78BuildRequires: bzip2-static
2fac0b02 79BuildRequires: glibc-static
acb26797 80BuildRequires: libselinux-static
b25cb9a7 81BuildRequires: libxml2-static
373c6f03
JB
82BuildRequires: ncurses-static
83BuildRequires: openssl-static
84BuildRequires: pcre-static
85BuildRequires: popt-static
86BuildRequires: readline-static
87BuildRequires: rpm-static
88BuildRequires: zlib-static
373c6f03 89%endif
b25cb9a7 90Requires(triggerpostun): awk
168acc54 91Requires(triggerpostun): sed >= 4.0
ff4e68af 92Requires: %{db_pkg} >= %{ver_db}-%{ver_db_rel}
340a1e21 93Requires: %{name}-libs = %{version}-%{release}
373c6f03 94Requires: rpm >= %{ver_rpm}
530c8c41 95Requires: rpm-db-ver = %{ver_db}
7d3144d4
JR
96#Requires: rpm-lib = %(rpm -q --qf '%{V}' rpm-lib)
97Requires: rpm-lib >= 5.4.10
e202a52a
ER
98# vf* scripts use sed
99Requires: sed
b44549bf 100BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
101
dcdcebb7
ER
102%define _libexecdir %{_prefix}/lib/%{name}
103
b44549bf 104%description
0fa0dc36 105poldek is an RPM package management tool which allows you to easily
106perform package verification, installation (including system
13fd950e 107installation from scratch), upgrading, and removal.
0fa0dc36 108
13fd950e
JB
109Program can be used in batch (like apt-get from Debian's APT) or
110interactive mode. The interactive mode puts you into a readline
111interface with command line autocompletion and history, similar to the
112shell mode of Perl's CPAN.
8efee472 113
9fe14a3f 114%{?with_static:This version is statically linked.}
d94b28a6 115
9fe14a3f 116%{!?with_imode:This version hasn't got interactive mode.}
7f07e487 117#'vim
1f84648f 118
9c03ea8f
ZU
119%description -l hu.UTF-8
120poldek egy RPM csomagkezelő eszköz, amely megkönnyíti a
121csomagellenőrzést, telepítést (beleértve a rendszertelepítést a
122nulláról), frissítést és eltávolítást.
123
124A program használható parancssorból (mint a Debian apt-get programja)
125vagy interaktív módban. Az interaktív mód egy readline környezetet
126jelent, parancskiegészítéssel és előzményekkel, hasonlóan a Perl CPAN
127shell módjához.
128
129%{?with_static:Ez a verzió statikusan linkelt.}
130
131%{!?with_imode:Ennek a verziónak nincs interaktív módja.}
132
caed9b36
JR
133%description -l pl.UTF-8
134poldek jest narzędziem linii poleceń służącym do weryfikacji,
135instalacji (włączając instalację systemu od zera), aktualizacji i
136usuwania pakietów.
56e1ab51 137
caed9b36 138Program może być używany w trybie wsadowym (jak debianowy apt-get) lub
d82a9cb2 139interaktywnym. Tryb interaktywny posiada interfejs readline z
caed9b36
JR
140dopełnianiem komend i historią, podobny do trybu shell perlowego
141modułu CPAN.
8efee472 142
9fe14a3f 143%{?with_static:Ta wersja jest konsolidowana statycznie.}
a611e0bc 144
9fe14a3f 145%{!?with_imode:Ta wersja nie posiada trybu interaktywnego.}
b44549bf 146
b25cb9a7 147%package libs
168acc54 148Summary: poldek libraries
9c03ea8f 149Summary(hu.UTF-8): A poldek könyvtárai
9faf625a 150Summary(pl.UTF-8): Biblioteki poldka
168acc54 151Group: Libraries
b25cb9a7
JB
152
153%description libs
154poldek libraries.
155
9c03ea8f
ZU
156%description libs -l hu.UTF-8
157A poldek könyvtárai.
158
caed9b36 159%description libs -l pl.UTF-8
b25cb9a7
JB
160Biblioteki poldka.
161
162%package devel
168acc54 163Summary: Header files for poldek libraries
9c03ea8f 164Summary(hu.UTF-8): A poldek könyvtár fejlesztői fájljai
9faf625a 165Summary(pl.UTF-8): Pliki nagłówkowe bibliotek poldka
168acc54 166Group: Development/Libraries
09d4c571 167Requires: %{name}-libs = %{version}-%{release}
b980560b 168Requires: rpm-devel >= %{ver_rpm}
b25cb9a7
JB
169
170%description devel
171Header files for poldek libraries.
172
9c03ea8f
ZU
173%description devel -l hu.UTF-8
174A poldek könyvtár fejlesztői fájljai.
175
caed9b36
JR
176%description devel -l pl.UTF-8
177Pliki nagłówkowe bibliotek poldka.
b25cb9a7
JB
178
179%package static
168acc54 180Summary: poldek static libraries
9c03ea8f 181Summary(hu.UTF-8): poldek statikus könyvtárak
9faf625a 182Summary(pl.UTF-8): Biblioteki statyczne poldka
168acc54 183Group: Development/Libraries
09d4c571 184Requires: %{name}-devel = %{version}-%{release}
b25cb9a7
JB
185
186%description static
187poldek static libraries.
188
9c03ea8f
ZU
189%description static -l hu.UTF-8
190poldek statikus könyvtárak.
191
caed9b36 192%description static -l pl.UTF-8
b25cb9a7
JB
193Biblioteki statyczne poldka.
194
58c31de0
JB
195%package -n python-poldek
196Summary: Python modules for poldek
9c03ea8f 197Summary(hu.UTF-8): Python modulok poldek-hez
9faf625a 198Summary(pl.UTF-8): Moduły języka Python dla poldka
58c31de0
JB
199Group: Libraries/Python
200Requires: %{name}-libs = %{version}-%{release}
340a1e21 201Requires: python-libs
58c31de0
JB
202
203%description -n python-poldek
204Python modules for poldek.
205
9c03ea8f
ZU
206%description -n python-poldek -l hu.UTF-8
207Python modulok poldek-hez.
208
caed9b36
JR
209%description -n python-poldek -l pl.UTF-8
210Moduły języka Python dla poldka.
58c31de0 211
03159b71 212%prep
a9c9446a 213%setup -q
85398bac 214%patch0 -p1
13aa6434 215%patch1 -p1
9c1c2b52 216%patch2 -p1
8dcb75fc 217
5e2c5cc3 218%{__rm} m4/libtool.m4 m4/lt*.m4
b44549bf 219
0579f9b7
ER
220# cleanup backups after patching
221find . '(' -name '*~' -o -name '*.orig' ')' -print0 | xargs -0 -r -l512 rm -f
4fa2b79c 222chmod u+x ./configure ./doc/conf-xml2.sh
0579f9b7 223
b44549bf 224%build
bef9d2a3 225%{__libtoolize}
21a83253 226%{__aclocal} -I m4
d878a63c 227%{__autoheader}
21a83253
MM
228%{__autoconf}
229%{__automake}
f8e81a61 230cd tndb
313cd172 231%{__libtoolize}
5e2c5cc3
JB
232%{__aclocal}
233%{__autoheader}
234%{__autoconf}
235%{__automake}
f8e81a61 236cd ../trurlib
313cd172 237%{__libtoolize}
5e2c5cc3
JB
238%{__aclocal}
239%{__autoheader}
240%{__autoconf}
241%{__automake}
f8e81a61 242cd ..
b25cb9a7 243
5e2c5cc3 244CPPFLAGS="%{rpmcppflags} -std=gnu99"
1f84648f 245%configure \
b25cb9a7 246 %{?with_static:--enable-static --disable-shared} \
9fe14a3f 247 %{!?with_imode:--disable-imode} \
dcdcebb7 248 --with-pkglibdir=%{_libexecdir} \
58c31de0
JB
249 --enable-nls \
250 %{?with_python:--with-python}
9fb594dc 251%{__make} -j1
a1f22296 252# --enable-trace
8efee472 253
b44549bf 254%install
255rm -rf $RPM_BUILD_ROOT
27edf30a 256install -d $RPM_BUILD_ROOT{%{_sysconfdir}/%{name}/repos.d,/var/cache/%{name}}
8efee472 257
9fb594dc 258%{__make} install -j1 \
c8f7d829 259 DESTDIR=$RPM_BUILD_ROOT
de1099c4 260
58c31de0 261%if %{with python}
9fb594dc 262%{__make} -C python -j1 install \
58c31de0
JB
263 DESTDIR=$RPM_BUILD_ROOT \
264 libdir=%{py_sitedir}
265%endif
266
5e2c5cc3 267%{?with_static:%{__rm} $RPM_BUILD_ROOT%{_bindir}/rpmvercmp}
a49836bb 268
9639596f 269%ifarch i486 i686 ppc sparc alpha athlon
23ead09a 270 %define _ftp_arch %{_target_cpu}
36004ea3 271%endif
9639596f 272%ifarch %{x8664}
23ead09a
ER
273 %define _ftp_arch x86_64
274 %define _ftp_alt_arch i686
36004ea3 275%endif
9639596f 276%ifarch i586
b614e8f7 277 %define _ftp_arch i486
58820d9b 278%endif
a49836bb 279%ifarch pentium2 pentium3 pentium4
23ead09a 280 %define _ftp_arch i686
36004ea3 281%endif
a49836bb 282%ifarch sparcv9 sparc64
23ead09a 283 %define _ftp_arch sparc
b614e8f7
JR
284 %define _ftp_arch %{_target_cpu}
285 %ifarch sparc64
23ead09a 286 %define _ftp_alt_arch sparcv9
23ead09a 287 %endif
652b5bc5 288%endif
32697bd0 289
b614e8f7
JR
290%define pld_conf %{SOURCE1}
291%define pld_debuginfo_conf %{SOURCE8}
292%define pld_archive_conf %{SOURCE11}
7c0e4fc5 293
b614e8f7
JR
294%ifarch %{x8664}
295 %define pld_multilib_conf %{SOURCE2}
296%endif
7c0e4fc5 297
b614e8f7
JR
298# aidath
299%ifarch sparcv9 sparc64
300 %define pld_conf %{SOURCE9}
301 %undefine pld_archive_conf
302%endif
303%ifarch sparc64
304 %define pld_multilib_conf %{SOURCE10}
7c0e4fc5 305%endif
23ead09a 306
c88cf671 307%{__sed} -e 's|%%ARCH%%|%{_ftp_arch}|g' < %{pld_conf} > $RPM_BUILD_ROOT%{_sysconfdir}/%{name}/repos.d/pld.conf
23ead09a 308
7c0e4fc5 309%if 0%{?pld_multilib_conf:1}
c88cf671 310 %{__sed} 's|%%ARCH%%|%{_ftp_alt_arch}|g' < %{pld_multilib_conf} > $RPM_BUILD_ROOT%{_sysconfdir}/%{name}/repos.d/pld-multilib.conf
7c0e4fc5
ER
311%endif
312
313%if 0%{?pld_debuginfo_conf:1}
c88cf671 314%{__sed} -e 's|%%ARCH%%|%{_ftp_arch}|g' < %{pld_debuginfo_conf} > $RPM_BUILD_ROOT%{_sysconfdir}/%{name}/repos.d/pld-debuginfo.conf
652b5bc5 315%endif
b25cb9a7 316
8db66c11 317%if 0%{?pld_archive_conf:1}
c88cf671 318%{__sed} -e 's|%%ARCH%%|%{_ftp_arch}|g' < %{pld_archive_conf} > $RPM_BUILD_ROOT%{_sysconfdir}/%{name}/repos.d/pld-archive.conf
8db66c11
ER
319%endif
320
7e5296f4 321# Always install snapshot configs
c88cf671 322%{__sed} -e 's|%%ARCH%%|%{_ftp_arch}|g' \
a584c5c5 323 -e 's|%%SNAP%%|%{SNAP}|g' < %{SOURCE100} > $RPM_BUILD_ROOT%{_sysconfdir}/%{name}/repos.d/pld-%{SNAP}.conf
c88cf671 324%{__sed} -e 's|%%ARCH%%|%{_ftp_arch}|g' \
a584c5c5
JR
325 -e 's|%%SNAP%%|%{SNAP}|g' < %{SOURCE102} > $RPM_BUILD_ROOT%{_sysconfdir}/%{name}/repos.d/pld-%{SNAP}-debuginfo.conf
326%ifarch %{x8664}
c88cf671 327 %{__sed} -e 's|%%ARCH%%|%{_ftp_alt_arch}|g' \
a584c5c5
JR
328 -e 's|%%SNAP%%|%{SNAP}|g' < %{SOURCE101} > $RPM_BUILD_ROOT%{_sysconfdir}/%{name}/repos.d/pld-%{SNAP}-multilib.conf
329%endif
7e5296f4
JR
330
331%if %{with snap}
c88cf671 332%{__sed} -i -e 's|@@SNAP@@||g' $RPM_BUILD_ROOT%{_sysconfdir}/%{name}/repos.d/pld.conf
7e5296f4 333%{__sed} -i '/@@SNAP@@.*/d' $RPM_BUILD_ROOT%{_sysconfdir}/%{name}/repos.d/pld-%{SNAP}.conf
a584c5c5 334%else
7e5296f4 335%{__sed} -i -e 's|@@SNAP@@||g' $RPM_BUILD_ROOT%{_sysconfdir}/%{name}/repos.d/pld-%{SNAP}.conf
c88cf671 336%{__sed} -i '/@@SNAP@@.*/d' $RPM_BUILD_ROOT%{_sysconfdir}/%{name}/repos.d/pld.conf
a584c5c5
JR
337%endif
338
27edf30a 339cp -p %{SOURCE5} $RPM_BUILD_ROOT%{_sysconfdir}/%{name}/cli.conf
b25cb9a7 340
9e6ff4ef 341%if %{with imode}
342# add desktop file and icon
343install -d $RPM_BUILD_ROOT{%{_desktopdir},%{_pixmapsdir}}
27edf30a
ER
344cp -p %{SOURCE6} $RPM_BUILD_ROOT%{_desktopdir}/%{name}.desktop
345cp -p %{SOURCE7} $RPM_BUILD_ROOT%{_pixmapsdir}/%{name}.png
9e6ff4ef 346%endif
347
b43abde7 348# sources we don't package
5e2c5cc3 349%{__rm} $RPM_BUILD_ROOT%{_sysconfdir}/%{name}/{rh,fedora,centos}-source.conf
b25cb9a7 350# include them in %doc
c88cf671 351%{__rm} -rf configs
b25cb9a7 352cp -a conf configs
c88cf671 353%{__rm} -f configs/Makefile*
b25cb9a7 354
62e80071 355%if %{with python}
58c31de0 356%py_postclean
5e2c5cc3 357%{__rm} $RPM_BUILD_ROOT%{py_sitedir}/_poldekmod.la
62e80071 358%endif
58c31de0 359
b25cb9a7 360%find_lang %{name}
f373d903 361
b44549bf 362%clean
363rm -rf $RPM_BUILD_ROOT
364
daf0e7ce
ER
365%post
366[ ! -x /usr/sbin/fix-info-dir ] || /usr/sbin/fix-info-dir -c %{_infodir} >/dev/null 2>&1
367if [ "$1" = "1" ]; then
368 # remove ignore = vserver-packages inside vserver on first install
369 {
370 while read f ctx; do
371 [ "$f" = "VxID:" -o "$f" = "s_context:" ] && break
372 done </proc/self/status
373 } 2>/dev/null
374 if [ -z "$ctx" -o "$ctx" = "0" ]; then
375 VSERVER=no
376 else
377 VSERVER=yes
378 fi
379 if [ "$VSERVER" = "yes" ]; then
380 %{__sed} -i -e '/^ignore/s/vserver-packages//' %{_sysconfdir}/%{name}/poldek.conf
381 fi
382fi
b25cb9a7 383
3896c8b1
ER
384%postun -p /sbin/postshell
385-/usr/sbin/fix-info-dir -c %{_infodir}
b25cb9a7
JB
386
387%post libs -p /sbin/ldconfig
388%postun libs -p /sbin/ldconfig
389
b25cb9a7
JB
390%triggerpostun -- poldek < 0.19.0-1.20050613.22.0
391if [ -f /etc/poldek.conf.rpmsave ]; then
392 awk '/^source/ {
393 name = $3;
394 path = $4;
395 auto = "yes";
396 autoup = "yes";
397 type = "pdir";
f154dd55 398 pri = "";
b25cb9a7
JB
399
400 if (sub(",noauto", "", name)) {
401 auto = "no";
402 }
403
f154dd55
ER
404 # process pri=\d+
405 if (match(name, /,pri=[0-9]+/)) {
406 pri = substr(name, RSTART + 5, RLENGTH - 5);
407 name = substr(name, 1, RSTART - 1) substr(name, RSTART + RLENGTH);
408 }
409
b25cb9a7
JB
410 # skip ac sources. already in new config.
411 if (name !~ /^ac(-(ready|test|supported|updates-(general|security)))?$/) {
412 print "";
413 print "[source]";
414 print "name = " name;
415 print "type = " type;
416 print "path = " path;
417 print "auto = " auto;
418 print "autoup = " autoup;
f154dd55
ER
419 if (pri) {
420 print "pri = " pri;
421 }
b25cb9a7
JB
422 }
423
424 }' < /etc/poldek.conf.rpmsave >> /etc/poldek/source.conf
19cae196 425 echo "Converted old custom sources from /etc/poldek.conf.rpmsave to new poldek format in /etc/poldek/source.conf"
b25cb9a7
JB
426
427 # copy hold=
428 hold=$(grep ^hold /etc/poldek.conf.rpmsave)
429 if [ "$hold" ]; then
c88cf671 430 %{__sed} -i -e "/^#hold =/s/^.*/$hold/" /etc/poldek/poldek.conf
b25cb9a7
JB
431 fi
432fi
433
b43abde7
ER
434%triggerpostun -- poldek < 0.30-0.20080225.00.1
435if ! grep -q '^%%includedir repos.d' %{_sysconfdir}/%{name}/poldek.conf; then
436 %{__sed} -i -e '/^%%include source.conf/{
437 a
438 a# /etc/poldek/repos.d/*.conf
439 a%%includedir repos.d
440 }' %{_sysconfdir}/%{name}/poldek.conf
441fi
442
443%{__sed} -i -e '/%%include %%{_distro}-source.conf/d' %{_sysconfdir}/%{name}/poldek.conf
444%{__sed} -i -e '/%%include %%{_distro}-multilib-source.conf/d' %{_sysconfdir}/%{name}/poldek.conf
445
446if [ -f %{_sysconfdir}/%{name}/pld-source.conf.rpmsave ]; then
447 cp -f %{_sysconfdir}/%{name}/repos.d/pld.conf{,.rpmnew}
478b6a69 448 cp -f %{_sysconfdir}/%{name}/pld-source.conf.rpmsave %{_sysconfdir}/%{name}/repos.d/pld.conf
b43abde7
ER
449fi
450
451%ifarch %{x8664}
452if [ -f %{_sysconfdir}/%{name}/pld-multilib-source.conf.rpmsave ]; then
453 cp -f %{_sysconfdir}/%{name}/repos.d/pld-multilib.conf{,.rpmnew}
478b6a69 454 cp -f %{_sysconfdir}/%{name}/pld-multilib-source.conf.rpmsave %{_sysconfdir}/%{name}/repos.d/pld-multilib.conf
b43abde7
ER
455fi
456%endif
457
767366b0 458%files -f %{name}.lang
b44549bf 459%defattr(644,root,root,755)
a9c9446a 460%doc ChangeLog README* NEWS TODO configs
b25cb9a7 461%dir %{_sysconfdir}/%{name}
08335479 462%dir %{_sysconfdir}/%{name}/repos.d
168acc54 463%config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/%{name}/*.conf
b43abde7 464%config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/%{name}/repos.d/*.conf
5e2c5cc3
JB
465%attr(755,root,root) %{_bindir}/ipoldek
466%attr(755,root,root) %{_bindir}/poldek
467%attr(755,root,root) %{_bindir}/rpmvercmp
dcdcebb7
ER
468%dir %{_libexecdir}
469%attr(755,root,root) %{_libexecdir}/*
5e2c5cc3 470%{_mandir}/man1/%{name}*.1*
d8826405 471%lang(pl) %{_mandir}/pl/man1/%{name}*
b25cb9a7 472%{_infodir}/poldek.info*
9e6ff4ef 473%if %{with imode}
474%{_desktopdir}/%{name}.desktop
475%{_pixmapsdir}/%{name}.png
476%endif
27edf30a 477%dir /var/cache/%{name}
b25cb9a7 478
b43abde7 479%if %{without static}
b25cb9a7
JB
480%files libs
481%defattr(644,root,root,755)
d8aeff9a
MB
482%attr(755,root,root) %{_libdir}/libpoclidek.so.*.*.*
483%attr(755,root,root) %{_libdir}/libpoldek.so.*.*.*
484%attr(755,root,root) %{_libdir}/libtndb.so.*.*.*
485%attr(755,root,root) %{_libdir}/libtrurl.so.*.*.*
486%attr(755,root,root) %{_libdir}/libvfile.so.*.*.*
487%attr(755,root,root) %ghost %{_libdir}/libpoclidek.so.0
488%attr(755,root,root) %ghost %{_libdir}/libpoldek.so.2
489%attr(755,root,root) %ghost %{_libdir}/libtndb.so.0
490%attr(755,root,root) %ghost %{_libdir}/libtrurl.so.0
491%attr(755,root,root) %ghost %{_libdir}/libvfile.so.0
b25cb9a7
JB
492%endif
493
494%files devel
495%defattr(644,root,root,755)
5e2c5cc3
JB
496%if %{without static}
497%attr(755,root,root) %{_libdir}/libpoclidek.so
498%attr(755,root,root) %{_libdir}/libpoldek.so
499%attr(755,root,root) %{_libdir}/libtndb.so
500%attr(755,root,root) %{_libdir}/libtrurl.so
501%attr(755,root,root) %{_libdir}/libvfile.so
502%endif
503%{_libdir}/libpoclidek.la
504%{_libdir}/libpoldek.la
505%{_libdir}/libtndb.la
506%{_libdir}/libtrurl.la
507%{_libdir}/libvfile.la
508%{_includedir}/poldek
509%{_includedir}/tndb
510%{_includedir}/trurl
511%{_includedir}/vfile
512%{_pkgconfigdir}/tndb.pc
c9a1a81d 513%{_pkgconfigdir}/trurlib.pc
b25cb9a7
JB
514
515%files static
516%defattr(644,root,root,755)
5e2c5cc3
JB
517%{_libdir}/libtndb.a
518%{_libdir}/libtrurl.a
58c31de0
JB
519
520%if %{with python}
521%files -n python-poldek
522%defattr(644,root,root,755)
523%attr(755,root,root) %{py_sitedir}/_poldekmod.so
524%{py_sitescriptdir}/poldek.py[co]
525%{py_sitescriptdir}/poldekmod.py[co]
526%endif
This page took 0.186949 seconds and 4 git commands to generate.