]> git.pld-linux.org Git - packages/plymouth.git/blobdiff - text-colors.patch
- point meson as /sbin and /bin to make it embed correct paths in systemd units,...
[packages/plymouth.git] / text-colors.patch
index d4e85980bcdabd1af91acbe82ccdd52fe8e018dd..0dfb91e67847aa73f2d5fd70f33aacc272b5baa1 100644 (file)
@@ -1,15 +1,61 @@
---- plymouth-0.8.4/src/plugins/splash/text/plugin.c~   2011-02-09 21:07:14.000000000 +0100
-+++ plymouth-0.8.4/src/plugins/splash/text/plugin.c    2012-04-27 12:56:30.461837997 +0200
-@@ -183,10 +183,10 @@
-                                     0xffffff);
-   ply_terminal_set_color_hex_value (terminal,
-                                     PLY_TERMINAL_COLOR_BLUE,
--                                    0x0073B3);
-+                                    PLYMOUTH_BACKGROUND_START_COLOR);
-   ply_terminal_set_color_hex_value (terminal,
-                                     PLY_TERMINAL_COLOR_BROWN,
--                                    0x00457E);
-+                                    PLYMOUTH_BACKGROUND_END_COLOR);
+--- plymouth-0.9.2/src/plugins/splash/tribar/plugin.c.orig     2015-05-24 21:32:03.443625675 +0200
++++ plymouth-0.9.2/src/plugins/splash/tribar/plugin.c  2015-05-24 21:35:09.136951216 +0200
+@@ -180,10 +180,10 @@
+                                           0xffffff);
+         ply_terminal_set_color_hex_value (terminal,
+                                           PLY_TERMINAL_COLOR_BLUE,
+-                                          0x0073B3);
++                                          PLYMOUTH_BACKGROUND_START_COLOR);
+         ply_terminal_set_color_hex_value (terminal,
+                                           PLY_TERMINAL_COLOR_BROWN,
+-                                          0x00457E);
++                                          PLYMOUTH_BACKGROUND_END_COLOR);
  
-   ply_text_display_set_background_color (view->display,
-                                          PLY_TERMINAL_COLOR_BLACK);
+         ply_text_display_set_background_color (view->display,
+                                                PLY_TERMINAL_COLOR_BLACK);
+--- plymouth-0.9.2/src/plugins/splash/text/plugin.c.orig       2015-05-24 21:32:03.446959010 +0200
++++ plymouth-0.9.2/src/plugins/splash/text/plugin.c    2015-05-24 21:36:36.543614214 +0200
+@@ -171,13 +171,13 @@
+         ply_terminal_set_color_hex_value (terminal,
+                                           PLY_TERMINAL_COLOR_BLACK,
+-                                          0x2e3436);
++                                          PLYMOUTH_BACKGROUND_START_COLOR);
+         ply_terminal_set_color_hex_value (terminal,
+                                           PLY_TERMINAL_COLOR_WHITE,
+                                           0xffffff);
+         ply_terminal_set_color_hex_value (terminal,
+                                           PLY_TERMINAL_COLOR_BROWN,
+-                                          0x979a9b);
++                                          PLYMOUTH_BACKGROUND_END_COLOR);
+         ply_text_display_set_background_color (view->display,
+                                                PLY_TERMINAL_COLOR_BLACK);
+--- plymouth-24.004.60/src/plugins/splash/tribar/meson.build.orig      2024-01-04 22:08:14.000000000 +0100
++++ plymouth-24.004.60/src/plugins/splash/tribar/meson.build   2024-02-17 09:44:34.175933648 +0100
+@@ -3,6 +3,11 @@ tribar_plugin = shared_module('tribar',
+   dependencies: [
+     libply_splash_core_dep,
+   ],
++  c_args: [
++    '-DPLYMOUTH_BACKGROUND_COLOR=@0@'.format(get_option('background-color')),
++    '-DPLYMOUTH_BACKGROUND_START_COLOR=@0@'.format(get_option('background-start-color-stop')),
++    '-DPLYMOUTH_BACKGROUND_END_COLOR=@0@'.format(get_option('background-end-color-stop')),
++  ],
+   include_directories: config_h_inc,
+   name_prefix: '',
+   install: true,
+--- plymouth-24.004.60/src/plugins/splash/text/meson.build.orig        2024-01-04 22:08:14.000000000 +0100
++++ plymouth-24.004.60/src/plugins/splash/text/meson.build     2024-02-17 09:41:08.590380734 +0100
+@@ -4,6 +4,11 @@ text_plugin = shared_module('text',
+     libply_splash_core_dep,
+     libply_splash_graphics_dep,
+   ],
++  c_args: [
++    '-DPLYMOUTH_BACKGROUND_COLOR=@0@'.format(get_option('background-color')),
++    '-DPLYMOUTH_BACKGROUND_START_COLOR=@0@'.format(get_option('background-start-color-stop')),
++    '-DPLYMOUTH_BACKGROUND_END_COLOR=@0@'.format(get_option('background-end-color-stop')),
++  ],
+   include_directories: config_h_inc,
+   name_prefix: '',
+   install: true,
This page took 0.159599 seconds and 4 git commands to generate.