]> git.pld-linux.org Git - packages/pidgin.git/blobdiff - pidgin.spec
up to 2.14.6
[packages/pidgin.git] / pidgin.spec
index 9daa19413b18b35682e4213c2bea3becbc3e1a1f..8edb8b821f14fbccbd073a3f9a2c8d759c794aac 100644 (file)
@@ -7,6 +7,7 @@
 %bcond_without doc             # Doxygen generated documentation
 %bcond_without cap             # Contact Availability Prediction plugin
 %bcond_without dbus            # D-Bus support (for pidgin-remote and others)
+%bcond_without gconf           # URL handler registration via GConf2
 %bcond_with    gnutls          # use GnuTLS instead of NSS
 %bcond_without gtkspell        # GtkSpell automatic spell checking
 %bcond_without nm              # NetworkManager support (requires D-Bus)
@@ -16,7 +17,7 @@
 %bcond_without vv              # Voice and Video support
 %bcond_without meanwhile       # meanwhile (Sametime protocol) support
 %bcond_without silc            # SILC protocol support
-%bcond_with    evolution       # Pidgin-Evolution plugin
+%bcond_without evolution       # Pidgin-Evolution plugin
 %bcond_without system_zephyr   # system installed Zephyr
 %bcond_with    unity           # Unity interface
 
@@ -25,7 +26,7 @@
 %endif
 
 %define                gtk2_ver        2.10.6
-%define                glib2_ver       2.26.0
+%define                glib2_ver       2.68.0
 
 Summary:       A GTK+ based multiprotocol instant messaging client
 Summary(de.UTF-8):     Pidgin ist ein Instant Messenger
@@ -34,18 +35,20 @@ Summary(ko.UTF-8):  AOL 인스턴트 메신저와 호환되는 클라이언트
 Summary(pl.UTF-8):     Oparty na GTK+ klient komunikatorów obsługujący wiele protokołów
 Summary(pt_BR.UTF-8):  Um cliente para o AOL Instant Messenger (AIM)
 Name:          pidgin
-Version:       2.14.4
+Version:       2.14.6
 Release:       1
 License:       GPL v2+
 Group:         Applications/Communications
 Source0:       https://downloads.sourceforge.net/pidgin/%{name}-%{version}.tar.bz2
-# Source0-md5: 9c25da082df1bd42bd1f345fe01d83d1
+# Source0-md5: bba0fd38ee1d8b9b725c4dbdc33e58e7
 Patch0:                %{name}-nolibs.patch
 Patch1:                %{name}-dbus-dir.patch
 Patch2:                %{name}-ca_file.patch
 URL:           http://www.pidgin.im/
+%if %{with gconf}
 BuildRequires: GConf2
 BuildRequires: GConf2-devel >= 2.16.0
+%endif
 %{?with_nm:BuildRequires:      NetworkManager-devel}
 BuildRequires: autoconf >= 2.50
 BuildRequires: automake >= 1:1.9
@@ -55,8 +58,7 @@ BuildRequires:        check >= 0.9.4
 %{?with_sasl:BuildRequires:    cyrus-sasl-devel}
 %{?with_dbus:BuildRequires:    dbus-devel >= 0.60}
 %{?with_dbus:BuildRequires:    dbus-glib-devel >= 0.71}
-%{?with_evolution:BuildRequires:       evolution-data-server-devel >= 1.8.1}
-%{?with_evolution:BuildRequires:       evolution-data-server-devel < 3.6}
+%{?with_evolution:BuildRequires:       evolution-data-server-devel >= 3.6}
 BuildRequires: farstream-devel >= 0.2.7
 BuildRequires: gettext-tools
 BuildRequires: glib2-devel >= 1:%{glib2_ver}
@@ -87,7 +89,7 @@ BuildRequires:        nss-devel
 %{?with_perl:BuildRequires:    perl-devel}
 BuildRequires: pkgconfig
 BuildRequires: protobuf-c-devel
-BuildRequires: python-modules >= 1:2.4
+BuildRequires: python3-modules >= 1:3.2
 %{?with_perl:BuildRequires:    rpm-perlprov}
 BuildRequires: rpm-pythonprov
 BuildRequires: rpmbuild(macros) >= 1.745
@@ -109,7 +111,7 @@ BuildRequires:      graphviz
 %endif
 Requires(post,postun): gtk-update-icon-cache
 Requires(post,postun): hicolor-icon-theme
-Requires(post,preun):  GConf2 >= 2.16.0
+%{?with_gconf:Requires(post,preun):    GConf2 >= 2.16.0}
 Requires:      gtk+2 >= 2:%{gtk2_ver}
 Requires:      hicolor-icon-theme
 Requires:      libpurple = %{version}-%{release}
@@ -249,6 +251,7 @@ Summary(hu.UTF-8):  Plugin az Evolution-ba beépítéséhez
 Summary(pl.UTF-8):     Wtyczka do integracji z Evolution
 Group:         Libraries
 Requires:      %{name} = %{version}-%{release}
+Requires:      evolution-data-server >= 3.6
 Obsoletes:     gaim-plugin-evolution < 2.0.1
 
 %description plugin-evolution
@@ -568,6 +571,7 @@ Obsługa protokołu Zephyr dla libpurple.
 %{__autoheader}
 %{__automake}
 %configure \
+       %{!?with_gconf:ac_cv_path_GCONFTOOL=no} \
        --enable-cap%{!?with_cap:=no} \
        --enable-consoleui%{!?with_text:=no} \
        %{?with_sasl:--enable-cyrus-sasl} \
@@ -639,7 +643,7 @@ done
 rm -rf $RPM_BUILD_ROOT
 
 %post
-%gconf_schema_install purple.schemas
+%{?with_gconf:%gconf_schema_install purple.schemas}
 %update_icon_cache hicolor
 if [ "$1" = 1 ]; then
 %banner %{name} -e <<-EOF
@@ -648,7 +652,7 @@ EOF
 fi
 
 %preun
-%gconf_schema_uninstall purple.schemas
+%{?with_gconf:%gconf_schema_uninstall purple.schemas}
 
 %postun
 %update_icon_cache hicolor
@@ -662,7 +666,7 @@ fi
 %files -f %{name}.lang
 %defattr(644,root,root,755)
 %doc AUTHORS ChangeLog{,.API} HACKING NEWS PLUGIN_HOWTO README*
-%{_sysconfdir}/gconf/schemas/purple.schemas
+%{?with_gconf:%{_sysconfdir}/gconf/schemas/purple.schemas}
 %attr(755,root,root) %{_bindir}/pidgin
 %dir %{_libdir}/pidgin
 %if %{with cap}
This page took 0.060354 seconds and 4 git commands to generate.