]> git.pld-linux.org Git - packages/phpMyAdmin.git/blobdiff - phpMyAdmin.spec
- updated to 4.8.5 (solves CVE-2019-6798, CVE-2019-6799)
[packages/phpMyAdmin.git] / phpMyAdmin.spec
index 5ef62439a0b3418b6f1aac732d66389c7a7a691f..6525123548d60c2fadb3b51bc7eed433b625e7d8 100644 (file)
@@ -4,15 +4,14 @@
 Summary:       phpMyAdmin - web-based MySQL administration
 Summary(pl.UTF-8):     phpMyAdmin - administracja bazami MySQL przez WWW
 Name:          phpMyAdmin
-Version:       4.0.6
+Version:       4.8.5
 Release:       1
 License:       GPL v2
 Group:         Applications/Databases/Interfaces
-Source0:       http://downloads.sourceforge.net/phpmyadmin/%{name}-%{version}-all-languages.tar.xz
-# Source0-md5: 646795297032cc9d53fe9bee261919e5
-Source1:       %{name}-apache.conf
+Source0:       https://files.phpmyadmin.net/phpMyAdmin/%{version}/%{name}-%{version}-all-languages.tar.xz
+# Source0-md5: e3737a28fff076003e56a83fe1920d04
+Source1:       apache.conf
 Source2:       %{name}-lighttpd.conf
-Source3:       %{name}-httpd.conf
 Patch0:                %{name}-config.patch
 Patch1:                %{name}-ServerSelectDisplayName.patch
 Patch2:                %{name}-ServerSelectDisplayName-config.patch
@@ -20,7 +19,9 @@ URL:          http://www.phpmyadmin.net/
 BuildRequires: rpmbuild(macros) >= 1.268
 BuildRequires: tar >= 1:1.22
 BuildRequires: xz
-Requires:      php(core) >= 5.2
+# phpMyAdmin doesn't support mysql < 5.5 and won't work with php < 5.3
+Requires:      mysql-libs >= 5.5
+Requires:      php(core) >= 5.3
 Requires:      php(ctype)
 Requires:      php(filter)
 Requires:      php(json)
@@ -34,10 +35,9 @@ Requires:    webapps
 Requires:      webserver(access)
 Requires:      webserver(alias)
 Requires(triggerpostun):       sed >= 4.0
-Suggests:      php-mysqli
+Suggests:      php(mysqli)
 Suggests:      webserver(indexfile)
 Suggests:      webserver(php)
-Conflicts:     apache-base < 2.4.0-1
 BuildArch:     noarch
 BuildRoot:     %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
 
@@ -58,13 +58,13 @@ manual. Currently phpMyAdmin can:
 - execute any SQL-statement, even batch-queries
 - manage keys on fields
 - load text files into tables
-- create (*) and read dumps of tables
-- export (*) and import data to CSV values
+- create and read dumps of tables
+- export and import data to CSV values
 - administer multiple servers and single databases
 - check referencial integrity
 - create complex queries automatically connecting required tables
 - create PDF graphics of your database layout
-- communicate in more than 50 different languages
+- communicate in more than 72 different languages
 
 %description -l pl.UTF-8
 phpMyAdmin potrafi zarządzać całymi bazami MySQL (potrzebne
@@ -78,7 +78,7 @@ podręcznika MySQL). Aktualnie phpMyAdmin potrafi:
 - wykonywać dowolne zapytania SQL
 - zarządzać kluczami na rekordach
 - wczytywać tekst z plików do tabel
-- obsługiwać ponad 20 języków
+- obsługiwać ponad 72 języków
 - zarządzać wieloma serwerami i pojedynczymi bazami danych
 - eksportować i importować dane do wartości CSV
 - tworzyć i czytać zrzuty tabel
@@ -86,22 +86,31 @@ podręcznika MySQL). Aktualnie phpMyAdmin potrafi:
 %prep
 %setup -q -n %{name}-%{version}-all-languages
 %patch0 -p1
-%patch1 -p0
+%patch1 -p1
 %patch2 -p0
 
+# cleanup backups after patching
+find '(' -name '*~' -o -name '*.orig' ')' -print0 | xargs -0 -r -l512 rm -f
+
+%{__rm} .editorconfig .eslintignore .eslintrc.json composer.json composer.lock package.json phpcs.xml.dist yarn.lock
+
 %install
 rm -rf $RPM_BUILD_ROOT
 install -d $RPM_BUILD_ROOT{%{_sysconfdir},%{_appdir}}
 
-install *.php *.css favicon.ico robots.txt $RPM_BUILD_ROOT%{_appdir}
-cp -a locale themes js libraries $RPM_BUILD_ROOT%{_appdir}
+cp -a . $RPM_BUILD_ROOT%{_appdir}
+
+cp -p libraries/config.default.php $RPM_BUILD_ROOT%{_sysconfdir}/config.inc.php
+ln -s %{_sysconfdir}/config.inc.php $RPM_BUILD_ROOT%{_appdir}/config.inc.php
 
-install libraries/config.default.php $RPM_BUILD_ROOT%{_sysconfdir}/config.inc.php
-ln -sf %{_sysconfdir}/config.inc.php $RPM_BUILD_ROOT%{_appdir}/config.inc.php
+cp -p %{SOURCE1} $RPM_BUILD_ROOT%{_sysconfdir}/httpd.conf
+cp -p %{SOURCE1} $RPM_BUILD_ROOT%{_sysconfdir}/apache.conf
+cp -p %{SOURCE2} $RPM_BUILD_ROOT%{_sysconfdir}/lighttpd.conf
 
-install %{SOURCE1} $RPM_BUILD_ROOT%{_sysconfdir}/httpd.conf
-install %{SOURCE3} $RPM_BUILD_ROOT%{_sysconfdir}/apache.conf
-install %{SOURCE2} $RPM_BUILD_ROOT%{_sysconfdir}/lighttpd.conf
+# packaged as doc
+%{__rm} $RPM_BUILD_ROOT%{_appdir}/{CONTRIBUTING.md,ChangeLog,DCO,LICENSE,README,RELEASE-DATE-*,CODE_OF_CONDUCT.md}
+# cleanup not packaged stuff
+%{__rm} -r $RPM_BUILD_ROOT%{_appdir}/{doc,examples,setup,sql}
 
 %clean
 rm -rf $RPM_BUILD_ROOT
@@ -112,10 +121,10 @@ rm -rf $RPM_BUILD_ROOT
 %triggerun -- apache1 < 1.3.37-3, apache1-base
 %webapp_unregister apache %{_webapp}
 
-%triggerin -- apache-base
+%triggerin -- apache < 2.2.0, apache-base
 %webapp_register httpd %{_webapp}
 
-%triggerun -- apache-base
+%triggerun -- apache < 2.2.0, apache-base
 %webapp_unregister httpd %{_webapp}
 
 %triggerin -- lighttpd
@@ -126,18 +135,20 @@ rm -rf $RPM_BUILD_ROOT
 
 %files
 %defattr(644,root,root,755)
-%doc ChangeLog README
+%doc CONTRIBUTING.md ChangeLog DCO LICENSE README examples/
 %dir %attr(750,root,http) %{_sysconfdir}
 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/apache.conf
 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/httpd.conf
 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/lighttpd.conf
 %attr(640,root,http) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/*.php
 %dir %{_appdir}
-%{_appdir}/js
-%{_appdir}/libraries
-%{_appdir}/locale
-%{_appdir}/themes
 %{_appdir}/*.css
 %{_appdir}/*.php
 %{_appdir}/favicon.ico
+%{_appdir}/js
+%{_appdir}/libraries
+%{_appdir}/locale
 %{_appdir}/robots.txt
+%{_appdir}/themes
+%{_appdir}/templates
+%{_appdir}/vendor
This page took 0.194536 seconds and 4 git commands to generate.