]> git.pld-linux.org Git - packages/phpMyAdmin.git/blame_incremental - phpMyAdmin.spec
- updated to 3.5.3
[packages/phpMyAdmin.git] / phpMyAdmin.spec
... / ...
CommitLineData
1# TODO
2# - add codepress (http://codepress.org/index.php) patch
3# - use system jquery (js/jquery), tcpdf (libraries/tcpdf) and php-gettext (libraries/gettext)
4Summary: phpMyAdmin - web-based MySQL administration
5Summary(pl.UTF-8): phpMyAdmin - administracja bazami MySQL przez WWW
6Name: phpMyAdmin
7Version: 3.5.3
8Release: 1
9License: GPL v2
10Group: Applications/Databases/Interfaces
11Source0: http://downloads.sourceforge.net/phpmyadmin/%{name}-%{version}-all-languages.tar.bz2
12# Source0-md5: 1552e878bb768bf477ca9ff86d0a6983
13Source1: %{name}.conf
14Source2: %{name}-lighttpd.conf
15Patch0: %{name}-config.patch
16Patch1: %{name}-ServerSelectDisplayName.patch
17Patch2: %{name}-ServerSelectDisplayName-config.patch
18URL: http://www.phpmyadmin.net/
19BuildRequires: rpmbuild(macros) >= 1.268
20Requires(triggerpostun): sed >= 4.0
21Requires: php(core) >= 5.2
22Requires: php(ctype)
23Requires: php(filter)
24Requires: php(json)
25Requires: php(mbstring)
26Requires: php(mcrypt)
27Requires: php(mysql)
28Requires: php(pcre)
29Requires: php(session)
30Requires: php(simplexml)
31Requires: webapps
32Requires: webserver(access)
33Requires: webserver(alias)
34Suggests: php-mysqli
35Suggests: webserver(indexfile)
36Suggests: webserver(php)
37BuildArch: noarch
38BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
39
40%define _appdir %{_datadir}/%{name}
41%define _webapps /etc/webapps
42%define _webapp %{name}
43%define _sysconfdir %{_webapps}/%{_webapp}
44
45%description
46phpMyAdmin can administer a whole MySQL-server (needs a super-user)
47but also a single database. To accomplish the latter you'll need a
48properly set up MySQL-user who can read/write only the desired
49database. It's up to you to look up the appropiate part in the MySQL
50manual. Currently phpMyAdmin can:
51- create and drop databases
52- create, copy, drop and alter tables
53- delete, edit and add fields
54- execute any SQL-statement, even batch-queries
55- manage keys on fields
56- load text files into tables
57- create (*) and read dumps of tables
58- export (*) and import data to CSV values
59- administer multiple servers and single databases
60- check referencial integrity
61- create complex queries automatically connecting required tables
62- create PDF graphics of your database layout
63- communicate in more than 50 different languages
64
65%description -l pl.UTF-8
66phpMyAdmin potrafi zarządzać całymi bazami MySQL (potrzebne
67uprawnienia superużytkownika) jak i pojedynczymi bazami danych.
68Potrzebny jest użytkownik, który ma prawa zapisu/odczytu tylko tych
69baz, którymi chcemy administrować (więcej informacji w odpowiedniej
70podręcznika MySQL). Aktualnie phpMyAdmin potrafi:
71- tworzyć i usuwać bazy
72- wykonywać create, copy, drop oraz alter na tabelach
73- dodawać, usuwać i modyfikować pola
74- wykonywać dowolne zapytania SQL
75- zarządzać kluczami na rekordach
76- wczytywać tekst z plików do tabel
77- obsługiwać ponad 20 języków
78- zarządzać wieloma serwerami i pojedynczymi bazami danych
79- eksportować i importować dane do wartości CSV
80- tworzyć i czytać zrzuty tabel
81
82%prep
83%setup -q -n %{name}-%{version}-all-languages
84%patch0 -p1
85%patch1 -p0
86%patch2 -p0
87
88%install
89rm -rf $RPM_BUILD_ROOT
90install -d $RPM_BUILD_ROOT{%{_sysconfdir},%{_appdir}}
91
92install *.php *.html *.css robots.txt $RPM_BUILD_ROOT%{_appdir}
93cp -a locale themes js libraries $RPM_BUILD_ROOT%{_appdir}
94
95install libraries/config.default.php $RPM_BUILD_ROOT%{_sysconfdir}/config.inc.php
96ln -sf %{_sysconfdir}/config.inc.php $RPM_BUILD_ROOT%{_appdir}/config.inc.php
97
98install %{SOURCE1} $RPM_BUILD_ROOT%{_sysconfdir}/httpd.conf
99install %{SOURCE1} $RPM_BUILD_ROOT%{_sysconfdir}/apache.conf
100install %{SOURCE2} $RPM_BUILD_ROOT%{_sysconfdir}/lighttpd.conf
101
102cp -f libraries/import/README{,-import}
103cp -f libraries/transformations/README{,-transformations}
104
105%clean
106rm -rf $RPM_BUILD_ROOT
107
108%triggerin -- apache1 < 1.3.37-3, apache1-base
109%webapp_register apache %{_webapp}
110
111%triggerun -- apache1 < 1.3.37-3, apache1-base
112%webapp_unregister apache %{_webapp}
113
114%triggerin -- apache < 2.2.0, apache-base
115%webapp_register httpd %{_webapp}
116
117%triggerun -- apache < 2.2.0, apache-base
118%webapp_unregister httpd %{_webapp}
119
120%triggerin -- lighttpd
121%webapp_register lighttpd %{_webapp}
122
123%triggerun -- lighttpd
124%webapp_unregister lighttpd %{_webapp}
125
126%files
127%defattr(644,root,root,755)
128%doc Documentation.* ChangeLog README README.VENDOR libraries/import/README-import libraries/transformations/README-transformations libraries/transformations/TEMPLATE* libraries/transformations/*.sh
129%dir %attr(750,root,http) %{_sysconfdir}
130%attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/apache.conf
131%attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/httpd.conf
132%attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/lighttpd.conf
133%attr(640,root,http) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/*.php
134%dir %{_appdir}
135%{_appdir}/js
136%{_appdir}/libraries
137%{_appdir}/locale
138%{_appdir}/themes
139%{_appdir}/*.css
140%{_appdir}/*.html
141%{_appdir}/*.php
142%{_appdir}/robots.txt
This page took 0.050684 seconds and 4 git commands to generate.