]> git.pld-linux.org Git - packages/phpMyAdmin.git/blame - phpMyAdmin.spec
- up to 3.3.9.2
[packages/phpMyAdmin.git] / phpMyAdmin.spec
CommitLineData
fdda4e42
ER
1# TODO
2# - add codepress (http://codepress.org/index.php) patch
d8c0193b 3Summary: phpMyAdmin - web-based MySQL administration
7f70cea7 4Summary(pl.UTF-8): phpMyAdmin - administracja bazami MySQL przez WWW
78a895aa 5Name: phpMyAdmin
caf47785 6Version: 3.3.9.2
e774a6a8 7Release: 1
c6adf9fe 8License: GPL v2
78a895aa 9Group: Applications/Databases/Interfaces
c22bd298 10Source0: http://downloads.sourceforge.net/phpmyadmin/%{name}-%{version}-all-languages.tar.bz2
caf47785 11# Source0-md5: db6b25e7b41d41b53d3bc03cd70c44ea
aac07012 12Source1: %{name}.conf
59d81573 13Source2: %{name}-lighttpd.conf
d0c3620a 14Patch0: %{name}-config.patch
77cf866b
ER
15Patch1: %{name}-ServerSelectDisplayName.patch
16Patch2: %{name}-ServerSelectDisplayName-config.patch
c3f22269
JB
17URL: http://www.phpmyadmin.net/
18BuildRequires: rpmbuild(macros) >= 1.268
f935b243 19Requires(triggerpostun): sed >= 4.0
77cf866b
ER
20Requires: php-common >= 4:5.2
21Requires: php-ctype
22Requires: php-mbstring
23Requires: php-mcrypt
24Requires: php-mysql
25Requires: php-pcre
7e902492 26Requires: php-session
c22bd298 27Requires: php-simplexml
f935b243 28Requires: webapps
9c9eb38c 29Requires: webserver(access)
bef21c33 30Requires: webserver(alias)
95983e51 31Suggests: php-mysqli
7bb50a64 32Suggests: webserver(indexfile)
7e902492 33Suggests: webserver(php)
89cacb94 34BuildArch: noarch
78a895aa
PG
35BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
36
7e9b99de 37%define _appdir %{_datadir}/%{name}
f935b243
ER
38%define _webapps /etc/webapps
39%define _webapp %{name}
40%define _sysconfdir %{_webapps}/%{_webapp}
78a895aa
PG
41
42%description
43phpMyAdmin can administer a whole MySQL-server (needs a super-user)
44but also a single database. To accomplish the latter you'll need a
45properly set up MySQL-user who can read/write only the desired
46database. It's up to you to look up the appropiate part in the MySQL
47manual. Currently phpMyAdmin can:
1d23e58d 48- create and drop databases
49- create, copy, drop and alter tables
50- delete, edit and add fields
51- execute any SQL-statement, even batch-queries
52- manage keys on fields
53- load text files into tables
54- create (*) and read dumps of tables
55- export (*) and import data to CSV values
56- administer multiple servers and single databases
ffe964b1
TP
57- check referencial integrity
58- create complex queries automatically connecting required tables
59- create PDF graphics of your database layout
60- communicate in more than 50 different languages
78a895aa 61
27fed873
JR
62%description -l pl.UTF-8
63phpMyAdmin potrafi zarządzać całymi bazami MySQL (potrzebne
64uprawnienia superużytkownika) jak i pojedynczymi bazami danych.
65Potrzebny jest użytkownik, który ma prawa zapisu/odczytu tylko tych
66baz, którymi chcemy administrować (więcej informacji w odpowiedniej
67podręcznika MySQL). Aktualnie phpMyAdmin potrafi:
68- tworzyć i usuwać bazy
69- wykonywać create, copy, drop oraz alter na tabelach
70- dodawać, usuwać i modyfikować pola
71- wykonywać dowolne zapytania SQL
72- zarządzać kluczami na rekordach
73- wczytywać tekst z plików do tabel
74- obsługiwać ponad 20 języków
75- zarządzać wieloma serwerami i pojedynczymi bazami danych
76- eksportować i importować dane do wartości CSV
77- tworzyć i czytać zrzuty tabel
78a895aa 78
78a895aa 79%prep
fb6eaade 80%setup -q -n %{name}-%{version}-all-languages
8677f286 81%patch0 -p1
aae97293 82%patch1 -p0
83%patch2 -p0
78a895aa
PG
84
85%install
86rm -rf $RPM_BUILD_ROOT
ef143b69 87install -d $RPM_BUILD_ROOT{%{_sysconfdir},%{_appdir}/{js,lang,libraries/{auth/swekey,dbg,dbi,engines,export,tcpdf/font,import,transformations}}}
f935b243
ER
88
89install *.php *.html *.css $RPM_BUILD_ROOT%{_appdir}
90install lang/*.php $RPM_BUILD_ROOT%{_appdir}/lang
ffe964b1 91cp -rf pmd $RPM_BUILD_ROOT%{_appdir}
f935b243 92cp -rf themes $RPM_BUILD_ROOT%{_appdir}
01cd4cc6 93cp -rf js $RPM_BUILD_ROOT%{_appdir}
52f3e0d7 94install libraries/*.php $RPM_BUILD_ROOT%{_appdir}/libraries
f935b243 95install libraries/auth/*.php $RPM_BUILD_ROOT%{_appdir}/libraries/auth
ef143b69 96install libraries/auth/swekey/*.{php,crt} $RPM_BUILD_ROOT%{_appdir}/libraries/auth/swekey
f935b243
ER
97install libraries/dbg/*.php $RPM_BUILD_ROOT%{_appdir}/libraries/dbg
98install libraries/dbi/*.php $RPM_BUILD_ROOT%{_appdir}/libraries/dbi
eedbae07 99install libraries/engines/*.php $RPM_BUILD_ROOT%{_appdir}/libraries/engines
100install libraries/export/*.php $RPM_BUILD_ROOT%{_appdir}/libraries/export
ffe964b1 101install libraries/import/*.php $RPM_BUILD_ROOT%{_appdir}/libraries/import
f4f5ac2a 102install libraries/tcpdf/*.php $RPM_BUILD_ROOT%{_appdir}/libraries/tcpdf
103install libraries/tcpdf/font/*.{php,z} $RPM_BUILD_ROOT%{_appdir}/libraries/tcpdf/font
f935b243 104install libraries/transformations/*.php $RPM_BUILD_ROOT%{_appdir}/libraries/transformations
78a895aa 105
52f3e0d7 106install libraries/config.default.php $RPM_BUILD_ROOT%{_sysconfdir}/config.inc.php
f935b243 107ln -sf %{_sysconfdir}/config.inc.php $RPM_BUILD_ROOT%{_appdir}/config.inc.php
aac07012 108
f935b243
ER
109install %{SOURCE1} $RPM_BUILD_ROOT%{_sysconfdir}/httpd.conf
110install %{SOURCE1} $RPM_BUILD_ROOT%{_sysconfdir}/apache.conf
c3491de8 111install %{SOURCE2} $RPM_BUILD_ROOT%{_sysconfdir}/lighttpd.conf
aac07012 112
ffe964b1
TP
113cp -f libraries/import/README{,-import}
114cp -f libraries/transformations/README{,-transformations}
115
78a895aa 116%clean
95798666 117rm -rf $RPM_BUILD_ROOT
78a895aa 118
879dcd55 119%triggerin -- apache1 < 1.3.37-3, apache1-base
f935b243 120%webapp_register apache %{_webapp}
aac07012 121
879dcd55 122%triggerun -- apache1 < 1.3.37-3, apache1-base
f935b243
ER
123%webapp_unregister apache %{_webapp}
124
243b3916 125%triggerin -- apache < 2.2.0, apache-base
f935b243
ER
126%webapp_register httpd %{_webapp}
127
243b3916 128%triggerun -- apache < 2.2.0, apache-base
f935b243 129%webapp_unregister httpd %{_webapp}
aac07012 130
59d81573
PG
131%triggerin -- lighttpd
132%webapp_register lighttpd %{_webapp}
133
134%triggerun -- lighttpd
135%webapp_unregister lighttpd %{_webapp}
136
78a895aa
PG
137%files
138%defattr(644,root,root,755)
01cd4cc6 139%doc Documentation.* CREDITS ChangeLog INSTALL README TODO translators.html scripts libraries/import/README-import libraries/transformations/README-transformations libraries/transformations/TEMPLATE* libraries/transformations/*.sh lang/*.sh
f935b243
ER
140%dir %attr(750,root,http) %{_sysconfdir}
141%attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/apache.conf
142%attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/httpd.conf
59d81573 143%attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/lighttpd.conf
f935b243
ER
144%attr(640,root,http) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/*.php
145%dir %{_appdir}
786331fa 146%{_appdir}/js
f935b243
ER
147%{_appdir}/lang
148%{_appdir}/libraries
ffe964b1 149%{_appdir}/pmd
786331fa 150%{_appdir}/themes
f935b243
ER
151%{_appdir}/*.css
152%{_appdir}/*.html
153%{_appdir}/*.php
This page took 1.115804 seconds and 4 git commands to generate.