]> git.pld-linux.org Git - packages/perl.git/blobdiff - perl_581-soname.patch
- sperl obsolete in perl-base not in main package; rel 3
[packages/perl.git] / perl_581-soname.patch
index 5632c819422ae32f25ca2d06ee4efc626171f686..72a81b796c865c5170fa6c3e51d7bb0a85767886 100644 (file)
@@ -1,22 +1,41 @@
---- perl-5.8.1/Makefile.SH.orig        Tue Aug 19 18:42:51 2003
-+++ perl-5.8.1/Makefile.SH     Fri Aug 22 14:33:39 2003
-@@ -494,13 +489,15 @@
- Makefile: $Makefile_s
- !GROK!THIS!
- else
--      $spitshell >>Makefile <<'!NO!SUBS!'
--$(LIBPERL): $& perl$(OBJ_EXT) $(obj) $(LIBPERLEXPORT)
+--- perl-5.10.1/Makefile.SH.orig       2009-08-03 22:43:30.000000000 +0200
++++ perl-5.10.1/Makefile.SH    2009-09-12 10:03:20.451763024 +0200
+@@ -160,7 +160,7 @@
+           # INSTALL file, under "Building a shared perl library".
+           # If there is no pre-existing $libperl, we don't need
+           # to do anything further.
+-          if test -f $archlib/CORE/$libperl; then
++#         if test -f $archlib/CORE/$libperl; then
+               rm -f preload
+               cat <<'EOT' > preload
+ #! /bin/sh
+@@ -171,7 +171,7 @@
+ EOT
+               chmod 755 preload
+               ldlibpth="$ldlibpth `pwd`/preload `pwd`/$libperl"
+-          fi
++#         fi
+           ;;
+       os390)  test -f /bin/env && ldlibpth="/bin/env $ldlibpth"
+               ;;
+@@ -728,14 +728,16 @@
+ !NO!SUBS!
+               ;;
+     esac
+-      $spitshell >>$Makefile <<'!NO!SUBS!'
+-$(LIBPERL): $& $(obj) $(DYNALOADER) $(LIBPERLEXPORT)
 +      $spitshell >>Makefile <<!NO!SUBS!
 +LIBPERL_SONAME=\$(LIBPERL).$version
-+\$(LIBPERL): \$& perl\$(OBJ_EXT) \$(obj) \$(LIBPERLEXPORT)
++\$(LIBPERL): \$& \$(obj) \$(DYNALOADER) \$(LIBPERLEXPORT)
  !NO!SUBS!
        case "$useshrplib" in
        true)
--              $spitshell >>Makefile <<'!NO!SUBS!'
--      $(LD) -o $@ $(SHRPLDFLAGS) perl$(OBJ_EXT) $(obj) $(libs)
-+              $spitshell >>Makefile <<!NO!SUBS!
-+      \$(LD) -o \$(LIBPERL_SONAME) \$(SHRPLDFLAGS) -Wl,-soname,\$(LIBPERL_SONAME) perl\$(OBJ_EXT) \$(obj) \$(libs)
-+      ln -sf \$(LIBPERL_SONAME) \$@
+               $spitshell >>$Makefile <<'!NO!SUBS!'
+-      rm -f $@
+-      $(LD) -o $@ $(SHRPLDFLAGS) $(obj) $(DYNALOADER) $(libs)
++      rm -f $@ $(LIBPERL_SONAME)
++      $(LD) -o $(LIBPERL_SONAME) $(SHRPLDFLAGS) -Wl,-soname,$(LIBPERL_SONAME) $(SHRPLDFLAGS) $(obj) $(DYNALOADER) $(libs)
++      ln -s $(LIBPERL_SONAME) $@
  !NO!SUBS!
                case "$osname" in
                aix)
This page took 0.034669 seconds and 4 git commands to generate.