]> git.pld-linux.org Git - packages/perl.git/blobdiff - perl.spec
- fix GDBM_File versioning
[packages/perl.git] / perl.spec
index 6c88bdfa11895ce5c07606568c5bede6e47aeb3f..4ff86954a607ac6fef50640317075e1d41f63564 100644 (file)
--- a/perl.spec
+++ b/perl.spec
@@ -44,7 +44,7 @@
 %define                perl_modversion()       %([ -f %{SOURCE3} ] && awk -vp=%1 '$1 == p{m=$1; gsub(/::/, "-", m); printf("perl-%s = %s\\n", m, $3)}END{if (!m) printf("# Error looking up [%s]\\n", p)}' %{SOURCE3} || echo ERROR)
 
 %define                ver     5.18.0
-%define                rel     5
+%define                rel     9
 Summary:       Practical Extraction and Report Language (Perl)
 Summary(cs.UTF-8):     Programovací jazyk Perl
 Summary(da.UTF-8):     Programmeringssproget Perl
@@ -85,6 +85,8 @@ Patch5:               %{name}_585-microperl_uconfig.patch
 Patch6:                %{name}-write-permissions.patch
 Patch7:                %{name}-t-syslog.patch
 Patch8:                %{name}-fix-pointer-arithmetic.patch
+Patch9:                %{name}-switch.patch
+Patch10:       %{name}-invalid-void-use.patch
 URL:           http://dev.perl.org/perl5/
 %ifarch ppc
 # gcc 3.3.x miscompiles pp_hot.c
@@ -666,9 +668,10 @@ formacie Perla a resztą systemu.
 Summary:       GDBM_File - Perl5 access to the gdbm library
 Summary(pl.UTF-8):     GDBM_File - dostęp do biblioteki gdbm w Perlu
 Version:       %perl_modver GDBM_File
-Epoch:         2
+Release:       %{ver}.%{rel}
+Epoch:         3
 Group:         Libraries
-Requires:      %{name}-base = 1:%{ver}-%{release}
+Requires:      %{name}-base = 1:%{ver}-%{rel}
 
 %description GDBM_File
 GDBM_File is a module which allows Perl programs to make use of the
@@ -690,6 +693,8 @@ z biblioteki GNU gdbm.
 %patch6 -p1
 %patch7 -p1
 %patch8 -p1
+%patch9 -p1
+%patch10 -p1
 
 cat > runperl <<'EOF'
 #!/bin/sh
@@ -878,13 +883,6 @@ sed -i -e 's#^\(ld.*=.*\)-Wl,--as-needed\(.*\)#\1 \2#g' $RPM_BUILD_ROOT%{perl_ar
 echo '# Module versions from Perl %{ver} distribution.' > perl-modules
 for m in $(awk '!/^#/ && !/^$/{print $1}' %{SOURCE3}); do
        case $m in
-       Devel::DProf)
-#              + perl -ilib -MDevel::DProf -e print 'Devel-DProf = ',$Devel::DProf::VERSION
-#              DProf: run perl with -d to use DProf.
-#              Compilation failed in require.
-#              BEGIN failed--compilation aborted.
-               v=$(%{__perl} -e 'do "Devel/DProf.pm"; print $Devel::DProf::VERSION')
-               ;;
        libnet)
                v=$(awk '/^libnet /{print $2; exit}' cpan/libnet/Changes)
                ;;
@@ -895,8 +893,10 @@ for m in $(awk '!/^#/ && !/^$/{print $1}' %{SOURCE3}); do
        echo "$m = $v" >> perl-modules
 done
 
-egrep -v '^([  ]*$|[;#])' %{SOURCE3} > .mods1
-egrep -v '^([  ]*$|[;#])' perl-modules > .mods2
+# ExtUtils::CBuilder Compress::Raw::Bzip2 Compress::Raw::Zlib ignored due to VERSION from the loop above
+# is missing ending '0'
+egrep -v '^([  ]*$|[;#])' %{SOURCE3} | egrep -v 'ExtUtils::CBuilder|Compress::Raw::Bzip2|Compress::Raw::Zlib' > .mods1
+egrep -v '^([  ]*$|[;#])' perl-modules | egrep -v 'ExtUtils::CBuilder|Compress::Raw::Bzip2|Compress::Raw::Zlib' > .mods2
 if ! cmp -s .mods1 .mods2; then
        : %{SOURCE3} outdated with $(pwd)/perl-modules
        exit 1
This page took 0.075382 seconds and 4 git commands to generate.