]> git.pld-linux.org Git - packages/perl-libwww.git/blobdiff - perl-libwww.spec
- version 5.822
[packages/perl-libwww.git] / perl-libwww.spec
index 504bdcbd223954780b31fec818d0bad86ebcfa82..ff18bca3b65fd872bf89bf5a634a1a32e24900c8 100644 (file)
@@ -1,70 +1,87 @@
-%define        perl_sitelib    %(eval "`perl -V:installsitelib`"; echo $installsitelib)
-
+#
+# Conditional build:
+%bcond_with    tests   # perform "make test"
+#
+%include       /usr/lib/rpm/macros.perl
+%define                pdir    WWW
+%define                pnam    libwww-perl
+Summary:       libwww-perl - a simple and consistent API to the World-Wide Web
+Summary(pl.UTF-8):     libwww-perl - prosty i logiczny API do WWW
 Name:          perl-libwww
-Version:       5.44
-Release:       4
-Vendor:                Mailing List <libwww-perl@ics.uci.edu>
-Source:         libwww-perl-%{version}.tar.gz
-Group:         Utilities/Text
-Copyright:     Free
-Summary:       Perl LIBWWW module
-Summary(pl):   Modu³ perla LIBWWW
-BuildRoot:     /tmp/%{name}-%{version}-root
-BuildRequires: perl >= 5.005_03-10
+Version:       5.822
+Release:       1
+# same as perl
+License:       GPL v1+ or Artistic
+Group:         Development/Languages/Perl
+Source0:       http://www.cpan.org/modules/by-module/%{pdir}/%{pnam}-%{version}.tar.gz
+# Source0-md5: 5b5856e0d61abb75fb5f52ed1678161f
+URL:           http://search.cpan.org/dist/libwww-perl/
+BuildRequires: perl(Net::FTP) >= 2.58
 BuildRequires: perl-Digest-MD5
-BuildRequires: perl-HTML-Parser
-BuildRequires: perl-URI
-Requires:      perl
-Requires:      %{perl_sitelib}
-Requires:      perl-HTML-Parser 
-Requires:      perl-MIME-Base64
-Requires:      perl-Digest-MD5 
-Requires:      perl-libnet 
-Requires:      perl-URI
+BuildRequires: perl-HTML-Parser >= 3.33
+BuildRequires: perl-MIME-Base64 >= 2.1
+BuildRequires: perl-URI >= 1.10
+BuildRequires: perl-devel >= 1:5.8.0
+BuildRequires: perl-libnet
+BuildRequires: rpm-perlprov >= 4.1-13
+Suggests:      perl-IO-Socket-SSL
+Obsoletes:     perl-libwww-perl
+BuildArch:     noarch
+BuildRoot:     %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
+
+# modules not always required
+%define        _noautoreq 'perl(HTML::Parse)' 'perl(HTML::FormatPS)' 'perl(HTML::FormatText)' 'perl(HTTP::GHTTP)' 'perl(IO::Socket::SSL)' 'perl(Mail::Internet)' 'perl(Authen::NTLM)'
 
 %description
-Libwww-perl is a collection of Perl modules which provides a simple
-and consistent programming interface (API) to the World-Wide Web.
+The libwww-perl collection is a set of Perl modules which provides a
+simple and consistent application programming interface to the
+World-Wide Web. The main focus of the library is to provide classes
+and functions that allow you to write WWW clients. The library also
+contain modules that are of more general use and even classes that
+help you implement simple HTTP servers.
 
-%description -l pl
-Libwww-perl jest kolekcj± modu³ów Perla, które dostaczaj± proste
-API do WWW (World-Wide Web).
+%description -l pl.UTF-8
+libwww-perl jest zbiorem modułów Perla, dostarczających prostego API
+do WWW (World-Wide Web). Głównym zadaniem biblioteki jest
+udostępnianie klas i funkcji, pozwalających na pisanie klientów WWW.
+Biblioteka zawiera także moduły bardziej ogólnego przeznaczenia, a
+nawet klasy, pozwalające na implementację prostego serwera HTTP.
 
 %prep
 %setup -q -n libwww-perl-%{version}
 
 %build
-perl Makefile.PL
-make OPTIMIZE="$RPM_OPT_FLAGS"
+yes | %{__perl} Makefile.PL \
+       INSTALLDIRS=vendor
+%{__make}
+
+%{?with_tests:%{__make} test}
 
 %install
 rm -rf $RPM_BUILD_ROOT
-install -d $RPM_BUILD_ROOT%{perl_archlib}
 
-make install \
+%{__make} install \
        DESTDIR=$RPM_BUILD_ROOT
 
-(  cd $RPM_BUILD_ROOT%{perl_sitearch}/auto/libwww-perl/
-   sed -e "s#$RPM_BUILD_ROOT##" .packlist >.packlist.new
-   mv .packlist.new .packlist
-)
-      
-gzip -9nf README TODO $RPM_BUILD_ROOT%{_mandir}/man{1,3}/*
+for file in GET HEAD POST; do
+       ln -sf lwp-request $RPM_BUILD_ROOT%{_bindir}/$file
+       rm -f $RPM_BUILD_ROOT%{_mandir}/man1/$file.1p
+       echo '.so lwp-request.1p' > $RPM_BUILD_ROOT%{_mandir}/man1/$file.1p
+done
 
 %clean
 rm -rf $RPM_BUILD_ROOT
 
 %files
 %defattr(644,root,root,755)
-%doc README.gz TODO.gz
-%{perl_sitelib}/*.pm
-%{perl_sitelib}/*.pod
-%{perl_sitelib}/Bundle/*
-%{perl_sitelib}/File/*
-%{perl_sitelib}/HTTP/*
-%{perl_sitelib}/LWP
-%{perl_sitelib}/WWW
-%{perl_sitearch}/auto/libwww-perl
+%doc README*
+%{perl_vendorlib}/*.pm
+%{perl_vendorlib}/File/*
+%{perl_vendorlib}/HTML/*
+%{perl_vendorlib}/HTTP/*
+%{perl_vendorlib}/Net/*
+%{perl_vendorlib}/LWP
+%{perl_vendorlib}/WWW/*
 %attr(755,root,root) %{_bindir}/*
-
-%{_mandir}/man*/*
+%{_mandir}/man1/*
+%{_mandir}/man3/[!B]*
This page took 0.035632 seconds and 4 git commands to generate.