]> git.pld-linux.org Git - packages/perl-libwww.git/blobdiff - perl-libwww.spec
- version 5.822
[packages/perl-libwww.git] / perl-libwww.spec
index 1abc85477b1a0c4fc1f78d920193588d6bc7f228..ff18bca3b65fd872bf89bf5a634a1a32e24900c8 100644 (file)
@@ -1,56 +1,87 @@
+#
+# Conditional build:
+%bcond_with    tests   # perform "make test"
+#
+%include       /usr/lib/rpm/macros.perl
+%define                pdir    WWW
+%define                pnam    libwww-perl
+Summary:       libwww-perl - a simple and consistent API to the World-Wide Web
+Summary(pl.UTF-8):     libwww-perl - prosty i logiczny API do WWW
 Name:          perl-libwww
-Version:       5.44
+Version:       5.822
 Release:       1
-Vendor:                Mailing List <libwww-perl@ics.uci.edu>
-Source:         libwww-perl-%{version}.tar.gz
-#Patch:                libwww-Makefile.patch
-Group:         Utilities/Text
-Copyright:     Free
-Summary:       Perl LIBWWW module
-Summary(pl):   Modu³ perla LIBWWW
-BuildRoot:     /tmp/%{name}-%{version}-root
-BuildRequires: perl
-%requires_eq   perl
-Requires:      perl-HTML-Parser, perl-MIME-Base64, perl-MD5, perl-libnet, perl-Data-Dumper
+# same as perl
+License:       GPL v1+ or Artistic
+Group:         Development/Languages/Perl
+Source0:       http://www.cpan.org/modules/by-module/%{pdir}/%{pnam}-%{version}.tar.gz
+# Source0-md5: 5b5856e0d61abb75fb5f52ed1678161f
+URL:           http://search.cpan.org/dist/libwww-perl/
+BuildRequires: perl(Net::FTP) >= 2.58
+BuildRequires: perl-Digest-MD5
+BuildRequires: perl-HTML-Parser >= 3.33
+BuildRequires: perl-MIME-Base64 >= 2.1
+BuildRequires: perl-URI >= 1.10
+BuildRequires: perl-devel >= 1:5.8.0
+BuildRequires: perl-libnet
+BuildRequires: rpm-perlprov >= 4.1-13
+Suggests:      perl-IO-Socket-SSL
+Obsoletes:     perl-libwww-perl
+BuildArch:     noarch
+BuildRoot:     %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
+
+# modules not always required
+%define        _noautoreq 'perl(HTML::Parse)' 'perl(HTML::FormatPS)' 'perl(HTML::FormatText)' 'perl(HTTP::GHTTP)' 'perl(IO::Socket::SSL)' 'perl(Mail::Internet)' 'perl(Authen::NTLM)'
 
 %description
-Libwww-perl is a collection of Perl modules which provides a simple
-and consistent programming interface (API) to the World-Wide Web.
+The libwww-perl collection is a set of Perl modules which provides a
+simple and consistent application programming interface to the
+World-Wide Web. The main focus of the library is to provide classes
+and functions that allow you to write WWW clients. The library also
+contain modules that are of more general use and even classes that
+help you implement simple HTTP servers.
 
-%description -l pl
-Libwww-perl jest kolekcj± modu³ów Perla, które dostaczaj± proste
-API do WWW (World-Wide Web).
+%description -l pl.UTF-8
+libwww-perl jest zbiorem modułów Perla, dostarczających prostego API
+do WWW (World-Wide Web). Głównym zadaniem biblioteki jest
+udostępnianie klas i funkcji, pozwalających na pisanie klientów WWW.
+Biblioteka zawiera także moduły bardziej ogólnego przeznaczenia, a
+nawet klasy, pozwalające na implementację prostego serwera HTTP.
 
 %prep
 %setup -q -n libwww-perl-%{version}
 
 %build
-CFLAGS="$RPM_OPT_FLAGS" perl Makefile.PL
-#patch -p1 < %{PATCH}
-make
+yes | %{__perl} Makefile.PL \
+       INSTALLDIRS=vendor
+%{__make}
+
+%{?with_tests:%{__make} test}
 
 %install
 rm -rf $RPM_BUILD_ROOT
-install -d $RPM_BUILD_ROOT/%{perl_sitearch} \
-       $RPM_BUILD_ROOT{%{_mandir}/man{1,3},%{_bindir}}
 
-make install PREFIX=$RPM_BUILD_ROOT/usr \
-       INSTALLMAN3DIR=$RPM_BUILD_ROOT%{_mandir}/man3 \
-       INSTALLMAN1DIR=$RPM_BUILD_ROOT%{_mandir}/man1
+%{__make} install \
+       DESTDIR=$RPM_BUILD_ROOT
 
-gzip -9nf README TODO $RPM_BUILD_ROOT%{_mandir}/man{1,3}/*
+for file in GET HEAD POST; do
+       ln -sf lwp-request $RPM_BUILD_ROOT%{_bindir}/$file
+       rm -f $RPM_BUILD_ROOT%{_mandir}/man1/$file.1p
+       echo '.so lwp-request.1p' > $RPM_BUILD_ROOT%{_mandir}/man1/$file.1p
+done
 
 %clean
 rm -rf $RPM_BUILD_ROOT
 
 %files
-%doc README.gz TODO.gz
-%{_libdir}/perl5/site_perl/5.005/LWP.pm
-%{_libdir}/perl5/site_perl/5.005/Bundle/*.pm
-%{_libdir}/perl5/site_perl/5.005/File/*.pm
-%{_libdir}/perl5/site_perl/5.005/HTTP/*
-%{_libdir}/perl5/site_perl/5.005/LWP/*
-%{_libdir}/perl5/site_perl/5.005/WWW/*
+%defattr(644,root,root,755)
+%doc README*
+%{perl_vendorlib}/*.pm
+%{perl_vendorlib}/File/*
+%{perl_vendorlib}/HTML/*
+%{perl_vendorlib}/HTTP/*
+%{perl_vendorlib}/Net/*
+%{perl_vendorlib}/LWP
+%{perl_vendorlib}/WWW/*
 %attr(755,root,root) %{_bindir}/*
 %{_mandir}/man1/*
-%{_mandir}/man3/*
+%{_mandir}/man3/[!B]*
This page took 0.080201 seconds and 4 git commands to generate.