]> git.pld-linux.org Git - packages/perl-libwww.git/blobdiff - perl-libwww.spec
- Up to 5.837
[packages/perl-libwww.git] / perl-libwww.spec
index 0009e3a8b7286747734c3c8e1b5759a0945b0923..999f0b9460c8def77168053b53d051d980613cb4 100644 (file)
@@ -1,72 +1,87 @@
+#
+# Conditional build:
+%bcond_with    tests   # perform "make test"
+#
 %include       /usr/lib/rpm/macros.perl
-Summary:       Perl LIBWWW module
-Summary(pl):   Modu³ perla LIBWWW
+%define                pdir    WWW
+%define                pnam    libwww-perl
+Summary:       libwww-perl - a simple and consistent API to the World-Wide Web
+Summary(pl.UTF-8):     libwww-perl - prosty i logiczny API do WWW
 Name:          perl-libwww
-Version:       5.64
+Version:       5.837
 Release:       1
-License:       GPL
+# same as perl
+License:       GPL v1+ or Artistic
 Group:         Development/Languages/Perl
-Group(cs):     Vývojové prostøedky/Programovací jazyky/Perl
-Group(de):     Entwicklung/Sprachen/Perl
-Group(es):     Desarrollo/Lenguajes/Perl
-Group(fr):     Development/Langues/Perl
-Group(ja):     ³«È¯/¸À¸ì/Perl
-Group(pl):     Programowanie/Jêzyki/Perl
-Group(pt):     Desenvolvimento/Linguagens/Perl
-Group(ru):     òÁÚÒÁÂÏÔËÁ/ñÚÙËÉ/Perl
-Source0:       ftp://ftp.perl.org/pub/CPAN/modules/by-module/WWW/libwww-perl-%{version}.tar.gz
-BuildRequires: rpm-perlprov >= 3.0.3-18
-BuildRequires:  perl(Net::FTP) >= 2.58
-BuildRequires: perl >= 5.6
+Source0:       http://www.cpan.org/modules/by-module/WWW/GAAS/%{pnam}-%{version}.tar.gz
+# Source0-md5: 9bbf1bce482b0bac98bb4f04253c03d0
+URL:           http://search.cpan.org/dist/libwww-perl/
+BuildRequires: perl(Net::FTP) >= 2.58
 BuildRequires: perl-Digest-MD5
-BuildRequires: perl-HTML-Parser
-BuildRequires: perl-MIME-Base64
-BuildRequires: perl-URI
+BuildRequires: perl-HTML-Parser >= 3.33
+BuildRequires: perl-MIME-Base64 >= 2.1
+BuildRequires: perl-URI >= 1.10
+BuildRequires: perl-devel >= 1:5.8.0
 BuildRequires: perl-libnet
+BuildRequires: rpm-perlprov >= 4.1-13
+Suggests:      perl-IO-Socket-SSL
+Obsoletes:     perl-libwww-perl
 BuildArch:     noarch
 BuildRoot:     %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
-Obsoletes:     perl-libwww-perl
 
 # modules not always required
-%define        _noautoreq "perl(HTML::Parse)" "perl(HTML::FormatPS)" "perl(HTML::FormatText)" "perl(HTTP::GHTTP)" "perl(IO::Socket::SSL)" "perl(Mail::Internet)"
+%define        _noautoreq 'perl(HTML::Parse)' 'perl(HTML::FormatPS)' 'perl(HTML::FormatText)' 'perl(HTTP::GHTTP)' 'perl(IO::Socket::SSL)' 'perl(Mail::Internet)' 'perl(Authen::NTLM)'
 
 %description
-Libwww-perl is a collection of Perl modules which provides a simple
-and consistent programming interface (API) to the World-Wide Web.
+The libwww-perl collection is a set of Perl modules which provides a
+simple and consistent application programming interface to the
+World-Wide Web. The main focus of the library is to provide classes
+and functions that allow you to write WWW clients. The library also
+contain modules that are of more general use and even classes that
+help you implement simple HTTP servers.
 
-%description -l pl
-Libwww-perl jest kolekcj± modu³ów Perla, które dostaczaj± proste API
-do WWW (World-Wide Web).
+%description -l pl.UTF-8
+libwww-perl jest zbiorem modułów Perla, dostarczających prostego API
+do WWW (World-Wide Web). Głównym zadaniem biblioteki jest
+udostępnianie klas i funkcji, pozwalających na pisanie klientów WWW.
+Biblioteka zawiera także moduły bardziej ogólnego przeznaczenia, a
+nawet klasy, pozwalające na implementację prostego serwera HTTP.
 
 %prep
 %setup -q -n libwww-perl-%{version}
 
 %build
-perl Makefile.PL </dev/null
-%{__make} OPTIMIZE="%{rpmcflags}"
+yes | %{__perl} Makefile.PL \
+       INSTALLDIRS=vendor
+%{__make}
+
+%{?with_tests:%{__make} test}
 
 %install
 rm -rf $RPM_BUILD_ROOT
 
-%{__make} install DESTDIR=$RPM_BUILD_ROOT
+%{__make} install \
+       DESTDIR=$RPM_BUILD_ROOT
 
-gzip -9nf README TODO
+for file in GET HEAD POST; do
+       ln -sf lwp-request $RPM_BUILD_ROOT%{_bindir}/$file
+       rm -f $RPM_BUILD_ROOT%{_mandir}/man1/$file.1p
+       echo '.so lwp-request.1p' > $RPM_BUILD_ROOT%{_mandir}/man1/$file.1p
+done
 
 %clean
-#rm -rf $RPM_BUILD_ROOT
+rm -rf $RPM_BUILD_ROOT
 
 %files
 %defattr(644,root,root,755)
-%doc *.gz
-%{perl_sitelib}/*.pm
-%{perl_sitelib}/*.pod
-%{perl_sitelib}/Bundle/*
-%{perl_sitelib}/File/*
-%{perl_sitelib}/HTML/*
-%{perl_sitelib}/HTTP/*
-%{perl_sitelib}/Net/*
-%{perl_sitelib}/LWP
-%{perl_sitelib}/WWW
+%doc README*
+%{perl_vendorlib}/*.pm
+%{perl_vendorlib}/File/*
+%{perl_vendorlib}/HTML/*
+%{perl_vendorlib}/HTTP/*
+%{perl_vendorlib}/Net/*
+%{perl_vendorlib}/LWP
+%{perl_vendorlib}/WWW/*
 %attr(755,root,root) %{_bindir}/*
 %{_mandir}/man1/*
-%{_mandir}/man3/*
+%{_mandir}/man3/[!B]*
This page took 0.680235 seconds and 4 git commands to generate.