]> git.pld-linux.org Git - packages/perl-libwww.git/blobdiff - perl-libwww.spec
- updated to 5.77
[packages/perl-libwww.git] / perl-libwww.spec
index 0476fc0b7d038b69d2f6a3f580d4822d57d1c809..87ce3f6edeb7594cb06550eb9c3c8cfa1dcf069a 100644 (file)
@@ -1,24 +1,26 @@
-#
+
 # Conditional build:
-# _with_tests - perform "make test"
-#
+%bcond_with    tests   # perform "make test"
+
 %include       /usr/lib/rpm/macros.perl
 %define                pdir    WWW
 %define                pnam    libwww-perl
 Summary:       libwww-perl - a simple and consistent API to the World-Wide Web
-Summary(pl):   libwww-perl - prosty i logiczny API do WWW 
+Summary(pl):   libwww-perl - prosty i logiczny API do WWW
 Name:          perl-libwww
-Version:       5.69
-Release:       2
-License:       GPL
+Version:       5.77
+Release:       1
+# same as Perl
+License:       GPL or Artistic
 Group:         Development/Languages/Perl
 Source0:       http://www.cpan.org/modules/by-module/%{pdir}/%{pnam}-%{version}.tar.gz
-BuildRequires: perl >= 5.6
-BuildRequires:  perl(Net::FTP) >= 2.58
+# Source0-md5: 7aed09ed638986764e229beb2cbad6b4
+BuildRequires: perl(Net::FTP) >= 2.58
 BuildRequires: perl-Digest-MD5
-BuildRequires: perl-HTML-Parser
-BuildRequires: perl-MIME-Base64
-BuildRequires: perl-URI
+BuildRequires: perl-HTML-Parser >= 3.33
+BuildRequires: perl-MIME-Base64 >= 2.1
+BuildRequires: perl-URI >= 1.10
+BuildRequires: perl-devel >= 5.8
 BuildRequires: perl-libnet
 BuildRequires: rpm-perlprov >= 4.1-13
 BuildArch:     noarch
@@ -26,7 +28,7 @@ BuildRoot:    %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
 Obsoletes:     perl-libwww-perl
 
 # modules not always required
-%define        _noautoreq "perl(HTML::Parse)" "perl(HTML::FormatPS)" "perl(HTML::FormatText)" "perl(HTTP::GHTTP)" "perl(IO::Socket::SSL)" "perl(Mail::Internet)" "perl(Authen::NTLM)"
+%define        _noautoreq 'perl(HTML::Parse)' 'perl(HTML::FormatPS)' 'perl(HTML::FormatText)' 'perl(HTTP::GHTTP)' 'perl(IO::Socket::SSL)' 'perl(Mail::Internet)' 'perl(Authen::NTLM)'
 
 %description
 The libwww-perl collection is a set of Perl modules which provides a
@@ -48,15 +50,16 @@ na implementacj
 
 %build
 %{__perl} Makefile.PL </dev/null \
-       INSTALLDIRS=vendor 
+       INSTALLDIRS=vendor
 %{__make}
 
-%{?_with_tests:%{__make} test}
+%{?with_tests:%{__make} test}
 
 %install
 rm -rf $RPM_BUILD_ROOT
 
-%{__make} install DESTDIR=$RPM_BUILD_ROOT
+%{__make} install \
+       DESTDIR=$RPM_BUILD_ROOT
 
 %clean
 rm -rf $RPM_BUILD_ROOT
@@ -73,4 +76,4 @@ rm -rf $RPM_BUILD_ROOT
 %{perl_vendorlib}/WWW/*
 %attr(755,root,root) %{_bindir}/*
 %{_mandir}/man1/*
-%{_mandir}/man3/[^B]*
+%{_mandir}/man3/[!B]*
This page took 0.135153 seconds and 4 git commands to generate.