]> git.pld-linux.org Git - packages/perl-libwww.git/blobdiff - perl-libwww.spec
- tabs in preamble
[packages/perl-libwww.git] / perl-libwww.spec
index b88c96d5d17de64a3996345785230e283909d5c3..4ac2a9936626dc49bb53ae76875e153a26bb352c 100644 (file)
@@ -1,24 +1,27 @@
 #
 # Conditional build:
 #
 # Conditional build:
-# _with_tests - perform "make test"
+%bcond_with    tests   # perform "make test"
 #
 %include       /usr/lib/rpm/macros.perl
 %define                pdir    WWW
 %define                pnam    libwww-perl
 Summary:       libwww-perl - a simple and consistent API to the World-Wide Web
 #
 %include       /usr/lib/rpm/macros.perl
 %define                pdir    WWW
 %define                pnam    libwww-perl
 Summary:       libwww-perl - a simple and consistent API to the World-Wide Web
-Summary(pl):   libwww-perl - prosty i logiczny API do WWW 
+Summary(pl.UTF-8):     libwww-perl - prosty i logiczny API do WWW
 Name:          perl-libwww
 Name:          perl-libwww
-Version:       5.69
-Release:       2
-License:       GPL
+Version:       5.805
+Release:       1
+# same as perl
+License:       GPL v1+ or Artistic
 Group:         Development/Languages/Perl
 Source0:       http://www.cpan.org/modules/by-module/%{pdir}/%{pnam}-%{version}.tar.gz
 Group:         Development/Languages/Perl
 Source0:       http://www.cpan.org/modules/by-module/%{pdir}/%{pnam}-%{version}.tar.gz
-BuildRequires: perl-devel >= 5.6
-BuildRequires:  perl(Net::FTP) >= 2.58
+# Source0-md5: db1eb693eee45d251966ad2bab49dbbf
+URL:           http://search.cpan.org/dist/libwww-perl/
+BuildRequires: perl(Net::FTP) >= 2.58
 BuildRequires: perl-Digest-MD5
 BuildRequires: perl-Digest-MD5
-BuildRequires: perl-HTML-Parser
-BuildRequires: perl-MIME-Base64
-BuildRequires: perl-URI
+BuildRequires: perl-HTML-Parser >= 3.33
+BuildRequires: perl-MIME-Base64 >= 2.1
+BuildRequires: perl-URI >= 1.10
+BuildRequires: perl-devel >= 1:5.8.0
 BuildRequires: perl-libnet
 BuildRequires: rpm-perlprov >= 4.1-13
 BuildArch:     noarch
 BuildRequires: perl-libnet
 BuildRequires: rpm-perlprov >= 4.1-13
 BuildArch:     noarch
@@ -26,7 +29,7 @@ BuildRoot:    %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
 Obsoletes:     perl-libwww-perl
 
 # modules not always required
 Obsoletes:     perl-libwww-perl
 
 # modules not always required
-%define        _noautoreq "perl(HTML::Parse)" "perl(HTML::FormatPS)" "perl(HTML::FormatText)" "perl(HTTP::GHTTP)" "perl(IO::Socket::SSL)" "perl(Mail::Internet)" "perl(Authen::NTLM)"
+%define        _noautoreq 'perl(HTML::Parse)' 'perl(HTML::FormatPS)' 'perl(HTML::FormatText)' 'perl(HTTP::GHTTP)' 'perl(IO::Socket::SSL)' 'perl(Mail::Internet)' 'perl(Authen::NTLM)'
 
 %description
 The libwww-perl collection is a set of Perl modules which provides a
 
 %description
 The libwww-perl collection is a set of Perl modules which provides a
@@ -36,27 +39,34 @@ that allow you to write WWW clients. The library also contain modules
 that are of more general use and even classes that help you implement
 simple HTTP servers.
 
 that are of more general use and even classes that help you implement
 simple HTTP servers.
 
-%description -l pl
-libwww-perl jest zbiorem modu³ów Perla, dostarczaj±cych prostego API
-do WWW (World-Wide Web). G³ównym zadaniem biblioteki jest udostêpnianie
-klas i funkcji, pozwalaj±cych na pisanie klientów WWW. Biblioteka zawiera
-tak¿e modu³y bardziej ogólnego przeznaczenia, a nawet klasy, pozwalaj±ce
-na implementacjê prostego serwera HTTP.
+%description -l pl.UTF-8
+libwww-perl jest zbiorem modułów Perla, dostarczających prostego API
+do WWW (World-Wide Web). Głównym zadaniem biblioteki jest udostępnianie
+klas i funkcji, pozwalających na pisanie klientów WWW. Biblioteka zawiera
+także moduły bardziej ogólnego przeznaczenia, a nawet klasy, pozwalające
+na implementację prostego serwera HTTP.
 
 %prep
 %setup -q -n libwww-perl-%{version}
 
 %build
 
 %prep
 %setup -q -n libwww-perl-%{version}
 
 %build
-%{__perl} Makefile.PL </dev/null \
-       INSTALLDIRS=vendor 
+yes | %{__perl} Makefile.PL \
+       INSTALLDIRS=vendor
 %{__make}
 
 %{__make}
 
-%{?_with_tests:%{__make} test}
+%{?with_tests:%{__make} test}
 
 %install
 rm -rf $RPM_BUILD_ROOT
 
 
 %install
 rm -rf $RPM_BUILD_ROOT
 
-%{__make} install DESTDIR=$RPM_BUILD_ROOT
+%{__make} install \
+       DESTDIR=$RPM_BUILD_ROOT
+
+for file in GET HEAD POST; do
+       ln -sf lwp-request $RPM_BUILD_ROOT%{_bindir}/$file
+       rm -f $RPM_BUILD_ROOT%{_mandir}/man1/$file.1p
+       echo '.so lwp-request.1p' > $RPM_BUILD_ROOT%{_mandir}/man1/$file.1p
+done
 
 %clean
 rm -rf $RPM_BUILD_ROOT
 
 %clean
 rm -rf $RPM_BUILD_ROOT
@@ -73,4 +83,4 @@ rm -rf $RPM_BUILD_ROOT
 %{perl_vendorlib}/WWW/*
 %attr(755,root,root) %{_bindir}/*
 %{_mandir}/man1/*
 %{perl_vendorlib}/WWW/*
 %attr(755,root,root) %{_bindir}/*
 %{_mandir}/man1/*
-%{_mandir}/man3/[^B]*
+%{_mandir}/man3/[!B]*
This page took 0.077877 seconds and 4 git commands to generate.