]> git.pld-linux.org Git - packages/perl-libwww.git/blobdiff - perl-libwww.spec
- standarized Source0 URL
[packages/perl-libwww.git] / perl-libwww.spec
index cb91e7ee27a53563cc70123a66c5d868ccb9d5c4..49e98fa0c1ed58d943c7238952c864f537783c88 100644 (file)
@@ -1,79 +1,80 @@
+#
+# Conditional build:
+%bcond_with    tests   # perform "make test"
+#
 %include       /usr/lib/rpm/macros.perl
 %define                pdir    WWW
 %define                pnam    libwww-perl
-Summary:       LIBWWW Perl module
-Summary(cs):   Modul LIBWWW pro Perl
-Summary(da):   Perlmodul LIBWWW
-Summary(de):   LIBWWW Perl Modul
-Summary(es):   Módulo de Perl LIBWWW
-Summary(fr):   Module Perl LIBWWW
-Summary(it):   Modulo di Perl LIBWWW
-Summary(ja):   LIBWWW Perl ¥â¥¸¥å¡¼¥ë
-Summary(ko):   LIBWWW ÆÞ ¸ðÁÙ
-Summary(no):   Perlmodul LIBWWW
-Summary(pl):   Modu³ Perla LIBWWW
-Summary(pt):   Módulo de Perl LIBWWW
-Summary(pt_BR):        Módulo Perl LIBWWW
-Summary(ru):   íÏÄÕÌØ ÄÌÑ Perl LIBWWW
-Summary(sv):   LIBWWW Perlmodul
-Summary(uk):   íÏÄÕÌØ ÄÌÑ Perl LIBWWW
-Summary(zh_CN):        LIBWWW Perl Ä£¿é
+Summary:       libwww-perl - a simple and consistent API to the World-Wide Web
+Summary(pl):   libwww-perl - prosty i logiczny API do WWW
 Name:          perl-libwww
-Version:       5.65
-Release:       2
-License:       GPL
+Version:       5.801
+Release:       1
+# same as perl
+License:       GPL v1+ or Artistic
 Group:         Development/Languages/Perl
-Source0:       ftp://ftp.cpan.org/pub/CPAN/modules/by-module/%{pdir}/%{pnam}-%{version}.tar.gz
-BuildRequires: perl >= 5.6
-BuildRequires:  perl(Net::FTP) >= 2.58
+Source0:       http://www.cpan.org/modules/by-module/%{pdir}/%{pnam}-%{version}.tar.gz
+# Source0-md5: eda011c6b5483d2d7443dd737cf03118
+URL:           http://search.cpan.org/dist/libwww-perl/
+BuildRequires: perl(Net::FTP) >= 2.58
 BuildRequires: perl-Digest-MD5
-BuildRequires: perl-HTML-Parser
-BuildRequires: perl-MIME-Base64
-BuildRequires: perl-URI
+BuildRequires: perl-HTML-Parser >= 3.33
+BuildRequires: perl-MIME-Base64 >= 2.1
+BuildRequires: perl-URI >= 1.10
+BuildRequires: perl-devel >= 1:5.8.0
 BuildRequires: perl-libnet
-BuildRequires: rpm-perlprov >= 3.0.3-18
+BuildRequires: rpm-perlprov >= 4.1-13
 BuildArch:     noarch
 BuildRoot:     %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
 Obsoletes:     perl-libwww-perl
 
 # modules not always required
-%define        _noautoreq "perl(HTML::Parse)" "perl(HTML::FormatPS)" "perl(HTML::FormatText)" "perl(HTTP::GHTTP)" "perl(IO::Socket::SSL)" "perl(Mail::Internet)"
+%define        _noautoreq 'perl(HTML::Parse)' 'perl(HTML::FormatPS)' 'perl(HTML::FormatText)' 'perl(HTTP::GHTTP)' 'perl(IO::Socket::SSL)' 'perl(Mail::Internet)' 'perl(Authen::NTLM)'
 
 %description
-LIBWWW is a collection of Perl modules which provides a simple and
-consistent programming interface (API) to the World-Wide Web.
+The libwww-perl collection is a set of Perl modules which provides a
+simple and consistent application programming interface to the World-Wide
+Web. The main focus of the library is to provide classes and functions
+that allow you to write WWW clients. The library also contain modules
+that are of more general use and even classes that help you implement
+simple HTTP servers.
 
 %description -l pl
-LIBWWW jest kolekcj± modu³ów Perla, które dostaczaj± proste API do
-WWW (World-Wide Web).
+libwww-perl jest zbiorem modu³ów Perla, dostarczaj±cych prostego API
+do WWW (World-Wide Web). G³ównym zadaniem biblioteki jest udostêpnianie
+klas i funkcji, pozwalaj±cych na pisanie klientów WWW. Biblioteka zawiera
+tak¿e modu³y bardziej ogólnego przeznaczenia, a nawet klasy, pozwalaj±ce
+na implementacjê prostego serwera HTTP.
 
 %prep
 %setup -q -n libwww-perl-%{version}
 
 %build
-perl Makefile.PL </dev/null
-%{__make} OPTIMIZE="%{rpmcflags}"
+%{__perl} Makefile.PL </dev/null \
+       INSTALLDIRS=vendor
+%{__make}
+
+%{?with_tests:%{__make} test}
 
 %install
 rm -rf $RPM_BUILD_ROOT
 
-%{__make} install DESTDIR=$RPM_BUILD_ROOT
+%{__make} install \
+       DESTDIR=$RPM_BUILD_ROOT
 
 %clean
 rm -rf $RPM_BUILD_ROOT
 
 %files
 %defattr(644,root,root,755)
-%doc README TODO
-%{perl_sitelib}/*.pm
-%{perl_sitelib}/*.pod
-%{perl_sitelib}/Bundle/*
-%{perl_sitelib}/File/*
-%{perl_sitelib}/HTML/*
-%{perl_sitelib}/HTTP/*
-%{perl_sitelib}/Net/*
-%{perl_sitelib}/LWP
-%{perl_sitelib}/WWW
+%doc README*
+%{perl_vendorlib}/*.pm
+%{perl_vendorlib}/File/*
+%{perl_vendorlib}/HTML/*
+%{perl_vendorlib}/HTTP/*
+%{perl_vendorlib}/Net/*
+%{perl_vendorlib}/LWP
+%{perl_vendorlib}/WWW/*
 %attr(755,root,root) %{_bindir}/*
 %{_mandir}/man1/*
-%{_mandir}/man3/*
+%{_mandir}/man3/[!B]*
This page took 0.110224 seconds and 4 git commands to generate.