]> git.pld-linux.org Git - packages/perl-libwww.git/blobdiff - perl-libwww.spec
- standarized Source0 URL
[packages/perl-libwww.git] / perl-libwww.spec
index 8d8921cc8c250f2b0aa622e2ec8549fca50b5897..49e98fa0c1ed58d943c7238952c864f537783c88 100644 (file)
@@ -1,51 +1,80 @@
+#
+# Conditional build:
+%bcond_with    tests   # perform "make test"
+#
+%include       /usr/lib/rpm/macros.perl
+%define                pdir    WWW
+%define                pnam    libwww-perl
+Summary:       libwww-perl - a simple and consistent API to the World-Wide Web
+Summary(pl):   libwww-perl - prosty i logiczny API do WWW
 Name:          perl-libwww
-Version:       5.44
+Version:       5.801
 Release:       1
-Vendor:                Mailing List <libwww-perl@ics.uci.edu>
-Source:         libwww-perl-%{version}.tar.gz
-#Patch:                libwww-Makefile.patch
-Group:         Utilities/Text
-Copyright:     Free
-Summary:       Perl LIBWWW module
-BuildRoot:     /tmp/%{name}-%{version}-root
-BuildRequires: perl
-%requires_eq   perl
-Requires:      perl-HTML-Parser, perl-MIME-Base64, perl-MD5, perl-libnet, perl-Data-Dumper
+# same as perl
+License:       GPL v1+ or Artistic
+Group:         Development/Languages/Perl
+Source0:       http://www.cpan.org/modules/by-module/%{pdir}/%{pnam}-%{version}.tar.gz
+# Source0-md5: eda011c6b5483d2d7443dd737cf03118
+URL:           http://search.cpan.org/dist/libwww-perl/
+BuildRequires: perl(Net::FTP) >= 2.58
+BuildRequires: perl-Digest-MD5
+BuildRequires: perl-HTML-Parser >= 3.33
+BuildRequires: perl-MIME-Base64 >= 2.1
+BuildRequires: perl-URI >= 1.10
+BuildRequires: perl-devel >= 1:5.8.0
+BuildRequires: perl-libnet
+BuildRequires: rpm-perlprov >= 4.1-13
+BuildArch:     noarch
+BuildRoot:     %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
+Obsoletes:     perl-libwww-perl
+
+# modules not always required
+%define        _noautoreq 'perl(HTML::Parse)' 'perl(HTML::FormatPS)' 'perl(HTML::FormatText)' 'perl(HTTP::GHTTP)' 'perl(IO::Socket::SSL)' 'perl(Mail::Internet)' 'perl(Authen::NTLM)'
 
 %description
-Libwww-perl is a collection of Perl modules which provides a simple
-and consistent programming interface (API) to the World-Wide Web.
+The libwww-perl collection is a set of Perl modules which provides a
+simple and consistent application programming interface to the World-Wide
+Web. The main focus of the library is to provide classes and functions
+that allow you to write WWW clients. The library also contain modules
+that are of more general use and even classes that help you implement
+simple HTTP servers.
+
+%description -l pl
+libwww-perl jest zbiorem modu³ów Perla, dostarczaj±cych prostego API
+do WWW (World-Wide Web). G³ównym zadaniem biblioteki jest udostêpnianie
+klas i funkcji, pozwalaj±cych na pisanie klientów WWW. Biblioteka zawiera
+tak¿e modu³y bardziej ogólnego przeznaczenia, a nawet klasy, pozwalaj±ce
+na implementacjê prostego serwera HTTP.
 
 %prep
 %setup -q -n libwww-perl-%{version}
 
 %build
-CFLAGS="$RPM_OPT_FLAGS" perl Makefile.PL
-#patch -p1 < %{PATCH}
-make
+%{__perl} Makefile.PL </dev/null \
+       INSTALLDIRS=vendor
+%{__make}
+
+%{?with_tests:%{__make} test}
 
 %install
 rm -rf $RPM_BUILD_ROOT
-install -d $RPM_BUILD_ROOT/%{perl_sitearch} \
-       $RPM_BUILD_ROOT{%{_mandir}/man{1,3},%{_bindir}}
-
-make install PREFIX=$RPM_BUILD_ROOT/usr \
-       INSTALLMAN3DIR=$RPM_BUILD_ROOT%{_mandir}/man3 \
-       INSTALLMAN1DIR=$RPM_BUILD_ROOT%{_mandir}/man1
 
-gzip -9nf README TODO $RPM_BUILD_ROOT%{_mandir}/man{1,3}/*
+%{__make} install \
+       DESTDIR=$RPM_BUILD_ROOT
 
 %clean
 rm -rf $RPM_BUILD_ROOT
 
 %files
-%doc README.gz TODO.gz
-%{_libdir}/perl5/site_perl/5.005/LWP.pm
-%{_libdir}/perl5/site_perl/5.005/Bundle/*.pm
-%{_libdir}/perl5/site_perl/5.005/File/*.pm
-%{_libdir}/perl5/site_perl/5.005/HTTP/*
-%{_libdir}/perl5/site_perl/5.005/LWP/*
-%{_libdir}/perl5/site_perl/5.005/WWW/*
+%defattr(644,root,root,755)
+%doc README*
+%{perl_vendorlib}/*.pm
+%{perl_vendorlib}/File/*
+%{perl_vendorlib}/HTML/*
+%{perl_vendorlib}/HTTP/*
+%{perl_vendorlib}/Net/*
+%{perl_vendorlib}/LWP
+%{perl_vendorlib}/WWW/*
 %attr(755,root,root) %{_bindir}/*
 %{_mandir}/man1/*
-%{_mandir}/man3/*
+%{_mandir}/man3/[!B]*
This page took 0.097057 seconds and 4 git commands to generate.