]> git.pld-linux.org Git - packages/perl-libwww.git/blame_incremental - perl-libwww.spec
- adapter
[packages/perl-libwww.git] / perl-libwww.spec
... / ...
CommitLineData
1#
2# Conditional build:
3%bcond_with tests # perform "make test"
4#
5%include /usr/lib/rpm/macros.perl
6%define pdir WWW
7%define pnam libwww-perl
8Summary: libwww-perl - a simple and consistent API to the World-Wide Web
9Summary(pl.UTF-8): libwww-perl - prosty i logiczny API do WWW
10Name: perl-libwww
11Version: 5.808
12Release: 1
13# same as perl
14License: GPL v1+ or Artistic
15Group: Development/Languages/Perl
16Source0: http://www.cpan.org/modules/by-module/%{pdir}/%{pnam}-%{version}.tar.gz
17# Source0-md5: 72120d9195ab1649c2d787eb1102a90c
18URL: http://search.cpan.org/dist/libwww-perl/
19BuildRequires: perl(Net::FTP) >= 2.58
20BuildRequires: perl-Digest-MD5
21BuildRequires: perl-HTML-Parser >= 3.33
22BuildRequires: perl-MIME-Base64 >= 2.1
23BuildRequires: perl-URI >= 1.10
24BuildRequires: perl-devel >= 1:5.8.0
25BuildRequires: perl-libnet
26BuildRequires: rpm-perlprov >= 4.1-13
27Obsoletes: perl-libwww-perl
28BuildArch: noarch
29BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
30
31# modules not always required
32%define _noautoreq 'perl(HTML::Parse)' 'perl(HTML::FormatPS)' 'perl(HTML::FormatText)' 'perl(HTTP::GHTTP)' 'perl(IO::Socket::SSL)' 'perl(Mail::Internet)' 'perl(Authen::NTLM)'
33
34%description
35The libwww-perl collection is a set of Perl modules which provides a
36simple and consistent application programming interface to the
37World-Wide Web. The main focus of the library is to provide classes
38and functions that allow you to write WWW clients. The library also
39contain modules that are of more general use and even classes that
40help you implement simple HTTP servers.
41
42%description -l pl.UTF-8
43libwww-perl jest zbiorem modułów Perla, dostarczających prostego API
44do WWW (World-Wide Web). Głównym zadaniem biblioteki jest
45udostępnianie klas i funkcji, pozwalających na pisanie klientów WWW.
46Biblioteka zawiera także moduły bardziej ogólnego przeznaczenia, a
47nawet klasy, pozwalające na implementację prostego serwera HTTP.
48
49%prep
50%setup -q -n libwww-perl-%{version}
51
52%build
53yes | %{__perl} Makefile.PL \
54 INSTALLDIRS=vendor
55%{__make}
56
57%{?with_tests:%{__make} test}
58
59%install
60rm -rf $RPM_BUILD_ROOT
61
62%{__make} install \
63 DESTDIR=$RPM_BUILD_ROOT
64
65for file in GET HEAD POST; do
66 ln -sf lwp-request $RPM_BUILD_ROOT%{_bindir}/$file
67 rm -f $RPM_BUILD_ROOT%{_mandir}/man1/$file.1p
68 echo '.so lwp-request.1p' > $RPM_BUILD_ROOT%{_mandir}/man1/$file.1p
69done
70
71%clean
72rm -rf $RPM_BUILD_ROOT
73
74%files
75%defattr(644,root,root,755)
76%doc README*
77%{perl_vendorlib}/*.pm
78%{perl_vendorlib}/File/*
79%{perl_vendorlib}/HTML/*
80%{perl_vendorlib}/HTTP/*
81%{perl_vendorlib}/Net/*
82%{perl_vendorlib}/LWP
83%{perl_vendorlib}/WWW/*
84%attr(755,root,root) %{_bindir}/*
85%{_mandir}/man1/*
86%{_mandir}/man3/[!B]*
This page took 0.031934 seconds and 4 git commands to generate.