]> git.pld-linux.org Git - packages/perl-libwww.git/blame_incremental - perl-libwww.spec
up to 6.49
[packages/perl-libwww.git] / perl-libwww.spec
... / ...
CommitLineData
1#
2# Conditional build:
3%bcond_with tests # perform "make test" (uses network)
4#
5%define pdir WWW
6%define pnam libwww-perl
7Summary: libwww-perl - a simple and consistent API to the World-Wide Web
8Summary(pl.UTF-8): libwww-perl - prosty i logiczny API do WWW
9Name: perl-libwww
10Version: 6.49
11Release: 1
12# same as perl
13License: GPL v1+ or Artistic
14Group: Development/Languages/Perl
15Source0: http://search.cpan.org/CPAN/authors/id/O/OA/OALDERS/%{pnam}-%{version}.tar.gz
16# Source0-md5: 86601652f46b924a26acecad0fe5c110
17URL: http://search.cpan.org/dist/libwww-perl/
18BuildRequires: perl-devel >= 1:5.8.8
19BuildRequires: rpm-perlprov >= 4.1-13
20BuildRequires: rpmbuild(macros) >= 1.663
21%if %{with tests}
22BuildRequires: perl(Net::FTP) >= 2.58
23BuildRequires: perl-Digest-MD5
24BuildRequires: perl-Encode >= 2.12
25BuildRequires: perl-Encode-Locale
26BuildRequires: perl-File-Listing >= 6
27BuildRequires: perl-HTML-Parser >= 3.33
28BuildRequires: perl-HTTP-Cookies >= 6
29BuildRequires: perl-HTTP-Daemon >= 6
30BuildRequires: perl-HTTP-Date >= 6
31BuildRequires: perl-HTTP-Message >= 6
32BuildRequires: perl-HTTP-Negotiate >= 6
33BuildRequires: perl-LWP-MediaTypes >= 6
34BuildRequires: perl-MIME-Base64 >= 2.1
35BuildRequires: perl-Net-HTTP >= 6.18
36BuildRequires: perl-Test-Needs
37BuildRequires: perl-Test-RequiresInternet
38BuildRequires: perl-Test-Simple
39BuildRequires: perl-URI >= 1.10
40BuildRequires: perl-WWW-RobotRules >= 6
41BuildRequires: perl-libnet
42%endif
43Requires: perl-File-Listing >= 6
44Requires: perl-HTTP-Cookies >= 6
45Requires: perl-HTTP-Daemon >= 6
46Requires: perl-HTTP-Date >= 6
47Requires: perl-HTTP-Message >= 6
48Requires: perl-HTTP-Negotiate >= 6
49Requires: perl-LWP-MediaTypes >= 6
50Requires: perl-MIME-Base64 >= 2.1
51Requires: perl-Net-HTTP >= 6.18
52Requires: perl-URI >= 1.10
53Requires: perl-WWW-RobotRules >= 6
54Provides: perl(LWP::Debug::TraceHTTP::Socket) = %{version}
55Provides: perl(LWP::Protocol::http::Socket) = %{version}
56Provides: perl(LWP::Protocol::http::SocketMethods) = %{version}
57Obsoletes: perl-libwww-perl
58BuildArch: noarch
59BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
60
61# modules not always required
62%define _noautoreq_perl HTTP::GHTTP Authen::NTLM
63
64%description
65The libwww-perl collection is a set of Perl modules which provides a
66simple and consistent application programming interface to the
67World-Wide Web. The main focus of the library is to provide classes
68and functions that allow you to write WWW clients. The library also
69contain modules that are of more general use and even classes that
70help you implement simple HTTP servers.
71
72%description -l pl.UTF-8
73libwww-perl jest zbiorem modułów Perla, dostarczających prostego API
74do WWW (World-Wide Web). Głównym zadaniem biblioteki jest
75udostępnianie klas i funkcji, pozwalających na pisanie klientów WWW.
76Biblioteka zawiera także moduły bardziej ogólnego przeznaczenia, a
77nawet klasy, pozwalające na implementację prostego serwera HTTP.
78
79%prep
80%setup -q -n libwww-perl-%{version}
81
82%build
83yes | %{__perl} Makefile.PL \
84 INSTALLDIRS=vendor
85%{__make}
86
87%{?with_tests:%{__make} test}
88
89%install
90rm -rf $RPM_BUILD_ROOT
91
92%{__make} pure_install \
93 DESTDIR=$RPM_BUILD_ROOT
94
95for file in GET HEAD POST; do
96 ln -sf lwp-request $RPM_BUILD_ROOT%{_bindir}/$file
97 echo '.so lwp-request.1p' > $RPM_BUILD_ROOT%{_mandir}/man1/$file.1p
98done
99%{__rm} $RPM_BUILD_ROOT%{perl_vendorlib}/libwww/*.pod
100
101%clean
102rm -rf $RPM_BUILD_ROOT
103
104%files
105%defattr(644,root,root,755)
106%doc Changes README*
107%attr(755,root,root) %{_bindir}/GET
108%attr(755,root,root) %{_bindir}/HEAD
109%attr(755,root,root) %{_bindir}/POST
110%attr(755,root,root) %{_bindir}/lwp-*
111%{perl_vendorlib}/LWP.pm
112%{perl_vendorlib}/LWP/Authen
113%{perl_vendorlib}/LWP/ConnCache.pm
114%{perl_vendorlib}/LWP/Debug.pm
115%dir %{perl_vendorlib}/LWP/Debug
116%{perl_vendorlib}/LWP/Debug/TraceHTTP.pm
117%{perl_vendorlib}/LWP/DebugFile.pm
118%{perl_vendorlib}/LWP/MemberMixin.pm
119%{perl_vendorlib}/LWP/Protocol.pm
120%{perl_vendorlib}/LWP/Protocol
121%{perl_vendorlib}/LWP/RobotUA.pm
122%{perl_vendorlib}/LWP/Simple.pm
123%{perl_vendorlib}/LWP/UserAgent.pm
124%{_mandir}/man1/GET.1p*
125%{_mandir}/man1/HEAD.1p*
126%{_mandir}/man1/POST.1p*
127%{_mandir}/man1/lwp-*.1p*
128%{_mandir}/man3/LWP*.3pm*
129%{_mandir}/man3/libwww::lwpcook.3pm*
130%{_mandir}/man3/libwww::lwptut.3pm*
This page took 0.031581 seconds and 4 git commands to generate.