]> git.pld-linux.org Git - packages/perl-ldap.git/blobdiff - perl-ldap.spec
- drop obsolete and outdated manual inclusion of rpm macros
[packages/perl-ldap.git] / perl-ldap.spec
index 0334c90ea8a12c5efae5920eeb02e9d031425064..6904bedbb1ad7ee48b6f1e031d58d34218153d7e 100644 (file)
@@ -1,73 +1,92 @@
 #
 # Conditional build:
-# _without_tests - do not perform "make test"
+%bcond_with    tests   # perform "make test" (requires working ldap server and gnupg configured with key retrieval with hkp)
 #
-%include       /usr/lib/rpm/macros.perl
-Summary:       perl-ldap Perl module
-Summary(pl):   Modu³ perla Perl-ldap
+Summary:       perl-ldap module - a client interface to LDAP servers
+Summary(pl.UTF-8):     Moduł perl-ldap - kliencki interfejs do serwerów LDAP
 Name:          perl-ldap
-Version:       0.2701
-Release:       3
-Epoch:         1
-License:       GPL
+Version:       0.57
+Release:       1
+Epoch:         3
+# same as perl
+License:       GPL v1+ or Artistic
 Group:         Development/Languages/Perl
 Source0:       http://www.cpan.org/modules/by-module/Net/%{name}-%{version}.tar.gz
-# Source0-md5: fd3cd83810bb3163e47dedd34277da76
+# Source0-md5: deff50f0de5d4cf95145765b6edd67d1
+Patch0:                non-unicode-dump.patch
+Patch1:                ignore-uninitialized.patch
+URL:           http://ldap.perl.org/
 BuildRequires: perl-Authen-SASL >= 2.00
-BuildRequires: perl-Convert-ASN1 >= 0.07
-BuildRequires: perl-Digest-HMAC
+BuildRequires: perl-Convert-ASN1 >= 0.20
 BuildRequires: perl-Digest-MD5
-BuildRequires: perl-IO-Socket-SSL
+BuildRequires: perl-IO-Socket-INET6
+BuildRequires: perl-IO-Socket-SSL >= 1.26
+BuildRequires: perl-JSON
 BuildRequires: perl-MIME-Base64
-BuildRequires: perl-URI >= 1.08
-BuildRequires: perl-XML-Parser
-BuildRequires: perl-devel >= 5.6.1
-BuildRequires: perl-libwww
+BuildRequires: perl-URI >= 1.1
+BuildRequires: perl-XML-SAX-Writer
+BuildRequires: perl-devel >= 1:5.18.0
 BuildRequires: rpm-perlprov >= 4.1-13
+%if %{with tests}
+BuildRequires: perl-Module-Signature
+BuildRequires: perl-Test-Simple
+BuildRequires: perl-libwww
+%endif
+Obsoletes:     perl-LDAP
 BuildArch:     noarch
 BuildRoot:     %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
 
-%define                _noautoreq 'perl(Convert::ASN1::Debug)'
-
 %description
 perl-ldap is a collection of modules that implements a LDAP services
 API for Perl programs.
 
-%description -l pl
-perl-ldap jest kolekcj± modu³ów umo¿liwiaj±cych dostêp do us³ug LDAP z
-poziomu programów perla.
+%description -l pl.UTF-8
+perl-ldap to zestaw modułów umożliwiających dostęp do usług LDAP z
+poziomu programów w Perlu.
 
 %prep
-%setup -q -n perl-ldap-%{version}
-find . -type f | xargs -r perl -pi -e 's|/local/bin/perl\d*|/bin/perl|g'
+%setup -q
+%patch0 -p1
+%patch1 -p1
 
 %build
 %{__perl} Makefile.PL \
        INSTALLDIRS=vendor
 %{__make}
-%{!?_without_tests:%{__make} test}
+
+%{?with_tests:%{__make} test}
+
+# this must be done after tests because of signature checking
+find blib -type f | xargs -r perl -pi -e 's|/local/bin/perl\d*|/bin/perl|g'
 
 %install
 rm -rf $RPM_BUILD_ROOT
 install -d $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
 
-%{__make} install \
+%{__make} pure_install \
        DESTDIR=$RPM_BUILD_ROOT
-
 cp -r {contrib,bin} $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
 
+%{__rm} $RPM_BUILD_ROOT%{_mandir}/man3/Bundle::Net::LDAP.3pm
+%{__rm} $RPM_BUILD_ROOT%{perl_vendorlib}/{Bundle/Net/LDAP.pm,Net/{,LDAP/}*.pod}
+rm -f $RPM_BUILD_ROOT%{perl_vendorarch}/auto/Net/LDAP/.packlist
+
 %clean
 rm -rf $RPM_BUILD_ROOT
 
 %files
 %defattr(644,root,root,755)
-%doc ChangeLog README TODO
+%doc CREDITS Changes README TODO
 %{perl_vendorlib}/LWP/Protocol/ldap.pm
-%{perl_vendorlib}/Net/LDAP.pm
+%{perl_vendorlib}/LWP/Protocol/ldapi.pm
+%{perl_vendorlib}/LWP/Protocol/ldaps.pm
+%{perl_vendorlib}/Net/LDAP*.pm
 %dir %{perl_vendorlib}/Net/LDAP
 %{perl_vendorlib}/Net/LDAP/*.pm
 %{perl_vendorlib}/Net/LDAP/Control
 %{perl_vendorlib}/Net/LDAP/Extension
-%{perl_vendorlib}/Net/LDAPS.pm
+%{perl_vendorlib}/Net/LDAP/Extra
+%{perl_vendorlib}/Net/LDAP/Intermediate
+%{_mandir}/man3/LWP::Protocol::ldap*
 %{_mandir}/man3/N*
 %{_examplesdir}/%{name}-%{version}
This page took 0.034194 seconds and 4 git commands to generate.