]> git.pld-linux.org Git - packages/perl-enum.git/blobdiff - perl-enum.spec
- drop obsolete and outdated manual inclusion of rpm macros
[packages/perl-enum.git] / perl-enum.spec
index 3addecd322b9ce0505b1b150e311aadc51aa463b..ea1ba29c3d34f6e0ba939802e9091b24309f4eef 100644 (file)
@@ -1,31 +1,21 @@
-%include       /usr/lib/rpm/macros.perl
-%define                pdir    enum
+#
+# Conditional build:
+%bcond_without tests   # do not perform "make test"
+
 %define                pnam    enum
-Summary:       enum Perl module
-Summary(cs):   Modul enum pro Perl
-Summary(da):   Perlmodul enum
-Summary(de):   enum Perl Modul
-Summary(es):   Módulo de Perl enum
-Summary(fr):   Module Perl enum
-Summary(it):   Modulo di Perl enum
-Summary(ja):   enum Perl ¥â¥¸¥å¡¼¥ë
-Summary(ko):   enum ÆÞ ¸ðÁÙ
-Summary(no):   Perlmodul enum
-Summary(pl):   Modu³ perla enum
-Summary(pt_BR):        Módulo Perl enum
-Summary(pt):   Módulo de Perl enum
-Summary(ru):   íÏÄÕÌØ ÄÌÑ Perl enum
-Summary(sv):   enum Perlmodul
-Summary(uk):   íÏÄÕÌØ ÄÌÑ Perl enum
-Summary(zh_CN):        enum Perl Ä£¿é
+Summary:       enum - C style enumerated types and bitmask flags in Perl
+Summary(pl.UTF-8):     enum - typy wyliczeniowe w stylu C i znaczniki bitowe dla Perla
 Name:          perl-enum
 Version:       1.016
-Release:       1
-License:       ?
+Release:       5
+# same as perl
+License:       GPL v1+ or Artistic
 Group:         Development/Languages/Perl
-Source0:       ftp://ftp.cpan.org/pub/CPAN/modules/by-module/%{pdir}/%{pnam}-%{version}.tar.gz
-BuildRequires: rpm-perlprov >= 3.0.3-16
-BuildRequires: perl >= 5.6
+Source0:       http://www.cpan.org/modules/by-module/%{pnam}/%{pnam}-%{version}.tar.gz
+# Source0-md5: aace7ee8648e5d20c0e81f5a51cb6604
+URL:           http://search.cpan.org/dist/enum/
+BuildRequires: perl-devel >= 1:5.8.0
+BuildRequires: rpm-perlprov >= 4.1-13
 BuildArch:     noarch
 BuildRoot:     %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
 
@@ -33,21 +23,25 @@ BuildRoot:  %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
 enum defines a set of symbolic constants with ordered numeric values
 ala C enum types.
 
-%description -l pl
-enum definiuje zestaw sta³ych symbolicznych o uporz±dkowanych
-warto¶ciach numerycznych, podobnie do typów enum w C.
+%description -l pl.UTF-8
+enum definiuje zestaw stałych symbolicznych o uporządkowanych
+wartościach numerycznych, podobnie do typów enum w C.
 
 %prep
 %setup -q -n %{pnam}-%{version}
 
 %build
-perl Makefile.PL
+%{__perl} Makefile.PL \
+       INSTALLDIRS=vendor
 %{__make}
 
+%{?with_tests:%{__make} test}
+
 %install
 rm -rf $RPM_BUILD_ROOT
 
-%{__make} install DESTDIR=$RPM_BUILD_ROOT
+%{__make} install \
+       DESTDIR=$RPM_BUILD_ROOT
 
 %clean
 rm -rf $RPM_BUILD_ROOT
@@ -55,5 +49,5 @@ rm -rf $RPM_BUILD_ROOT
 %files
 %defattr(644,root,root,755)
 %doc Changes README
-%{perl_sitelib}/enum.pm
+%{perl_vendorlib}/enum.pm
 %{_mandir}/man3/*
This page took 0.085419 seconds and 4 git commands to generate.