]> git.pld-linux.org Git - packages/perl-asa.git/blame - perl-asa.spec
- initial
[packages/perl-asa.git] / perl-asa.spec
CommitLineData
a68f2a62
AM
1#
2# Conditional build:
3%bcond_without tests # do not perform "make test"
4#
5%define pdir asa
6Summary: asa - Lets your class/object say it works like something else
7Name: perl-asa
8Version: 1.04
9Release: 1
10License: GPL v1+ or Artistic
11Group: Development/Languages/Perl
12Source0: http://www.cpan.org/modules/by-authors/id/E/ET/ETHER/asa-%{version}.tar.gz
13# Source0-md5: cbe6d1db505eb4eaa2bf35a637fc0451
14URL: https://metacpan.org/release/asa
15BuildRequires: perl-devel >= 1:5.8.0
16BuildRequires: rpm-perlprov >= 4.1-13
17BuildRequires: rpmbuild(macros) >= 1.745
18%if %{with tests}
19%endif
20BuildArch: noarch
21BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
22
23%description
24Perl 5 doesn't natively support Java-style interfaces, and it doesn't
25support Perl 6 style roles either.
26
27You can get both of these things in half a dozen different ways via
28various CPAN modules, but they usually require that you buy into
29"their way" of implementing your code.
30
31Other have turned to "duck typing".
32
33This is, for the most part, a fairly naive check that says "can you do
34this method", under the "if it looks like a duck, and quacks like a
35duck, then it must be a duck".
36
37It assumes that if you have a ->quack method, then they will treat you
38as a duck, because doing things like adding Duck to your @ISA array
39means you are also forced to take their implementation.
40
41%prep
42%setup -q -n %{pdir}-%{version}
43
44%build
45%{__perl} Makefile.PL \
46 INSTALLDIRS=vendor
47%{__make}
48
49%{?with_tests:%{__make} test}
50
51%install
52rm -rf $RPM_BUILD_ROOT
53
54%{__make} pure_install \
55 DESTDIR=$RPM_BUILD_ROOT
56
57%clean
58rm -rf $RPM_BUILD_ROOT
59
60%files
61%defattr(644,root,root,755)
62%doc Changes INSTALL README
63%{perl_vendorlib}/asa.pm
64%{_mandir}/man3/asa.3*
This page took 0.089526 seconds and 4 git commands to generate.