]> git.pld-linux.org Git - packages/perl-XML-SAX-Expat.git/blobdiff - perl-XML-SAX-Expat.spec
- drop obsolete and outdated manual inclusion of rpm macros
[packages/perl-XML-SAX-Expat.git] / perl-XML-SAX-Expat.spec
index da1068c2141c5cba446bd55aecd2955894509287..5b7bc313322e7c2236d8c719f45cbfa9ae54fd4d 100644 (file)
@@ -1,26 +1,28 @@
 #
 # Conditional build:
 %bcond_without tests   # do not perform "make test"
-#
-%include       /usr/lib/rpm/macros.perl
-%define        pdir    XML
-%define        pnam    SAX-Expat
+
+%define                pdir    XML
+%define                pnam    SAX-Expat
 Summary:       XML::SAX::Expat - SAX2 driver for Expat (XML::Parser)
-Summary(pl):   XML::SAX::Expat - sterownik SAX2 dla modu³u Expat (XML::Parser)
+Summary(pl.UTF-8):     XML::SAX::Expat - sterownik SAX2 dla modułu Expat (XML::Parser)
 Name:          perl-XML-SAX-Expat
-Version:       0.37
-Release:       1
+Version:       0.51
+Release:       2
 # same as perl
-License:       GPL or Artistic
+License:       GPL v1+ or Artistic
 Group:         Development/Languages/Perl
-Source0:       http://www.cpan.org/modules/by-module/%{pdir}/%{pdir}-%{pnam}-%{version}.tar.gz
-# Source0-md5: c48024d363a1ff9abaf8f9af592d38cd
+Source0:       http://www.cpan.org/modules/by-module/XML/%{pdir}-%{pnam}-%{version}.tar.gz
+# Source0-md5: 74c540095d84e3f054d1f8703a73ef76
+URL:           http://search.cpan.org/dist/XML-SAX-Expat/
+BuildRequires: perl(XML::SAX::Base) >= 1.00
 BuildRequires: perl-XML-NamespaceSupport >= 0.03
 BuildRequires: perl-XML-Parser >= 2.27
 BuildRequires: perl-XML-SAX >= 0.03
-BuildRequires: perl(XML::SAX::Base) >= 1.00
 BuildRequires: perl-devel >= 1:5.8.0
 BuildRequires: rpm-perlprov >= 4.1-13
+BuildRequires: sed >= 4.0
+Requires:      perl-XML-SAX >= 0.03
 BuildArch:     noarch
 BuildRoot:     %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
 
@@ -28,21 +30,19 @@ BuildRoot:  %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
 This is an implementation of a SAX2 driver sitting on top of Expat
 (XML::Parser).
 
-%description -l pl
-To jest implementacja sterownika SAX2 w oparciu o modu³ Expat
+%description -l pl.UTF-8
+To jest implementacja sterownika SAX2 w oparciu o moduł Expat
 (XML::Parser).
 
 %prep
 %setup -q -n %{pdir}-%{pnam}-%{version}
 
 # we want to add_parser in post, not on make install
-head -n 16 Makefile.PL > Makefile.PL.tmp
-mv -f Makefile.PL.tmp Makefile.PL
+%{__sed} -i -e '/^sub MY::install/,/^}/ s/^/#/' Makefile.PL
 
 %build
 %{__perl} Makefile.PL \
        INSTALLDIRS=vendor
-
 %{__make}
 
 %{?with_tests:%{__make} test}
@@ -61,7 +61,7 @@ umask 022
 %{__perl} -MXML::SAX -e "XML::SAX->add_parser(q(XML::SAX::Expat))->save_parsers()"
 
 %postun
-if [ "$1" = "0" ]; then
+if [ "$1" = "0" ] && [ -x %{__perl} ]; then
        umask 022
        %{__perl} -MXML::SAX -e "XML::SAX->remove_parser(q(XML::SAX::Expat))->save_parsers()"
 fi
@@ -70,4 +70,4 @@ fi
 %defattr(644,root,root,755)
 %doc Changes
 %{perl_vendorlib}/XML/SAX/Expat.pm
-%{_mandir}/man3/*
+%{_mandir}/man3/XML::SAX::Expat.3pm*
This page took 0.064991 seconds and 4 git commands to generate.