]> git.pld-linux.org Git - packages/perl-XML-LibXML.git/blame - perl-XML-LibXML.spec
- added O: perl-XML-LibXML-Common
[packages/perl-XML-LibXML.git] / perl-XML-LibXML.spec
CommitLineData
c3053b4d 1#
2# Conditional build:
d2bc690b 3%bcond_without tests # do not perform "make test"
c3053b4d 4#
93b10e78 5%include /usr/lib/rpm/macros.perl
9a0b3960 6%define pdir XML
7%define pnam LibXML
5b1cc450 8Summary: XML::LibXML - interface to the GNOME libxml2 library
ae85d059 9Summary(pl.UTF-8): XML::LibXML - interfejs do biblioteki libxml2 z GNOME
70aff09e 10Name: perl-XML-LibXML
f2f14532 11Version: 1.70
8f080126 12Release: 2
35b66355 13# same as perl
d2bc690b 14License: GPL v1+ or Artistic
93b10e78 15Group: Development/Languages/Perl
e9816160 16Source0: http://www.cpan.org/modules/by-module/XML/%{pdir}-%{pnam}-%{version}.tar.gz
f2f14532 17# Source0-md5: 33d4294f708e20c298cfe534d1166844
5c9eff29 18URL: http://search.cpan.org/dist/XML-LibXML/
35b66355 19BuildRequires: gdome2-devel >= 0.7.3
46f69d6d 20BuildRequires: libxml2-devel >= 2.5.10
88362b24 21BuildRequires: perl-XML-LibXML-Common
0042f58e 22BuildRequires: perl-XML-NamespaceSupport >= 1.07
c3053b4d 23BuildRequires: perl-XML-SAX >= 0.11
46f69d6d 24BuildRequires: perl-devel >= 1:5.8.0
e086ce6b 25BuildRequires: pkgconfig
38915a66 26BuildRequires: rpm-perlprov >= 4.1-13
46f69d6d 27Requires: libxml2 >= 2.5.10
7a25fbd0 28Provides: perl-XML-LibXML-XPathContext = %{version}
29Obsoletes: perl-XML-LibXML-XPathContext <= 0:0.07
8f080126 30Obsoletes: perl-XML-LibXML-Common
88362b24 31BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
93b10e78 32
33%description
25829699 34This module implements much of the DOM Level 2 API as an interface to
a559f02a 35the GNOME libxml2 library. This makes it a fast and highly capable
25829699
JB
36validating XML parser library, as well as a high performance DOM.
37
89406f45
JR
38%description -l pl.UTF-8
39Ten moduł to implementacja większości API DOM Level 2 jako interfejsu
40do biblioteki GNOME libxml2. Daje to szybki i o dużych możliwościach
41parser sprawdzający poprawność XML-a, a także wysoko wydajny DOM.
93b10e78 42
43%package SAX
46f69d6d 44Summary: XML::LibXML::SAX Perl module - XML::LibXML direct SAX parser
ae85d059 45Summary(pl.UTF-8): Moduł Perla XML::LibXML::SAX - bezpośredni parser SAX z XML::LibXML
93b10e78 46Group: Development/Languages/Perl
3f1d5dc1 47Requires: %{name} = %{version}-%{release}
93b10e78 48
49%description SAX
25829699 50This class allows you to generate SAX2 events using LibXML. Note that
64c92586 51this is not a stream based parser, instead it parses documents into a
52DOM and traverses the DOM tree. The reason being that libxml2's stream
53based parsing is extremely primitive, and would require an extreme
54amount of work to allow SAX2 parsing in a stream manner.
25829699 55
89406f45
JR
56%description SAX -l pl.UTF-8
57Ta klasa pozwala generować zdarzenia SAX2 przy użyciu LibXML2. To nie
58jest parser bazujący na strumieniach - przetwarza dokumenty na DOM i
59następnie wędruje po drzewie DOM. Wynika to z faktu, że w libxml2
60parsowanie oparte na strumieniach jest bardzo prymitywne i wymagałoby
61wiele pracy, aby umożliwić strumieniowe parsowanie SAX2.
93b10e78 62
63%prep
e9816160 64%setup -q -n %{pdir}-%{pnam}-%{version}
93b10e78 65
66%build
0de22b55
AG
67SKIP_SAX_INSTALL=true;
68export SKIP_SAX_INSTALL
d7823dc1 69
38915a66 70%{__perl} Makefile.PL \
64a03af0 71 INSTALLDIRS=vendor
e086ce6b 72%{__make} \
f3dbed48 73 CC="%{__cc}" \
e086ce6b 74 OPTIMIZE="%{rpmcflags}"
93b10e78 75
46f69d6d 76%{?with_tests:%{__make} test}
c3053b4d 77
93b10e78 78%install
79rm -rf $RPM_BUILD_ROOT
80install -d $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
81
e086ce6b
JB
82%{__make} install \
83 DESTDIR=$RPM_BUILD_ROOT
93b10e78 84install example/{*.pl,*.xml,*.dtd,*.xhtml} $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
85
86install -d $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}/complex
87install example/complex/{*.xml,*.dtd} $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}/complex
88
89install -d $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}/complex/dtd
90install example/complex/dtd/*.dtd $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}/complex/dtd
91
88362b24
JB
92%clean
93rm -rf $RPM_BUILD_ROOT
d238a71d 94
93b10e78 95%post SAX
4538f7d7 96umask 022
35b66355 97%{__perl} -MXML::SAX -e "XML::SAX->add_parser(q(XML::LibXML::SAX::Parser))->save_parsers()"
93b10e78 98
99%preun SAX
05892067
JB
100if [ "$1" = "0" ]; then
101 umask 022
102 %{__perl} -MXML::SAX -e "XML::SAX->remove_parser(q(XML::LibXML::SAX::Parser))->save_parsers()"
103fi
93b10e78 104
93b10e78 105%files
106%defattr(644,root,root,755)
c3053b4d 107%doc Changes README
38915a66 108%{perl_vendorarch}/XML/LibXML.pm
e086ce6b 109%{perl_vendorarch}/XML/LibXML/[!S]*.pm
38915a66 110%{perl_vendorarch}/auto/XML/LibXML/LibXML.bs
111%attr(755,root,root) %{perl_vendorarch}/auto/XML/LibXML/LibXML.so
13a12d43 112%{_mandir}/man3/XML::LibXML.3pm*
e086ce6b 113%{_mandir}/man3/XML::LibXML::[!S]*
1968b26e 114%{_mandir}/man3/XML::LibXML::S[!A]*
c3053b4d 115%dir %{_examplesdir}/%{name}-%{version}
116%attr(755,root,root) %{_examplesdir}/%{name}-%{version}/x*.pl
e086ce6b 117%{_examplesdir}/%{name}-%{version}/[!x]*
93b10e78 118
119%files SAX
120%defattr(644,root,root,755)
38915a66 121%dir %{perl_vendorarch}/XML/LibXML/SAX
122%{perl_vendorarch}/XML/LibXML/SAX.pm
123%{perl_vendorarch}/XML/LibXML/SAX/*.pm
0042f58e 124%{_mandir}/man3/XML::LibXML::SAX.3pm*
93b10e78 125%{_mandir}/man3/XML::LibXML::SAX::*
This page took 0.094397 seconds and 4 git commands to generate.